Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke

GELÖST

VLAN wechsel, alte IP bleibt bestehen

Mitglied: Steger

Steger (Level 1) - Jetzt verbinden

20.10.2009, aktualisiert 13:58 Uhr, 5360 Aufrufe, 9 Kommentare

Bei dem Wechsel des VLAN bleibt die alte IP bestehen

Hallo Leute,
Bei dem Wechsel des VLAN bleibt die alte IP bestehen. könnte mir jemand Helfen?

Cisco Switch
WinServer 2003
-- DHCP mit 2 adress bereichen
-- DNS
Clients: Win XP Prof.


bin für jede Antwort dankbar!

mfg Steger
Mitglied: aqui
20.10.2009 um 13:56 Uhr
Äääähhhh, wo ist denn nun dein Problem ??? Bzw. WAS, bitte sehr, soll uns dieser Thread sagen...??

VLAN ID wechseln im Switch und das wars !!
Wenn die IP gleich bleibt musst du gar nix ändern ?! Was soll diese Frage ?
Bitte warten ..
Mitglied: Steger
20.10.2009 um 14:03 Uhr
also wenn ich mit einem client das VLAN netz wechsel will, bleibt die alte IP bestehen, also ich habe immer noch die Adresse vom anderen netz, die mir der DHCP zugewiesen hat.
Bitte warten ..
Mitglied: dog
20.10.2009 um 14:14 Uhr
Ja nu, das ist ja auch normal. Stichwort: DHCP Lease Time.

Du musst erst die IP-Konfig lösen, damit er sich eine neue IP holt:

01.
ipconfig /release 
02.
ipconfig /renew
Bitte warten ..
Mitglied: aqui
20.10.2009 um 14:16 Uhr
Das ist kinderleicht zu machen...
Ein Client kann das VLAN nur wechseln wenn du das Kabel von diesem Client am Switch in einen anderen Port steckst der diesem neuen VLAN dann zugeordnet ist oder eine dynamische VLAN Zuweisung mit 802.1x machst !!
Wenn dieses VLAN ein anderes IP Netz hat und der Server dafür weiterhin DHCP IP Adressen vergeben soll musst du dem Server dann entsprechend diese Netzwerk im DHCP Server konfigurieren und einen UDP Forwarder im Switch eintragen sofern der Switch routet !
Beispiel (Annahme Server IP 172.16.10.100, neues VLAN 20 172.16.20.0 /24:

Cisco_Switch#
clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Enduser Ports in VLAN 10 (Server)
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/2
description Enduser Ports in VLAN 20 (Client neues VLAN)
switchport access vlan 10
spanning-tree portfast
!
interface Vlan10
ip address 172.16.10.254 255.255.255.0
no ip route-cache
!
interface Vlan20
ip address 172.16.20.254 255.255.255.0
ip helper-addres 172.16.10.100
no ip route-cache


Das wars...!!
Der DHCP Server im Server muss natürlich das 172.16.20.0er Netz (neues VLAN) eingetragen haben, Maske 255.255.255.0, Gateway 172.16.20.254 (Switch IP) und als DNS Server die IP des DNS (Vermutlich dein Server also 172.16.10.100) für die Clients !

Theoretisch kann man auch den Switch DHCP Server spielen lassen für das (neue) VLAN 20 aber das ist Blödsinn, denn so hättest du 2 verschiedene DHCP Server.
Logischerweise technisch besser ist natürlich die zentrale DHCP Lösung zentral auf dem Server !!
Bitte warten ..
Mitglied: Steger
20.10.2009 um 14:16 Uhr
ja das schon, aber sollte sich idealerweise automatisch beim wechsel des VLAN eine neue adresse vom DHCP holen
Bitte warten ..
Mitglied: Steger
20.10.2009 um 14:54 Uhr
Vielen Dank bis dahin, ich werde es mal ausprobieren.

Wer sonst irgendeine Idee hat, bitte posted mir weiter!
Bitte warten ..
Mitglied: aqui
20.10.2009 um 16:16 Uhr
Du bist witzig...die Cisco Konfig ist dir so vorgegeben...da gibt es keinerlei "andere Ideen"...für eine Lösung !

Kannst aber beruhigt sein, das obige ist millionenfach weltweit im Einsatz und wird sicher funktionieren !
Bitte warten ..
Mitglied: Steger
21.10.2009 um 14:43 Uhr
Bitte warten ..
Mitglied: aqui
21.10.2009 um 22:52 Uhr
Wenns das war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Leeres Fenster bleibt bestehen
Frage von Ghost108Microsoft Office1 Kommentar

Hallo zusammen, ich habe folgende "Problematik" Ich öffnen Excel 2016 und erhalte eine leere Arbeitsmappe Hier gehe ich nun ...

Microsoft
IP geändert DNS Eintrag bleibt alte IP
gelöst Frage von buserverMicrosoft12 Kommentare

Hallo, ich habe bei meinem 2008r2 DataCenter DC die IP-Adressen von 192.168.2.14 und 192.168.2.15 auf die IP-Adressen 192.168.2.20 und ...

Suse
Druckjob unter Suse-LInux bleibt bestehen
Frage von didi60Suse

Guten Tag zusammen, das Ziel ist über Linux raw-Daten an Drucker zu senden. Im Moment existieren 2 Drucker, die ...

PHP
Logout auf Website - Sessoin bleibt bestehen
Frage von IT-CallePHP4 Kommentare

Hallo, ich habe ein Problem, das wiefolgt aussieht. Ich logge mich ganz normal auf einer Website ein (Lokal mit ...

Neue Wissensbeiträge
Router & Routing

PfSense als Addon auf QNAP

Information von magicteddy vor 8 StundenRouter & Routing2 Kommentare

Moin, für Spielereien eine ganz nette Idee aber ich fürchte das soetwas auch als echte Firewall genutzt wird: In ...

Datenschutz

Teamviewer kommt für IoT-Geräte wie den Raspberry Pi

Information von magicteddy vor 15 StundenDatenschutz

Moin, jetzt werden IoT Geräte endgültig zur Wanze? Anscheinend kann man auf einem Dashboard seine Geräte visualisieren Ich stelle ...

Microsoft

Letzte Updates für Win10 und Server2016 müssen bei Bedarf über den Update catalogue in den WSUS importiert werden!

Tipp von DerWoWusste vor 19 StundenMicrosoft1 Kommentar

automatisch kommt da nichts an im WSUS und auch nicht im SCCM. Siehe Hinweise zum Bezug der jeweils neuesten ...

Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 3 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Preis für Wartungsvertrag ok?
gelöst Frage von a-za-zNetzwerkmanagement22 Kommentare

Hallo! Mal ne Frage, weil ich mich mit dem akzeptablen Preis für einen Reaktionszeitvertrag nicht auskenne. Meine Firma hat ...

Windows Netzwerk
Ist ein Portforwarding auf einen PC ohne lauschendes Programm ein (großes) Sicherheitsproblem?
Frage von PluwimWindows Netzwerk13 Kommentare

Hallo zusammen, zur Fernwartung eines Rechners an einem anderen Ort nutze ich VNC. Da dieser Rechner einfach nur eine ...

Windows Server
Terminal Server 2016 erkennt Berechtigungen nicht
gelöst Frage von Thomas2Windows Server10 Kommentare

Hallo Administratoren, folgendes Problem stellt sich dar: Es gibt zwei Windows Server 2016, die als Terminal Server fungieren. Jetzt ...

Sonstige Systeme
7-zip: Programm frägt nach Passwort erst bei einzelnen Dateien
Frage von freeskierchrisSonstige Systeme7 Kommentare

Guten Morgen, ich habe ein Problem beim Arbeiten mit 7-zip: Wenn ich die einzelnen Dateien zu einem Archiv verpacke ...