Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Vollaufender Systemcache bei Netzwerkzugriff

Frage Microsoft Windows Server

Mitglied: UHAG

UHAG (Level 1) - Jetzt verbinden

07.04.2010, aktualisiert 21:44 Uhr, 6562 Aufrufe, 7 Kommentare

Hallo,

habe seit einiger Zeit das Problem, das bei einem unserer Server bei Netzzugriff über eine Windowsfreigabe der Systemcache vergrößert, damit der frei verfügbare RAM sinkt, bis auf 0. Alle anderen Prozesse werden dadurch natürlich "weggedrückt". Vor allem die VMs die auf der Maschine mitlaufen müssen nach dem Kopieren sehr viel von der Platte nachladen, weil aller RAM in den Systemcache fließt. Das Problem tritt sowohl vom RAID als auch von HDDS auf die direkt auf dem Board angeschlossen sind.
Da wir oft sehr große Bilddateien vom Server kopieren wird dieser oft beansprucht und ist beim Kopieren nicht mehr bedient bar. Ich würde nun gerne wissen wie das ganz technisch funktioniert um den Fehler einkreisen zu können. Anbei eine Abbildung der Speicherhistorie vom ProcessMonitor. Wäre für jeden Hinweis dankbar weil ich wie gesagt nicht mehr so richtig weiß wie ich diesem Problem begegnen soll. Anbei noch meine Systemdaten. Falls ihr noch mehr Infos braucht, reagiere ich zeitnah.

HW:
RAM: 4GB
RAID: Adaptec RAID SAS/SATA mit RAID 5
NIC: Intel 1000PT

SW:
MS Windows 2003 x64 Ent.
VMWare Server 1.0.9
Updates aktuell

Vielen Dank für eure Bemühungen
Viele Grüße

Speicherhistorie beim Kopiervorgang (ca. 10GB pro Datei)
27ef0be0b25a8947a2e72b9d64a5b394 - Klicke auf das Bild, um es zu vergrößern
Mitglied: MausBanderS
07.04.2010 um 22:15 Uhr
Heho...

AFAIR ist die Einstellung unter Systemsteuerung->System->Erweitert->Einstellungen von Systemleistung->Erweitert->Speichernutzung Programme/Systemcache dafür verantwortlich. Die Einstellung Systemcahce sorgt für die Verwendung des gesamten Arbeitsspeichers als
Cache, was Deine Probleme verursacht.

Allerdings schlage ich vor, Du beäugst Cacheset.exe aus der SysinternalsSuite einmal näher.

HTH,

Gruß Martin
Bitte warten ..
Mitglied: maretz
07.04.2010 um 22:25 Uhr
Moin,

lagert der Server denn definitiv nur noch aus?

a) Bei VMs passiert es auch häufig das er auf die Festplatte zugreifft da er den RAM der VM ja auch als Datei auf der Festplatte hat (z.B. Suspend-To-Ram-Funktion) .

b) Sollte er nur den freien RAM bis auf 0 runterfahren und die Swap-File nur wenig nutzen dann ist das auch kein Problem sondern etwas vorteilhaftes. Ich vergleiche das mal mit dem Motorrad von mir: Ich habe 4 Zylinder a 250ccm. Ich möchte auch bitte das alle 4 genutzt werden - und nicht das ich mit 3 Zylindern fahre damit ich den 4ten in Reserve habe! Beim PC möchte ich auch das mein RAM genutzt wird - sonst hätte ich den nicht gebraucht und es wäre Geldverschwendung! Und jedes bisschen nicht-genutzter RAM darf gern als File-Cache verwendet werden... (Das ist übrigens bei Linux schon lange üblich - unser Webserver in der Firma hat 8 GB RAM und davon sind ca. 7 GB als Filecache genutzt... - aber der Hoster hat die dinger halt alle mit 8 GB ausgestattet....). Wenn ich ehrlich bin: Von mir aus darf der sogar noch den Grafik-RAM als Filecache mitnutzen - mir doch egal, Bunte Bilder will ich nicht aber wenn ne Datei aus dem RAM kommt ist das locker um eine größenordnung (ns statt ms bzw. GB/s statt MB/s) schneller als die Festplatte...
Bitte warten ..
Mitglied: UHAG
07.04.2010 um 22:46 Uhr
lagert der Server denn definitiv nur noch aus?

Definitiv ja!
Habe jetzt nochmal alles was Prozesse sind aus gemacht. VMWare ... usw.
Auch mal die Option Systemsteuerung->System->Erweitert->Einstellungen von Systemleistung->Erweitert->Speichernutzung auf Programme gesetzt.
Keine Verbesserung. Magerer Speed von den Platten die direkt am Board sind ca. 20MB/s. Vom RAID nur 50MB/s.
Bitte warten ..
Mitglied: filippg
08.04.2010 um 04:16 Uhr
Hallo,

wir hatten schon gelegentlich Ärger mit RAM durch das Scalable Networking Pack (TCP Offloading/TCP Chimney). Würde dir raten, das mal (testweise) zu deaktivieren.

Gruß

Filipp
Bitte warten ..
Mitglied: UHAG
15.04.2010 um 20:55 Uhr
Problem gelöst.

http://www.ghisler.ch/board/viewtopic.php?p=171529

Lag an unserem Dateimanager. Wenn mit Windows Explorer kopiert wird gibt es keine Problem.

Danke für eure Hilfe
Bitte warten ..
Mitglied: filippg
15.04.2010 um 21:21 Uhr
Hallo,

von wo nach wo wird kopiert? Du führst auf dem Client TC aus, und auf dem Server steigt der Speicherverbrauch?

Gruß

Filipp
Bitte warten ..
Mitglied: UHAG
13.05.2010 um 11:12 Uhr
Jupp, genau so war es. Auf den Windows 7 Clienten läuft der Total Commander als FileManager.
Bitte warten ..
Ähnliche Inhalte
Windows 7
Absturz bei Netzwerkzugriff
gelöst Frage von hotrockinWindows 71 Kommentar

Hallo, ich habe mit einem neu installiertem Windows7-64 PC folgendes Phänomen (erstmals, ich habe davor schon viele Systeme eingerichtet, ...

Netzwerke
Netzwerkzugriff langsam
gelöst Frage von slanskyNetzwerke5 Kommentare

Hallo Leute, ich habe folgendes Problem: Wir haben mehrere Rechner innerhalb der Firma umgezogen. Das bedeutet die Rechner sind ...

Server
Netzwerkzugriff nur über Domain
Frage von sebastian2608Server4 Kommentare

Abend Leute, mal eine etwas andere Frage: Wie würdet ihr es lösen, wenn es heißt mal sollte den Netzwerkzugriff ...

LAN, WAN, Wireless
Netzwerkzugriff vom lokalen DMZ - User
gelöst Frage von ChristianM75LAN, WAN, Wireless7 Kommentare

Hallo Community, Ich habe folgendes Problem: Mein Webserver steht in der DMZ und hat nur eine lokale Anmeldung. Jetzt ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 17 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 22 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 22 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Windows XP
Windows XP Aktivieren geht nicht
Frage von tetikmiroWindows XP13 Kommentare

Hallo Ich habe einen Windows XP mit einen vCenter Converter umgezogen auf eine ESXI. Soweit funktioniert dies auch ohne ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
gelöst Frage von prodriveNetzwerkmanagement12 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...