Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN Ipsec Verbindung von xp im LAN zu w2k-Server gibt Fehler 678

Frage Netzwerke Netzwerkprotokolle

Mitglied: flysky

flysky (Level 1) - Jetzt verbinden

11.06.2007, aktualisiert 04.11.2008, 8286 Aufrufe, 5 Kommentare

Hallo liebe Experten,

ich hab folgendenes Problem mit der VPN Verbindung und komme einfach nicht weiter, vielleicht kennt jemand die Lösung und kann mir helfen:

Server:
-w2k Server SP4
-IP: 192.168.0.100
-Domänenserver (festen IP-Adressen)
-Jana Proxy für Internet und Mail
-DSL Arcor
-DYNDNS und Updater
-VPN Ipsec Dienst
-RRAS
-McAfee Firewall

Client1:
XP SP2
hängt im LAN und in der Domäne des Servers
Verbindung zum Internet via Proxyserver 192.168.0.100

Client2:
XP SP2
externer Rechner - gehört nicht zur Domäne

Client3:
XP SP2
Laptop mit UMTS Karte
hängt nicht in LAN - gehört zur Domäne


Die VPN Verbindung funktioniert einwandfrei zwischen:
1. ... Client2 und Server.
2. ... Client3 und Server.
3. Auch die VPN Verbindung zwischen Client1 und Server funktioniert, wenn bei der Anwahl die IP des Domänenserver (192.168.0.100) angegeben wird - d.h. Verbindung nur via LAN.

4. sie funktioniert zwischen Client1 und Server nicht (Fehlercode 678) wenn ich die aktuelle - von Arcor vergebene IP Adresse des Servers 88.x.x.x.- als Host eingebe. Wenn ich die Dyndns Adresse angebe, kommt sogar 769: "das angegebene Ziel ist nicht erreichbar" .

Ein Firewall-Problem ist es nicht - Problem besteht auch bei abgeschalteter Firewall.
User Rechte und RRAS Freigaben existieren.

Ipsecmon auf dem Server zeigt mir, dass eine VPN Verbindung aufgebaut wird - bei der Anwahl mit dem Fehler 678. Bei Anwahl, die den Fehler 769 hat, zeigt Ipsecmon nichts.

Ich habe auf dem XP Rechner den Microsoft Hotfix in der Registry eingegeben : AssumeUDPEncapsulationContextOnSendRule = 2

Trotz allem googeln bin ich nicht weitergekommen.

Wäre für jeden Rat dankbar.

flysky
Mitglied: aqui
11.06.2007 um 12:30 Uhr
Arcor filtert scheinbar ausgehende IPsec Verbindungen oder Teile des IPsec Protokoll wie das ESP Protokoll. Trotz mehrfacher Zusicherung der Hotline und Nachfrage wird es trotzdem gefiltert, was sehr leicht nachzuweisen ist.
Wenn du von Fremdnetzen IPsec Verbindungen aufbaust also incomming Verbindungen hast rennt es problemlos nur nicht innerhalb des Arcor Netzes. Das ist reproduzierbar wenigstens in manchen Bereichen und scheinbar auch bei dir.
Ein generelles Problem bei Arcor....leider. Wenn du spaßeshalber einmal PPTP als Protokoll nimmst wirst du sehen das es damit fehlerfrei funktioniert ! Was auch ganz klar zeigt das Arcor IPsec innerhalb ihres Backbones manipuliert mit Filtern, jedenfalls was ausgehende Verbindungen anbedtrifft. Das legt die Vermutung nache das sie an ihren Systemen mit inbound ACLs arbeiten.
Ggf. musst du der Hotline mal mit Vetragskündigung drohen, vielleicht fixt das deren Problem...

Nebenbei bemerkt einen Windows Server so ohne Router im Internet zu exponieren ist sträflicher Leichtsinn und zeugt nicht gerade von Professionalität (sorry...). Warum man immer noch sowas macht wo DSL Router heute um die 35 Euro kosten und damit erheblich mehr Sicherheit vor Angriffen und Attacken bieten ist mehr als unverständlich ! Mit einer entsprechenden PFW Liste oder noch besser einem VPN fähigen Router der selber VPN Server ist (wie z.B. Draytek) dort hättest du auch sehr wahrscheinlich diese o.a. Probleme nicht !
Bitte warten ..
Mitglied: flysky
11.06.2007 um 14:58 Uhr
Hallo aqui, danke für deine sssssssssssssuperschnelle und kompetente Antwort .

Hab deinen Rat ausprobiert. PPTP funktioniert tatsächlich!
Ich bin aber etwas perplex, da Client2 ebenfalls im Arcor Netz ist und die Verbindung funktioniert doch einwandfrei !?
Kann es eventuell am Jana Proxy hängen ?

Ich teile deine Sicherheitsbedenken generell und werde mich nach einem Hardwarerouter umschauen. Was bringt das Teil aber an mehr Sicherheit zu dem was ich aktuell habe ?
Aktuell haben ich : Firewall, AV, mehrere Anti-Malware Software, sehr eingeschränkten RRAS Einwahl Richtlinien, Ipsec und - falls mit PFW eine Personal Firewall Liste gemeint ist - auch eine PFW Liste.

Gruß flysky
Bitte warten ..
Mitglied: andyw5
22.01.2008 um 14:05 Uhr
Moin alle zusammen,

habe auf einer XP-Maschine o.g. Problem.
Ich habe mit dem Rechner in der Fa. eine VPN-Verbindung zum 2003 Server aufgebaut und es hat alles hervorragend funktioniert.
Jetzt ist der Kollege mit seinem Notebook im Ausland und wenn er die VPN-Verb. aufbauen will, erhält er obeb genannte Meldung.
Telnet auf den Server fuktioniert.

Habe pptp und andere Einstellungen getestet, jedoch ohne Erfolg.
Weiß jemand Rat?
Vielen Dank im voraus
Andy
Bitte warten ..
Mitglied: theStorm
31.10.2008 um 03:56 Uhr
Tag zusammen.

So, nun ist es wohl soweit und ich hab mich hier für diese Sache mal angemeldet nachdem ich hier schon zahlreiche nützliche Hilfe gefunden habe.

Ich möchte ein VPN einrichten. Ich habe so wie es ausschaut auch das beschrieben Arcor-Problem - eine Verbindung mit einem Peer bei der Telekom ging. Aber die beiden Arcor-Anschlüsse wollen einfach nicht. Erschwerend hinzu kommt, das ich bisher VPN noch nie eingerichtet hab
Nundenn, da ich zunächst günstige Allnet-Router gekauft hatte, und dort nichts von PPTP gefunden habe, habe ich jetzt zwei Bintec-Router besorgt - R230aw falls das jemandem was sagt. Meine Fage beschränkt sich zunächst mal auf folgendes: Bei manchen der Bintec-Modelle gibt es im Menüpunkt VPN einen Unterpunkt PPTP - eigentlich wollte ich so ein Gerät kaufen, habe aber leider das falsche erwischt (scheinbar). Allerdings kann ich wohl die Interneteinwahl ansich mit PPTP einrichten statt mit PPPoE. Ist es das, was ihr gemacht habt, womit ihr erfolg hattet? Oder habt ihr das VPN direkt über PPTP laufen gehabt? ...ich verstehe das mit dem VPN wie gesagt alles noch nicht so ganz und deswegen fehlt mir der durchblick. Hoffe ich krieg die zwei Router morgen zum laufen.

Danke schonmal.

Grüße
Andi

PS: Arcor stellt sich übrigens immer noch Quer - habe gestern und vorgestern MEHRFACH mit denen telefoniert. Erfolglos. Ist eine bodenlose Frechheit. Sie sagen einfach "da wird nichts gesperrt".

PS2: also nach langem überlegen glaube ich immer mehr das ihr das vpn selbst über pptp eingerichtet habt und nicht die internet-einwahl. der router bietet allerdings noch l2tp an, was ja irgendwie auf pptp aufsetzt, aber auch ipsec nutzt - so wie ich das verstanden habe. könnte es damit denn klappen mit arcor?? *verzweifel*
eine pptp-lizenz kostet nochmal ca. 100 euro netto ... das braucht man dann vermutlich für jeden der beiden router..also wäre schon gut wenn das über l2tp geht
Bitte warten ..
Mitglied: theStorm
04.11.2008 um 23:30 Uhr
So, für alle die auch mal ein Problem mit Arcor und VPN haben:

Ich habe jetzt die Bintec-Router erfolgreich konfiguriert. Das VPN klappt - über IPSec - ganz ohne L2TP oder sonstirgendwas. Ich habe keine großartigen Tricks anwenden müssen. Warum es mit den ALLNET-Dingern nicht ging - keine Ahnung.

Zwar hab ich noch ein Problem mit der Domänenanmeldung aber das gehört nicht in diesen Thread.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst VPN von Fritz!Box zu Windows Server 2012 R2 IPSec (7)

Frage von Andre02 zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst VPN von ZyXEL USG zu Windows Server 2012 R2 (13)

Frage von itschloegl zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...