Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN (SBS 2003) und Cisco PIX 501

Frage Netzwerke

Mitglied: ChrisX81

ChrisX81 (Level 1) - Jetzt verbinden

22.04.2008, aktualisiert 16:22 Uhr, 4573 Aufrufe, 1 Kommentar

Hallo erstmal. Da ich von Netzwerk-Technik nicht wirklich viel Plan habe, habe ich den Artikel vielleicht nicht optimal platziert. Man möge mir das verzeihen

Nun zu meinem Problem:

Ich habe einen Small Business Server 2003. Auf diesem habe ich per Assistent "RAS konfigurieren" VPN eingerichtet. Zwischen I-Net und dem Server steht eine PIX 501. Eingewählt ins Internet wird mit einem Standard D-Link-Router. Die Adressen der relavanten Geräte:

Router: 192.168.1.254.
PIX Outside-Interface: 192.168.1.253
PIX Inside-Interface: 172.20.250.1
SBS 2003 Server: 172.20.1.1
Auf dem SBS läuft der DHCP, der die Clients mit IP-Adressen versorgt.

Ich habe schon einiges probiert, hier und da was gelesen bin aber nicht wirklich weiter gekommen. Von der Theorie her müsste ich doch nur auf dem Router und der PIX jeweils eine Port-Weiterleitung des Ports 1723 einrichten, das hat aber nicht geklappt.
Leider habe ich meine versuchsweise eingerichtete Einstellung gelöscht, bevor ich sie mir gesichert habe. Deshalb hier nur meine Einstellung ohne Port-Weiterleitung:

Result of PIX command: "show running config"

Saved
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ### encrypted
passwd ### encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
name 192.168.1.254 ROUTER
name 172.20.1.1 SERVER01
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any time-exceeded
access-list 100 permit icmp any any unreachable
access-list 100 permit tcp any eq 1080 any eq 1080
access-list 100 permit udp any eq 1080 any eq 1080
access-list 100 permit tcp any eq www any eq www
access-list inside_outbound_nat0_acl permit ip 172.20.0.0 255.255.0.0 172.20.200.0 255.255.255.0
pager lines 24
logging on
interface ethernet0 10baset
interface ethernet1 10full
mtu outside 1500
mtu inside 1500
ip address outside 192.168.1.253 255.255.255.0
ip address inside 172.20.250.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool Standard 172.20.200.1-172.20.200.254
pdm location 172.20.200.0 255.255.255.0 outside
pdm location ROUTER 255.255.255.255 outside
pdm location SERVER01 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 192.168.1.15-192.168.1.250
global (outside) 2 192.168.1.251
global (outside) 3 ROUTER
global (outside) 3 192.168.0.1
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 2 0.0.0.0 0.0.0.0 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 ROUTER 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 172.20.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
no sysopt route dnat
telnet timeout 5
ssh timeout 5
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP client configuration address local Standard
vpdn group PPTP-VPDN-GROUP client configuration dns 217.237.151.225
vpdn group PPTP-VPDN-GROUP client configuration wins SERVER01
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username ### password *
dhcpd address 172.20.250.2-172.20.250.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:f82c9c2af51474022b660bbc5009cdbd
: end


Ich hoffe, nichts vergessen zu haben, was zur Problemlösung nötig ist!
Mitglied: aqui
22.04.2008 um 16:22 Uhr
Was soll denn der Unsinn PPTP VPN Session durch die PIX durchzutunneln auf den MS Server wo die PIX die VPN Connections doch viel besser SELBER terminieren kann als der MS Server !!! Und das ganz ohne das überflüssige Tunneling und die Frickelei mit NAT !
Was du hier machst ist: "Warum einfach machen wenn es umständlich auch geht...!!" (Oder du weisst nicht wirklich was eine PIX ist gescheige denn kann...) ??!!

Die Cisco Seite hat die passende Konfig für dich:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/prod_configuratio ...

und

http://www.cisco.com/en/US/tech/tk827/tk369/tk529/tsd_technology_suppor ...
speziell:
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configur ...


Willst du es dennoch uf die unsinnige und umständliche Art machen musst du das GRE Protokoll (Protkollnummer 47) und TCP 1723 auf der PIX forwarden auf den Server sonst wird es nix mit VPNs.
Achtung: Das VPN Protokoll PPTP ist jetzt geraten, da du uns ja nicht mitteilst welches VPN Protokoll du benutzen willst
Bitte warten ..
Ähnliche Inhalte
Firewall
Cisco PIX 501 Firewall und Putty
gelöst Frage von User85aFirewall6 Kommentare

Schönen Guten Abend Ich Weiß einfach nicht mehr weiter ist zwar ne Blöde frage aber irgendwie bekomme ich das ...

Firewall
Cisco Pix 501 - Fehler Unable to launch device manager !!?
Frage von babyloniaFirewall7 Kommentare

Hi, Cisco Pix 501 Version 6.3(5) Ich habe den PIX Device Manager pdm304.bin installiert. Dann habe ich versucht den ...

Router & Routing
Keine PDM-Konfiguration meiner guten alten pix 501
Frage von rabo001Router & Routing1 Kommentar

Hallo, ich weis es ist ein Uraltteil aber ich möchte sie weiter nutzen meine pix501. Nur jetzt gibt es ...

Firewall
Cisco PIX 506E keine Internetverbidung - Grundlagenfrage
Frage von CKbeatsFirewall3 Kommentare

Hallo liebe Experten, da ich nur mit Windows-Systemen und Datenbanken zu tun habe betrete ich absolutes Neuland. Habe privat ...

Neue Wissensbeiträge
Perl

Perl hat heute Geburtstag: 30 Jahre Perl: Lange Gesichter zum Geburtstag

Information von Penny.Cilin vor 5 StundenPerl2 Kommentare

Hallo, auch wenn es wenige wissen und noch weniger Leute es nutzen. Perl hat heute Geburtstag. 30 Jahre Perl ...

Sicherheit

Blackberry stirbt - Keine Updates für Priv mehr

Tipp von certifiedit.net vor 6 StundenSicherheit

Blackberry wird zu einer 08/15 Firma und geht wohl mehr und mehr den Weg, den HTC schon ging. Von ...

Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 2 TagenWindows 1010 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 2 TagenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
gelöst Frage von HelloWorldBatch & Shell22 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Netzwerkgrundlagen
Belibiges Teilnetz einer Subnetzmaske rausfinden?
gelöst Frage von CenuzeNetzwerkgrundlagen17 Kommentare

Wundervollen Gutentag, mittlerweile kann ich Subnetting so einigermaßen, aber ein Problem habe ich noch. Netzwerkadresse und Boradcast errechnen ist ...

LAN, WAN, Wireless
WLAN Reichweite erhöhen mit neuer Antenne
gelöst Frage von gdconsultLAN, WAN, Wireless12 Kommentare

Hallo, ich besitze einen TL-WN722N USB-WLAN Dongle mit einer richtigen Antenne. Ich frage mich jetzt ob man die Reichweite ...

Windows Server
Logging von "gesendeten Nachrichten" auf Terminalservern
gelöst Frage von Z3R0C0MM4N0THiN6Windows Server10 Kommentare

Hallo zusammen, kann mir jemand auf kurzem Wege sagen ob 1) die per Task-Manager (oder damals tsadmin) an Benutzer ...