Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Webseite von intern ohne Formatierung

Frage Netzwerke DNS

Mitglied: Gatschi

Gatschi (Level 1) - Jetzt verbinden

14.01.2015, aktualisiert 12:46 Uhr, 1216 Aufrufe, 4 Kommentare

Hallo,

ich habe folgendes Problem:

Unsere Internetseite wird seitdem sie neu erstellt wurde nicht mehr korrekt angezeigt (siehe Bilder).
Das Problem habe ich nur wenn ich von INTERN auf die Seite zugreifen möchte. Merkwürdig ist, dass wenn ich manuell auf den Clients z.B. die 8.8.8.8 (Google-DNS) oder den von unserem Provider als DNS eintrage wir die Seite korrekt angezeigt, ebenso von extern.

Folgendes hat nicht geholfen:
- Browserverlauf löschen etc.
- ipconfig /flushdns
- Auf dem DNS-Server den Cache gelöscht und Zonen neu geladen
- und natürlich alles neu gestartet

Zur Umgebung:
- 2 Domaincontroller (Windows Server 2008 R2, DHCP, DNS, ...)
- Clients (Windows 7, MacOs, iOS)
- Die Webseite wird extern gehostet
- Firewall (Sonicwall) und Modem von Vodafone

00efc88725282df73e7fb9478731707d - Klicke auf das Bild, um es zu vergrößern

e83e49a6f27dd98e7917d2a8f3afdb00 - Klicke auf das Bild, um es zu vergrößern
Mitglied: colinardo
14.01.2015, aktualisiert um 12:50 Uhr
Hallo,
existiert die extern gehostete Domain zufällig intern bei euch ebenfalls als Zone (Stichwort Split-DNS)?
Könnte sein das da ein Programmierer hier einen festen Pfad mit Domainnamen zum Stylesheet eingebaut hat, der dann intern bei euch ins leere zeigt.

Grüße Uwe
Bitte warten ..
Mitglied: Gatschi
14.01.2015 um 13:00 Uhr
Hallo,

die Domain existiert auch intern als Zone. Dort ist auch der passende Host (A) Eintrag für WWW -> IP-Adresse vorhanden.
Das hatte ja mit der alten Seite auch funktioniert.

Das würde ja dann bedeuten dass der Programmierer der Seite was ändern müssen, oder?
Bitte warten ..
Mitglied: colinardo
14.01.2015, aktualisiert um 13:29 Uhr
Zitat von Gatschi:
Das würde ja dann bedeuten dass der Programmierer der Seite was ändern müssen, oder?
Wenn man sich die Seite mal ansehen könnte wäre das hilfreich für eine Aussage von unserer Seite. Wenn du die Seite hier nicht posten darfst, sende den Link mal per Personal Message.Könnte sein das man da keinen relativen Link eingefügt hat.

Und wenn nur www bei euch hinterlegt ist funktioniert ein Aufruf ohne www vermutlich nicht, außer ihr habt ebenfalls einen leeren A-Eintrag für die Zone angelegt der auf den Webserver zeigt.

Grüße Uwe
Bitte warten ..
Mitglied: Dani
14.01.2015 um 23:57 Uhr
Moin,
Das würde ja dann bedeuten dass der Programmierer der Seite was ändern müssen, oder?
Sollte ich mit einem Eintrag in der .htaccess regeln lassen:
01.
RewriteEngine On 
02.
RewriteCond %{HTTP_HOST} !^www\. 
03.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
Natürlich ungetestet...
Ansonsten würdest z.B. beim Firefox über die Entwickertools (F12) und dort Netzwerkanalyse genau sehen, ob evtl. Dateien nicht geladen werden können.


Gruß,
Dani
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Linux Desktop
Webseite aufgerufen - Linux gehackt (5)

Link von BirdyB zum Thema Linux Desktop ...

RedHat, CentOS, Fedora
gelöst Die Website hat die Anzeige dieser Webseite abgelehnt - SePolicies - Linux (1)

Frage von rainergugus zum Thema RedHat, CentOS, Fedora ...

Sicherheit
gelöst NMAP von intern ins Internet (16)

Frage von Thorsten85 zum Thema Sicherheit ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...