Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win2k3 Netzwerklaufwerk Unterbrechungen im Datenstrom langsames Gigabit

Frage Microsoft Windows Netzwerk

Mitglied: vip3234

vip3234 (Level 1) - Jetzt verbinden

01.10.2008, aktualisiert 15.10.2008, 3711 Aufrufe, 2 Kommentare

Hallo,

ich habe beim Kopieren von einem Netzwerklaufwerk des Servers aus ein Problem mit der Datenrate, was auf ein Zusammenbrechen des Datenstromes zurückzuführen ist.
Weitere Details siehe unten:

Folgende Konfiguration liegt vor:

1x Server Windows 2003 SBS Standard mit 2x Intel Pro Gigabit on Board (intel serverboard)
und Hardware Raid5 mit Adaptec Controller und 4x400GB Seagate Festplatten

1x Client mit Windows Vista Ultimate und 1x Intel Gigabit Adapter in Board
und SATA2 1x320GB Seagate Festplatte

Das Szenario wurde mit direkter Cross Over Verbindung über Cat5e Kabel UND über einen Gigabit Switch getestet.

Mit netio ermittelte Netzwerkdatenrate: 99Mb/s-110Mb/s

Mit HdTach ermittelte Daten:
lesen schreiben
Raid5: 55MB/s 30MB/s
SATA2: 73MB/s 60MB/s

CPU Auslastung während des Kopierens:
Server: 6%
Client: 10%

Das Szenario:

Auf dem Server ist ein Netzwerklaufwerk, auf dem eine Datei mit 2,5GB liegt, die es zu kopieren gilt. Des Weiteren ist auch der Zielort auf dem Client freigegeben.
1. Es wird nun vom CLIENT aus der Kopiervorgang vom Servernetzwerklaufwerk lokal auf den Client gestartet.


Das untere Bild zeigt den Transfer mit NetMeter auf dem Client

e8359eab840fc9a990fbfefc2491eb8b-vista_business_-_win2k3 - Klicke auf das Bild, um es zu vergrößern


Wie man deutlich sehen kann, wird der Datenstrom immer wieder unterbrochen und es enstehen deutlich erkennbare Abstände. Dies führt zu einer Transferrate von durchschnittlich 20-25Mb/s


2. Nun wird der gleiche Versuch noch einmal gemacht, nur dass jetzt der Kopiervorgang vom Server aus auf das ebenfalls freigegebene Ziel auf dem Client gestartet wird.
Somit also der gleiche Vorgang, nur eben vom Server aus gestartet.


Das untere Bild zeigt wieder den Transfer mit NetMeter auf dem Client

3eba0744fe3909547860e393c889be40-win2k3_-_vista - Klicke auf das Bild, um es zu vergrößern


Der Datenstrom ist nun konstant und gleichmäßig. Die durchschnittliche Tranferrate liegt jetzt mit 50MB/s beim Festplattenlimit.



3. Zum Vergleich wurde noch ein Kopiervorgang zwischen 2 gleichwertigen Vista Clients gemacht. Auch hier ist der Datenstrom konstant und die Rate lag bei ca. 45MB/s

ecd10ca7f0eb0a9d62a7db8e76feceb9-vista_-_vista - Klicke auf das Bild, um es zu vergrößern



Nun stellt sich die Frage, womit das Ganze zusammenhängt ? Wieso bricht der Datenstrom immer in kurzen Abständen zusammen wenn der Vorgang vom Client aus gestartet wurde und wieso nicht, wenn dieser vom Server aus begonnen wird ?


Ich wäre euch echt dankbar, wenn mir da jemand weiterhelfen könnte.

Gruß,
Ludwig
Mitglied: XOR-Bit
15.10.2008 um 19:14 Uhr
Hallo,
Raid 5 hat eine schlechtere Schreibperformance als die meisten anderen Raid-Konfigurationen, was oben ja auch gemessen steht. Wenn die Platten nun mit "nur" 30 MB/s wegschreiben können, dann sind die 20 bis 25 MB/s doch gar nicht so schlecht. Auch die übrige Schilderung passt recht gut, denn die Transferraten zwischen Systemen, deren HD I/O besser performt, ist genügend dicht an den Schreibraten der jeweiligen HDs. Ebenso passt das asymmetrische Übertragungsverhalten Server <-> Client zu dieser These.
Gruß
XOR
Bitte warten ..
Mitglied: vip3234
15.10.2008 um 19:21 Uhr
Hallo und danke für die Antwort.

Allerdings kann es nicht an der Festplatten performance liegen. Denn wenn ich daten vom raid5 beziehe werden die Daten zu keinem Zeitpunkt geschrieben. Und die Zielplatten können sehr wohl mit mehr als 30Mb/s schreiben,
denn wie beschrieben erreiche ich eine Geschwindigkeit von 55mb/s wenn ich vom Server aus den Vorgang starte.

Nochmal kurz:

Quelle (server) und Ziel (Client) bleiben gleich. Es wird immer vom Server gelesen und auf den Client geschrieben.
Jedoch im eine Fall vom Server aus gestartet und im anderen vom Client.
Im einen Fall erreiche ich 55MB/s und im anderen eben nur 24MB/s
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
Alternative zu Emulex 10 Gigabit OCe14102 NT - S2D (2)

Frage von StfnCstr zum Thema Server-Hardware ...

LAN, WAN, Wireless
gelöst 1 GBit Lan mit 0,09 bis 0,1 Gigabit Datendurchsatz (19)

Frage von viki11 zum Thema LAN, WAN, Wireless ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (11)

Frage von Akcent zum Thema Hyper-V ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...