Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win2k3 Routing zwischen 2 Netzen

Frage Netzwerke Router & Routing

Mitglied: d4sid-555

d4sid-555 (Level 1) - Jetzt verbinden

23.11.2005, aktualisiert 25.11.2005, 9888 Aufrufe, 12 Kommentare

Hi zusammen

Bin gerade dabei mein Heimnetzwerk zu konfen, komme aber mit dem routing nid weiter.
folgendes:

Ich habe 2 Netze:

192.168.0.0 (WLAN - Netz)
192168.1.0 (LAN - Netz)

im 192.168.0.0 er Netz hab ich folgendes:

- Win 2k3 Server mit DNS, DC, DHCP (IP 192.168.0.16, sub 255.255.255.0, Gateway 192.168.0.15)
- Win 2k3 Server mit Routing (IP 192.168.0.16, sub 255.255.255.0, Gateway 192.168.0.15)
- Win XP Client (IP 192.168.0.11, sub 255.255.255.0, Gateway 192.168.0.15)
- Win XP Client (IP 192.168.0.12, sub 255.255.255.0, Gateway 192.168.0.15)

DNS is bei allen auf 192.168.0.16

im 192.168.1.0 er Netz:

- Win 2k3 Server mit DNS, DC, DHCP (IP 192.168.1.102, sub 255.255.255.0, Gateway 192.168.1.101)
- Win 2k3 Server mit Routing (IP 192.168.1.101, sub 255.255.255.0, Gateway 192.168.1.101)
- Win XP Client (IP 192.168.1.100, sub 255.255.255.0, Gateway 192.168.0.15)
- Win 2k Client (IP 192.168.1.80, sub 255.255.255.0, Gateway 192.168.0.15)

DNS is bei allen auf 192.168.1.102

die beiden Netze werden über den Win 2k3 Server geroutet, das funktioniert einwandfrei, ich kann jeden vom anderen aus pingen, kann mich auch über jedes Netz bsp. am DC anmelden.
Hier die Routing Tabelle:

0.0.0.0 0.0.0.0 192.168.0.15 192.168.0.15 1
0.0.0.0 0.0.0.0 192.168.1.101 192.168.1.101 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.0.0 255.255.255.0 192.168.0.15 192.168.0.15 1
192.168.0.15 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.0.255 255.255.255.255 192.168.0.15 192.168.0.15 1
192.168.1.0 255.255.255.0 192.168.1.101 192.168.1.101 1
192.168.1.101 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.1.255 255.255.255.255 192.168.1.101 192.168.1.101 1
224.0.0.0 240.0.0.0 192.168.0.15 192.168.0.15 1
224.0.0.0 240.0.0.0 192.168.1.101 192.168.1.101 1
255.255.255.255 255.255.255.255 192.168.0.15 192.168.0.15 1
255.255.255.255 255.255.255.255 192.168.1.101 192.168.1.101 1

Nun hab ich aber im 0 er Netz noch ein Acesspoint, über den ich das Internet beziehe.
Der AP und WAN - Router hat die IP 192.168.0.1 (Wireless Netz läuft über den AP)
Nun möchte ich das Internet im ganzen Netz bereitstellen, dazu habe ich noch eine statische Route hinzugefügt:

0.0.0.0 0.0.0.0 192.168.0.1 192.168.0.15 1

also meine ganze Routing tabelle sieht nun so aus:

Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.0.1 192.168.0.15 1
0.0.0.0 0.0.0.0 192.168.0.15 192.168.0.15 1
0.0.0.0 0.0.0.0 192.168.1.101 192.168.1.101 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.0.0 255.255.255.0 192.168.0.15 192.168.0.15 1
192.168.0.15 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.0.255 255.255.255.255 192.168.0.15 192.168.0.15 1
192.168.1.0 255.255.255.0 192.168.1.101 192.168.1.101 1
192.168.1.101 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.1.255 255.255.255.255 192.168.1.101 192.168.1.101 1
224.0.0.0 240.0.0.0 192.168.0.15 192.168.0.15 1
224.0.0.0 240.0.0.0 192.168.1.101 192.168.1.101 1
255.255.255.255 255.255.255.255 192.168.0.15 192.168.0.15 1
255.255.255.255 255.255.255.255 192.168.1.101 192.168.1.101 1
Standardgateway: 192.168.0.1
Ständige Routen:
Keine

Nun habe ich am Router (192.168.0.15 / 192.168.1.101) und am DC/DNS/DHCP - Server (192.168.0.16 / 192.168.1.102) Internet, im restlichen Netz jedoch nicht. Habe schon diverses ausprobiert, aber funktioniert einfach nicht. Normalerweise wenn ich ins i-net will hab ich bei der Karte als Gateway 192.168.0.1 konfiguriert, da ich aber ein Router dazwischen habe, ist der Gateway im .0 er Netz nun überall 192.168.0.15.

Jemand ne nützliche Idee wie ich das hinkriegen kann? Ich will im gesammten .0 er und .1 er Netz Internet zur Verfügung haben. Muss ich da ev. NAT noch aktivieren?

Gruss

d4s!d
Mitglied: Karo
23.11.2005 um 18:01 Uhr
Schau mal bei User Atti58. Der hat da zwei Tutorials die Dir vielleicht weiterhelfen
http://www.administrator.de/index.php?mod=show_public_profile&nr=34 ...

Karo
Bitte warten ..
Mitglied: d4sid-555
23.11.2005 um 18:45 Uhr
danke für den tipp, nützt bei mir leider nichts, da mein netz anders aufgebaut ist:

http://mastalord.ma.ohost.de/Netzwerk.JPG

hier hab ich kurz mein Netz mit paint gezeichnet, ev versteht ihrs so besser

jemand ne Idee??
Bitte warten ..
Mitglied: superboh
24.11.2005 um 04:06 Uhr
Hi,

also ohne diesen Plan hätt ich mir das Ganze nicht begriffen bzw. hätte gleich aufgegeben es verstehen zu wollen (zu viele Zahlen bzw. Routen ).

Aber noch eine Frage: Wo hast Du denn diese zusätzliche Route eingetragen? Auf dem "zentralen" Router-Rechner? Was hat der denn für ein Default-Gateway? Doch wohl die 192.168.0.1 oder? Dann schmeiss diese Route wieder raus, denn alles was er nicht sonstwohin routen kann, geht ja zum Default-Gateway.
Auf dem Accesspoint brauchst Du noch ne Rückroute nach dem Schema

route 192.168.1.0 mask 255.255.255.0 gatetway 192.168.0.15

damit Anfragen aus dem 1er Netz auch wieder dorthin zurückfinden.

Was ich nicht ganz verstanden habe, ist ob die Clients im 0er Netz Internet haben oder nicht? Weil eigentlich müssten sie ja haben, zumal der Server dort (192.168.0.16) ja hat. Und der hat ja keine andere TCP/IP Konfiguration wie die Clients oder?
Falls die Clients kein I-Net haben, trage mal auf einem eine IP fest ein und versuch es dann nochmal. Wenns dann geht, liegts am DHCP. Das klären wir dann im Schritt 2.

Gruss,
Thomas
Bitte warten ..
Mitglied: d4sid-555
24.11.2005 um 08:47 Uhr
moin

die zusätzliche Route ist auf dem Win 2k3 Router eingetragen, welcher als Gateway 192.168.0.15 hat (wechsel auf 192.168.0.1 nützt nichts, hab ich auch schon probiert)
ohne Internet funktioniert die Kommunikation von Netz 1 zu Netz 2 und umgekehrt problemlos.
das .0 er Netz hat kein Internet, nur der Router und der DNS/DC/DHCP Server hat Internet (was ich nicht verstehe). Die Clients haben die selbe Konfiguration wie der Router, IP 192.168.0.x, sub 255.255.255.0, GW 192.168.0.15, DNS 192.168.0.16
Damit ich über den AP Internet bekomme, müsste ich bei den WLAN-Karten als Gateway 192.168.0.1 eintragen.
Mit dem DHCP ist alles ok, der vergibt eh nur IPs ins 192.168.1.0 er Netz (atm hat nur der 1.80 er Win2k Client DHCP aktiviert)

Der AP braucht keine zusätzliche Route, das übernimmt ja mein Win2k3 Router. Er routet ja das .0 er Netz zum .1 er und umgekehrt.

Noch zum Verständnis, Der DNS/DC/DHCP Server is in beiden Netzen der selbe, der hat einfach 2 Netzwerkkarten

Sobald ich Zeit habe werde ich nochmals versuchen einen besseren Netzwerkplan zu zeichnen, zum besseren Verständnis
Bitte warten ..
Mitglied: superboh
24.11.2005 um 08:57 Uhr
Also so wie ich den Plan lese, gibt es im 0er Netz einen Server (der DC,DHCP und DNS ist und es gibt einen Server im 1er Netz der auch DC,DHCP und DNS ist. Und dann gibt es noch den Server der die zwei NICs hat und Router ist. Soweit richtig?

Nee, nicht richtig, habs grad gelesen ... Du hast einen Server der DC, DHCP und DNS ist. Hat je eine NIC im 0er und eine im 1er Netz. Und es gibt den Router-Server, der auch 2 NICs hat. So richtig?

Hm, aber das wäre auch unlogisch, weil dann könnte der DC,DHCP und DNS-Server ja das Routing mitmachen und Du würdest einen sparen.

Gruss,
Thomas
Bitte warten ..
Mitglied: superboh
24.11.2005 um 09:13 Uhr
die zusätzliche Route ist auf dem Win
2k3 Router eingetragen, welcher als Gateway
192.168.0.15 hat

Hm, er kann sich aber doch selbst nicht als Gateway haben ???

Der AP braucht keine zusätzliche Route,
das übernimmt ja mein Win2k3 Router. Er
routet ja das .0 er Netz zum .1 er und
umgekehrt.

Versetz sich mal in die Lage des APs (er ist ja auch Router wie ich verstanden habem nämlich für alles was in I-Net muss und zurück kommt). Er hat eine Anfrage eines Clients aus dem 1er Netz an einen Webserver weitergeleitet. Nun kommt das Datenpaket aus dem Internet und er will es an den Client durchreichen ... tja, jetzt hat er ein Problem, weil er den Client nicht in seinem 0er Netz erreicht. Erst durch die Route weiss er ja, dass er das Paket über den W2k3-Router ins 1er Netz bekommt.

Gruss,
Thomas
Bitte warten ..
Mitglied: d4sid-555
24.11.2005 um 14:14 Uhr
habe zum besseren Verständnis nochmals einen Plan gezeichnet:

http://mastalord.ma.ohost.de/Netzwerkplan.JPG

auf die Beiträge werde ich später noch ne Antwort geben, hab leider atm keine Zeit.
thx für die Beiträge
Bitte warten ..
Mitglied: superboh
24.11.2005 um 17:19 Uhr
Nichts für ungut, aber die Clients iritieren nur, sie sollte man in einem Netzwerkplan weglassen.
Also Server, Router, Switch und so was gehört rein, sprich alles was in irgend einer Form für die Kommunikation nötig ist.
Brauchst den Plan aber nicht nochmal neu machen

Was ich aber immer noch nicht verstehe, hast Du einen DC,DHCP und DNS -Server der eine NIC in jedem der beiden Netze hat oder sind es zwei getrennte Rechner?

Gruss,
Thomas
Bitte warten ..
Mitglied: d4sid-555
24.11.2005 um 18:19 Uhr
Nichts für ungut, aber die Clients
iritieren nur, sie sollte man in einem
Netzwerkplan weglassen.
Also Server, Router, Switch und so was
gehört rein, sprich alles was in irgend
einer Form für die Kommunikation
nötig ist.
Brauchst den Plan aber nicht nochmal neu
machen

^^ alle sind eh nid eingezeichnet

Was ich aber immer noch nicht verstehe, hast
Du einen DC,DHCP und DNS -Server der eine NIC
in jedem der beiden Netze hat oder sind es
zwei getrennte Rechner?

Gruss,
Thomas

das erste der server hat in beiden netzen ne NIC, darum hab ich im neuen plan auch noch die hostnamen eingetragen, im " " ist der hostnamen. master ist auch in beiden netzen erreichbar.
bin bald zu Hause, dann kann ich dir die anderen sachen auch noch beantworten, hatte heute zu viel stress :X
Bitte warten ..
Mitglied: d4sid-555
24.11.2005 um 23:42 Uhr
so, nach etlichen Stunden komm ich endlich auf die Seite oO Meine ISP hat wohl irgendwie Probleme mit dem DNS, etliche Seiten im Netz gehen nicht, auch jetzt noch nicht. Jetzt geht bsp diese Seite wieder, dafür geht google nicht mehr :O

Also habs hinbekommen... *freu*

beim Router hab ich Gateway auf 192.168.0.1 gesetzt, Routing hab ich nun nicht nur LAN Routing, sondern hab NAT ausgewählt, rest bei den Clients bleibt das selbe, jetzt hab ich auf allen Clients / Server Internet, obwohls ichs nid verstehe wieso ich NAT machen muss.

thx für deine hilfe superboh (Thomas)
Bitte warten ..
Mitglied: superboh
25.11.2005 um 00:22 Uhr
so, nach etlichen Stunden komm ich endlich
auf die Seite oO Meine ISP hat wohl
irgendwie Probleme mit dem DNS, etliche
Seiten im Netz gehen nicht, auch jetzt noch
nicht. Jetzt geht bsp diese Seite wieder,
dafür geht google nicht mehr :O

Äh, Du bist nicht zufällig bei Arcor? Weil ich hab die gleichen Probleme seit einigen Tage, diese Seite hier ist sehr sehr schlecht zu erreichen, Wikipedia sehr oft auch nicht.

Bei Deinem Problem läuft jetzt dann echt alles? Was NAT damit zu tun hat, weiss ich auch nicht so ganz, aber in der EDV muss man nicht alles verstehen, es reicht oft wenn man es einfach akzeptiert.

Gruss,
Thomas
Bitte warten ..
Mitglied: d4sid-555
25.11.2005 um 12:53 Uhr
Äh, Du bist nicht zufällig bei
Arcor? Weil ich hab die gleichen Probleme
seit einigen Tage, diese Seite hier ist sehr
sehr schlecht zu erreichen, Wikipedia sehr
oft auch nicht.

nope, bluewin bei mir läufts seit gestern ca. 0.00 Uhr wieder normal


Bei Deinem Problem läuft jetzt dann
echt alles? Was NAT damit zu tun hat, weiss
ich auch nicht so ganz, aber in der EDV muss
man nicht alles verstehen, es reicht oft wenn
man es einfach akzeptiert.

Gruss,
Thomas

Mom läuft alles ok, was ich noch nicht testen konnte, wenn ich nur WLAN habe ob ich ins LAN Netz komme,
wobei ich denke es sollte keine Probleme geben. Mehr dazu weiss heute abend.
Eigentlich möchte ich shcon verstehen wieso etwas so funktioniert aber andersrum nid, sicher bin ich froh dass es funktioniert,
aber wieso wäre nid schlecht zu wissen naja, werde das schon noch rausfinden

Gruss

d4s!d
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
gelöst Routing zwischen zwei Netzen (31)

Frage von Xaero1982 zum Thema Router & Routing ...

Netzwerke
Routing zwischen 2 Fritzboxen langsam (2)

Frage von danielr1996 zum Thema Netzwerke ...

Router & Routing
gelöst Routing - Netzwerk Problem - zwischen Filiale und Zentrale (12)

Frage von clonex zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...