Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win7 net use Befehl erfolgreich, Laufwerk nicht angezeigt

Frage Microsoft Windows Netzwerk

Mitglied: Babelsberger

Babelsberger (Level 1) - Jetzt verbinden

23.01.2012, aktualisiert 12:44 Uhr, 5880 Aufrufe, 1 Kommentar

Es wird versucht zwischen mobilen Arbeitsstationen ein Netzwerk aufzubauen mittels NET USE X: \\192.168.200.1\server . Es kommt hierbei zu Merkwürdigkeiten unter Windows 7.

Hallo!

Ich habe Laptops im Einsatz die sich vor Ort zu 3er und 4er Netzwerken verbinden müssen. Hierzu gibt es einfache Windowsfreigaben auf Festplatte D: (namentlich "server").
Die Benutzer haben einfach Links in einem Ordner (C:\Netz\Netz), welche auf Batchdateien verweisen (C:\Netz). Diesen Ordner (C:\Netz\Netz) binde ich als Symbolleiste in die Taskleiste ein. Das hat nur den schönen optischen Effekt dass der Ordner "Netz" in der Taskleiste auch als "Netz" auftaucht, mit einem kleinen Pfeil daran. Klickt man diesen, klappt die Leiste nach oben auf und es sieht beinahe wie ein Netzwerk-umschalten-Programm aus, ist aber alles Bordmittel .
Das zum Einsatz kommende Netzwerkscript unter Windows 7, für den zweiten Benutzer im Netzwerk:

01.
@echo off 
02.
cls 
03.
net use X: /d /y 
04.
netsh interface ipv4 set address "LAN-Verbindung" static 192.168.200.2 
05.
ping -n 5 localhost >nul 
06.
net use X: \\192.168.200.1\Server /user:xxxxxx 
07.
echo. 
08.
pause
(Anmerkung: der Ping ins Nichts ist eine Verzögerungstaktik, damit die IP-Adresse auch sicher gesetzt wurde, bevor versucht wird das Laufwerk zu verbinden.)
Er tut was er soll, sagt auch "Befehl wurde erfolgreich ausgeführt". In der Explorer-Laufwerksliste taucht aber X: nun gar nicht auf. Irgendwas hat also nicht geklappt.

Nun der Clou. Ich gehe in das entsprechende Verzeichnis c:\Netz (wo ja die Batchdateien drin liegen), mache einen Doppelklick manuell auf die entsprechende Batchdatei (für Benutzer Nr. 2 eben die Nutzer2.bat) und bumms, das Laufwerk Q: wird im Explorer angezeigt. Ich verstehs nicht. Warum klappt es manuell, nicht aber wenn ich die Verknüpfung über die Windows Taskleiste starten will? Das Problem trat mittlerweile mehrfach auf. Eine Verlängerung des "Ping ins Nichts" half auch nicht.

Weiß jemand weiter?

Schönen Gruß,
Babelsberger
Mitglied: DerWoWusste
23.01.2012 um 14:30 Uhr
Hi.

Ich sehe zwei Möglichkeiten:
Entweder ist es ein Bug, der unter seltenen, bei Dir gegebenen Randumständen, auftritt, oder Du gibst nicht korrekt wieder, auf was der Nutzer da klickt. Sollte es eine Batch sein, die mehr tut, als das oben angegebene, beispielsweise, dass sie andere Anmeldeinformationen als die des Users nutzt, wäre das erklärbar. Wenn nicht, kann es nur ein Bug sein. Bitte teste, ob nach anklicken Deiner Verknüpfung ein Neustart des Prozesses explorer.exe (über den Taskmanager) das Netzlaufwerk im Explorer auftauchen lässt.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Windows Netzwerk
gelöst ISCSI Laufwerk wird doppelt angezeigt (2)

Frage von Shardas zum Thema Windows Netzwerk ...

VB for Applications
VB.net Combobox databinding langsam (3)

Frage von ForgottenRealm zum Thema VB for Applications ...

Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(2)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Systemdateien
Warum System auf "C:" (29)

Frage von DzumoPRO zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Cisco SG200: Auf bestimmtem vLAN bestimmte TCP-Ports sperren (16)

Frage von SarekHL zum Thema LAN, WAN, Wireless ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Cloud-Dienste
gelöst Bitcoins minen über Nacht? (16)

Frage von 1410640014 zum Thema Cloud-Dienste ...