Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 7-8, L2TP-VPN-Verbindung mit X.509 sendet falsches Zertifikat

Frage Netzwerke LAN, WAN, Wireless

Mitglied: SilentWarrior

SilentWarrior (Level 1) - Jetzt verbinden

04.01.2013 um 13:01 Uhr, 2602 Aufrufe, 3 Kommentare

Hi,

habe folgendes Problem, ich möchte eine VPN-Verbindung zu einer Sophos UTM herstellen. Ich habe dies auch schon hinbekommen und es funktioniert auf einem Gerät, nun wollte ich ein zweites konfigurieren und es funktioniert nicht.

Folgendes habe ich getan, ich habe die nötigen Zertifikate unter Windows auf dem Computerkonto installiert. Das CA Zertifikat unter "Vertrauenswürdige Stammzertifikate" und das User-Zertifikat unter "Eigene Zertifikate".
Unter eigene Zertifikate ist noch ein weiteres Zertifikat.

Die VPN-Verbindung habe ich über Windows konfiguriert und auf L2TP mit Zertifikat eingestellt. Sonst gibt es hier ja nicht viel einzustellen.

Wenn ich nun aber die Verbindung starte, sehe ich am VPN-Server-Log, dass das falsche Zertifikat gesendet wird, mit dem der VPN-Server natürlich nichts anfängt und die Verbindung ablehnt.

Verwende ich Preshared-Keys funktioniert die Verbindung, es ist also prinzipiell von den Einstellungen her richtig.

Das selbe Problem hatte ich anfangs auch auf dem Gerät, dass nun funktioniert. Dort hatte ich auch mehrere Stunden experimentiert und plötzlich ging es dann, aber hier wurde auch ständig ein falsches Zertifikat gesendet.
Also müsste es doch auf dem zweiten Gerät auch hinzubekommen sein.

Zu den Zertifikaten, bei dem VPN Zertifikat sind alle Verwendungszwecke aktiviert, bei dem anderen Zertifikat ist nur Client- und Serverauth. aktiviert. Die Aussteller der Zertifikate sind unterschiedlich.

Ich hatte auch schon versucht über die Verwendungszwecke Windows dazu zu bewegen, dass es das richtige Zertifikat nimmt, aber leider hat dies keinen Unterschied gemacht.

Hat hier jemand eine Idee ?


Danke.
Mitglied: aqui
04.01.2013 um 14:06 Uhr
Hast du die Zertifikate wirklich richtig installiert ? Im Gegensatz zu XP wo ein Doppelklick reichte geht es unter 7/8 anders:
Start --> Ausführen --> certmgr.msc den Zertifikatsmanger aufrufen, bei Windows 7 wählt man dann manuell "Stammzertifizierungsstellen" als Zertifikatsspeicher aus und installiert das Zertifikat dort !
Damit funktioniert es fehlerfrei.
Bitte warten ..
Mitglied: SilentWarrior
04.01.2013, aktualisiert um 15:19 Uhr
Ich denke schon, dass die Zertifikate richtig installiert worden sind. Habe die Zertifikate über Importieren im mmc Zertifikate SnapIn gemacht, was ja das gleiche sein sollte.
Die Zertifikate werden mir dort auch angezeigt, also daran sollte es wohl nicht liegen oder ?
Bitte warten ..
Mitglied: SilentWarrior
04.01.2013 um 15:19 Uhr
Nachtrag:
Ich habe nun mal das andere Zertifikat, dass immer gesendet wird aus dem Speicher genommen, dann ist nur noch das VPN Zertifikat vorhanden und wird gesendet und die Verbindung wird aufgebaut. Die Zertifikate sind demnach wohl richtig installiert. Windows wählt aber aus welchen Gründen auch immer das falsche der beiden Zertifikate aus.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
MikroTik Router hEX lite L2TP over IPSec Verbindung zu VPN Provider (5)

Frage von Ch3p4cK zum Thema Router & Routing ...

Firewall
Sophos - L2TP over IPsec - Windows 10 Client (4)

Frage von fluluk zum Thema Firewall ...

Netzwerke
VPN-Verbindung Server 2016 und Win10 (IPSec mit Zertifikat) Fehler (5)

Frage von PN-Schrauber zum Thema Netzwerke ...

Neue Wissensbeiträge
Mac OS X

Apple hat macOS High Sierra veröffentlicht

(4)

Information von Frank zum Thema Mac OS X ...

Viren und Trojaner

Ransomware or Wiper? RedBoot Encrypts Files but also Modifies Partition Table

(4)

Information von BassFishFox zum Thema Viren und Trojaner ...

Notebook & Zubehör

WOL bei HP Notebooks

(8)

Erfahrungsbericht von Henere zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Windows Server
Seit IP Umstellung DC DNS Fehler (29)

Frage von Yaimael zum Thema Windows Server ...

Windows 10
gelöst Netzwerkkarte schaltet sich erst nach dem Logon ein (24)

Frage von DerWoWusste zum Thema Windows 10 ...

Grafik
gelöst CAD Arbeitsplätze (17)

Frage von Diddi93 zum Thema Grafik ...

Weiterbildung
gelöst Fest angestellter Admin oder Systemhaus Admin mit Kundenbetreuung? (16)

Frage von Voiper zum Thema Weiterbildung ...