Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 in VM unter ESXi - Grafikprobleme

Frage Virtualisierung

Mitglied: Dominik11

Dominik11 (Level 1) - Jetzt verbinden

29.03.2010, aktualisiert 15:17 Uhr, 7702 Aufrufe, 11 Kommentare

Hallo zusammen,

http://img52.imageshack.us/img52/8430/21428672.gif

Windows 7 (32 bit) in einer VM unter ESXi 3.5, nach nem Windows-Neustart bekomme ich nur oben dargestellte Bildschirmausgabe.
Mache ich einen Reset der VM, gehe mit F8 vor'm Booten ins Menü und wähle "in 640x480 starten", funktioniert das und man kommt rein. Beim nächsten (Neu-)Start ist's dann aber wieder so wie oben, auch wenn ich z. B. die Auflösung auf 800x600 stelle...

vmware-Tools sind installiert.

Any idea?

Danke und Grüße

D
Mitglied: Connor1980
29.03.2010 um 14:02 Uhr
Das sieht für mich nach falsche Auflösung oder Bildwiederholfrequenz des "Monitors" aus. evtl. mal die Ansichtsmöglichkeiten über View durchgehen.
Bitte warten ..
Mitglied: Dominik11
29.03.2010 um 14:04 Uhr
zunächstmal danke. Leider kein View oder Ähnliches vorhanden, nur kostenloser einzelner ESXi ohne zusätzliche Lizenzen.
Bitte warten ..
Mitglied: -ch-ru-
29.03.2010 um 15:07 Uhr
Wieviel Video-RAM hat denn die Maschine zugewiesen bekommen?
Bitte warten ..
Mitglied: Dominik11
29.03.2010 um 15:12 Uhr
bzgl. des Video-RAM habe ich nichts eingestellt / einstellen können. Ich finde auch keine derartige Option im VI-Client...?
Bitte warten ..
Mitglied: -ch-ru-
29.03.2010 um 15:24 Uhr
welche ESXi Version ist denn installiert? In der aktuellen ESXi Version kann man den VideoRAM so einstellen. Unter der 3.5 Version kann man die *.vmx Datei runterladen von der Maschine(datastore) und diese mit Notepad öffnen. Dort kann man dann nachschaun wieviel Video-RAM die Maschine besitzt bzw. diesen verändern.
Bitte warten ..
Mitglied: Connor1980
29.03.2010 um 16:43 Uhr
Zitat von Dominik11:
zunächstmal danke. Leider kein View oder Ähnliches vorhanden, nur kostenloser einzelner ESXi ohne zusätzliche
Lizenzen.
Sry, ich meinte den Menüpunkt View, über den die Fenstergröße verändert werden kann, was im Endeffekt dem "Monitor" entspricht, auf dem die Größe ausgegeben werden soll. Oder eben Einstellung deer Grafikakrte oder veraltete/teilweise/nicht korrekt installierte vmware-tools.
Bitte warten ..
Mitglied: Dominik11
30.03.2010 um 09:26 Uhr
Zitat von -ch-ru-:
welche ESXi Version ist denn installiert? In der aktuellen ESXi Version kann man den VideoRAM so einstellen. Unter der 3.5 Version
kann man die *.vmx Datei runterladen von der Maschine(datastore) und diese mit Notepad öffnen. Dort kann man dann nachschaun
wieviel Video-RAM die Maschine besitzt bzw. diesen verändern.

ESXi 3.5 ist im Einsatz. Leider ist in der vmx-Datei nichts vom Video-RAM zu finden:

config.version = "8"
virtualHW.version = "4"
floppy0.present = "true"
nvram = "srvxxxxxx.nvram"
deploymentPlatform = "windows"
virtualHW.productCompatibility = "hosted"
tools.upgrade.policy = "useGlobal"
powerType.powerOff = "default"
powerType.powerOn = "default"
powerType.suspend = "default"
powerType.reset = "default"

displayName = "srvxxxxxx"
extendedConfigFile = "srvxxxxxx.vmxf"

scsi0.present = "true"
scsi0.sharedBus = "none"
scsi0.virtualDev = "lsilogic"
memsize = "1536"
scsi0:0.present = "true"
scsi0:0.fileName = "srvxxxxxx-000001.vmdk"
scsi0:0.deviceType = "scsi-hardDisk"
ide0:0.present = "true"
ide0:0.clientDevice = "TRUE"
ide0:0.deviceType = "cdrom-raw"
ide0:0.startConnected = "FALSE"
floppy0.startConnected = "false"
floppy0.clientDevice = "true"
ethernet0.present = "true"
ethernet0.virtualDev = "e1000"
ethernet0.networkName = "VM Network"
ethernet0.addressType = "generated"
guestOSAltName = "Microsoft Windows Vista (32-bit)"
guestOS = "winvista"
uuid.location = "56 4d 5b a0 fc 98 cc df-18 96 82 6c ba ae 61 a4"
uuid.bios = "56 4d 5b a0 fc 98 cc df-18 96 82 6c ba ae 61 a4"
toolScripts.afterPowerOn = "true"
toolScripts.afterResume = "true"
toolScripts.beforeSuspend = "true"
toolScripts.beforePowerOff = "true"

floppy0.fileName = "/dev/fd0"

scsi0:0.redo = ""
ethernet0.generatedAddress = "00:0c:29:ae:61:a4"
tools.syncTime = "FALSE"
sched.swap.derivedName = "/vmfs/volumes/4996c81f-1c09578f-d1d6-0012799281f8/srvxxxxxx/srvxxxxxx-ca9d99fe.vswp"
ethernet0.generatedAddressOffset = "0"
hostCPUID.0 = "00000005756e65476c65746e49656e69"
guestCPUID.0 = "00000005756e65476c65746e49656e69"
userCPUID.0 = "00000005756e65476c65746e49656e69"
hostCPUID.1 = "00000f4a000208000000659dbfebfbff"
guestCPUID.1 = "00000f4800010800000000010febfbff"
userCPUID.1 = "00000f4a000208000000659dbfebfbff"
hostCPUID.80000001 = "00000000000000000000000120000000"
guestCPUID.80000001 = "00000000000000000000000000000000"
userCPUID.80000001 = "00000000000000000000000120000000"
evcCompatibilityMode = "FALSE"
ide0:0.fileName = "/usr/lib/vmware/isoimages/windows.iso"

tools.remindInstall = "TRUE"

sched.swap.hostLocal = "disabled"
Bitte warten ..
Mitglied: -ch-ru-
30.03.2010 um 09:59 Uhr
Dann füg mal bitte diesen Wert hinzu:
svga.vramSize = "16777216"

Dann müsste die Maschine 16MB Video-RAM haben
Bitte warten ..
Mitglied: Dominik11
30.03.2010 um 12:40 Uhr
Damit läuft es jetzt - vielen, vielen Dank!

(Warum und wieso das nicht von vorn herein so korrekt in der VM läuft und warum dies so wenig dokumentiert ist... weiß der Teufel)
Bitte warten ..
Mitglied: Dominik11
30.03.2010 um 13:55 Uhr
Falsche Entwarnung, nach dem nächsten Neustart ist das gleiche Problem wieder da

Gibt's doch garnicht...
Bitte warten ..
Mitglied: Dominik11
30.03.2010 um 14:18 Uhr
Lösung gefunden! Nach langem Hin und Her: Es ist mein Notebook, mit dem ich arbeite. Hier habe ich ein externes TFT angeschlossen als zwei-Schirm-Lösung (erweiterter Desktop).

Schalte ich die Desktoperweiterung und damit das externe Display ab, gibt es dieses Problem der VM in dem VI-Client nicht mehr. Und da soll mal jemand drauf kommen....
Bitte warten ..
Neuester Wissensbeitrag
Exchange Server

WSUS bietet CU22 für Exchange 2007 SP3 nicht an. EOL Exchange 2007

Tipp von DerWoWusste zum Thema Exchange Server ...

Ähnliche Inhalte
Hyper-V
gelöst Windows 2012R2 VM nicht per PING erreichbar (4)

Frage von Akcent zum Thema Hyper-V ...

Windows 10
gelöst Windows 10 VM unter Server 2012 R2 Hyper-V (3)

Frage von a1b2c3 zum Thema Windows 10 ...

Windows Server
Sql server 2014 installation auf einer windows server 2012r2 vm (5)

Frage von meister00 zum Thema Windows Server ...

Windows Netzwerk
Windows Server 20012 R2 VPN einrichten in VM (3)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Windows Server
SBS 2011 Standard virtualisieren (14)

Frage von HeinrichM zum Thema Windows Server ...

Backup
Datensicherung ARCHIV (12)

Frage von fautec56 zum Thema Backup ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...