Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Internet Server

Windows Server 2003 - Probleme mit Umlauten bei Get-Formularen

Mitglied: ratlos64

ratlos64 (Level 1) - Jetzt verbinden

11.02.2009, aktualisiert 07:34 Uhr, 3450 Aufrufe, 4 Kommentare

Hallo, habe folgendes Problem:
Auf einem Windows Server 2003 gibt es Probleme beim Absenden von Get-Formularen, sobald Umlaute in input-Feldern enthalten sind. Es kommt der Fehlercode: 500 Interner Serverfehler.

Ganz einfaches Beispiel:
<form method="get" >
<input type="Text" name="a1" value="">
<input type="Submit" name="ok" value="ok">
</form>

wird ein "a" eingegeben, funktioniert alles

wird ein "ä" eingegeben,steht dann zwar richtig in der Adresszeile ...test1.html?a1=%E4&ok=ok,
aber es kommt zum Fehler 500 Interner Serverfehler.

Bei Absenden mit Post klappt alles.

Ich denke, es ist eine Einrichtung des Servers, habe aber Null-Ahnung davon.
Kann mir vielleicht jemand helfen?
Vielen vielen Dank!
Mitglied: mkuchen
11.02.2009 um 09:40 Uhr
Mal als Tipp, falls du mal Programmierer werden willst:

Man benutzt auch keine Umlaute (= und wenn dann versuch´s statt ä mit &auml; ... statt ö mit &ouml; ..... statt ü machste einfach &uuml;

Ich hoffe das hilft dir weiter ....
Bitte warten ..
Mitglied: ratlos64
11.02.2009 um 09:44 Uhr
Nein, leider nicht....
Ich glaube, ich wurde falsch verstanden.
In das Input-Feld können Daten im Browser eingegeben werden und da gibt jemand evtl. einen Namen Bärbel ein und schon klappt das Versenden des Formulars nicht.
Hat also mit Programmieren nichts zu tun.
Bitte warten ..
Mitglied: mkuchen
11.02.2009 um 09:54 Uhr
Ich gehe mal davon aus, dass dein w2k3 server mit nem IIs arbeitet. Dieser IIS kommt dann wohl mit den Umlauten nicht klar.

Man kann das Ganze über string replace methoden abwickeln .... bevor das Formular abgeschickt wird, muss eine Routine den eingetragenen Namen nach Umlauten durchsuchen und diese dann ersetzen. Falls das Formular in einem PHP, ASP, JSP oder wasauchimmer Script steckt, entwickle einfach so eine Methode. Anleitungen dafür gibt´s im www zuhauf, denke ich....
Bitte warten ..
Mitglied: ratlos64
11.02.2009 um 13:32 Uhr
erst mal danke für die schnelle Antwort.
habe inzwischen folgendes herausbekommen:

wird der server normal mit http angesprochen, funktioniert alles.

Ein Fehler kommt nur, wenn man über https, also über einen ISA-Server, diese die Seite aufruft.
Leider verwalte ich die Server nicht und hab da so überhaupt keine
Ahnung.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Server verchluckt Umlaute
gelöst Frage von AzubineWindows Server9 Kommentare

Hallo, wir haben einen ESXI 6.0 neu installiert, so wie 4 Vms (2012 R2). Nun haben wir auf 2 ...

Batch & Shell
PowerShell Get-ADGroupMembership von Workgroup Server aus
gelöst Frage von FlashOverBatch & Shell2 Kommentare

Hallo zusammen. Ich habe ein einfaches Script, welches die Gruppenmitglieder von ein paar Gruppen ausliest. Das wird genutzt um ...

Windows Server
Windows Server 2k16 Druckserver Formulare sperren oder Löschen
Frage von Phill93Windows Server1 Kommentar

Hallo, hab mir einen neuen Druckserver auf Basis von Windows Server 2016 installiert. Was mich schon die ganze Zeit ...

PHP
PHP Adresse mit eigenen GET Parametern als GET Parameter
gelöst Frage von justanumber44PHP3 Kommentare

Hallo :D Wenn ich eine Adresse wie habe, wie schaffe ich es am besten die Adresse als Parameter zu ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 3 TagenSicherheit12 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall10 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS9 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen9 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...

Windows Netzwerk
Zugriff auf den Desktop Ordner eines anderen Rechners in der gleichen Domäne
gelöst Frage von JensNomaWindows Netzwerk6 Kommentare

Guten Abend, ich war neulich mit unserem Admin am Tisch gesessen. Er an seinem Notebook angemeldet mit dem Domänen-Admin, ...