Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server 2003, Routing und Ras parallel zu OpenVPN

Frage Microsoft Windows Server

Mitglied: haufenelend

haufenelend (Level 1) - Jetzt verbinden

13.08.2008, aktualisiert 18.08.2008, 8342 Aufrufe, 3 Kommentare

Probleme beim Parallelbetrieb von OPenVPN auf einem Windows Server 2003 mir Routing und Ras

Hallo zusammen,

ich habe auf einem Windows Server 2003 System seit längerem Routing und Ras für die VPN Einwahl konfiguriert und nutze dies auch erfolgreich.

Ich habe nun die aktuelle OpenVPN Version auf dem selben System installiert, konfiguriert und kann auch eine Verbindung von extern zu dem Server herstellen.

Problem:

Nach erfolgreich einwahl auf dem OpenVpn Server werden keine Daten über diese Verbindung übertragen. Es ist auch nicht möglich den OpenVPN Server vom Client aus anzupingen.

Ich vermute mal, dass daran die Konfiguration / der gleichzeitige Betrieb von Routing und Ras auf dem selben System schuld ist.

Kann mir jemand sagen, welche Einstellungen ich im Routing und Ras vornehmen muss, damit in Zukunft auch Daten übertragen werden?

Ich habe den OpenVPN Adapter auch schon beim NAT eingefügt, brachte aber keinen Erfolg.

Danke fuer eure Untersützung.
Mitglied: robshl
14.08.2008 um 08:11 Uhr
Hallo,


eine solche Konfiguration verwenden wir seit ca. 2 Wochen, da wir die bestehende OpenVPN Verbindungen durch einsitige Einführung von VPN Routern auf RRAS (L2TP) umstellen und daher ein zeitweiliger paralleler Betrieb notwendig ist. Wir haben aber damit aber nicht das oben beschriebene Problem. Wichtig war nur, dass wir eine Batch haben mit der OpenVPN und die damit verbundenen Routen starten:

Bsp:

sleep 10
net start openvpnservice
sleep 10
route add x.x.x.x maks x.x.x.x <OPENVPNIP>

Diese Batch starten wir dann mittels dem Scheduler bei Systemstart.

Mit Routen im RRAS klappt das nicht. Auch mit den Routen in der OpenVPN Koniguration habe ich Probleme gehabt.

Dafür gibt es jetzt das Phänomen, dass diese Server hin und wieder mal einen schönen BSOD zeigen, mit IRQ_LESS_OR_EQUAL. Auch nicht schön. Bei einem Server habe ich jetzt schon OpenVPN deaktiviern können, dort ist es seit dem ruhig.

Ich werde jetzt versuchen die Umstellung schnellstmöglich hinter mich zu bringen.
Bitte warten ..
Mitglied: datasearch
17.08.2008 um 10:31 Uhr
Schade eigentlich. Normalerweise hört man das anders herum. Ich weiß, hat nix mit dem Problem zu tun, aber warum seit ihr denn von OVPN zurück nach L2TP gewechselt? Die zuverlässigkeit beim Tunnelaufbau kann es ja nicht gewesen sein .

Vieleicht ein fehlendes feature oder zu komplizierte Verwaltung des Systems? Wenn du lust und Zeit hast, würde ich mich über eine Antwort freuen.

Hallo haufenelend,

normalerweise ist das eine übliche konfiguration für OpenVPN. Es sollte unter Windows, auch auf einem Server mit aktiviertem Routing-Dienst installiert werden. Sonst hätte man ja nur sehr schwer die kontrolle über statische Routen, Routingprotokolle usw.

Bitte nicht das NAT auf der OpenVPN TAP/TUN schnitstelle aktivieren. Das macht Probleme. Auch musst du, wenn ein DHCP-Server läuft, diesen auf dieser deaktivieren.

Kannst du die IP des OpenVPN-Servers innerhalb des VPN-Segments anpingen? Also vom VPN-Server aus? Funktioniert es auch noch von einem Client im selben Subnet wie der Server? Nicht das du ein Problem mit dem Routing in das OVPN Netz hast. Klingt fast danach. Poste am besten mal die relevanten Einträge aus der Konfig und die Netzadressen deines VPN-Netzes. Bitte auch mal die Netze die du dem RRAS-Dienst für Einwahl zugewiesen hast.
Bitte warten ..
Mitglied: robshl
18.08.2008 um 12:51 Uhr
Hallo,

auch wenn es etwas OFF-Topic ist:

es gabe da einige Restriktionen im Netzwerk, die dazu führten, dass es sinnvoller wäre RRAS zu verwenden.

Ferner kann hier im Hause nur einer Routing, und mit der grafischen Oberfläche ist es evtl. einfacher einem Laien das zu erklären.

Das wäre es vielleicht auch, wenn der BSOD nicht so oft gekommen wäre, es war auch an verschiedenen Standorten mit unterschiedlichen Konfigurationen so, dass IPNAT.SYS eine Ausnahme erzeugt hatte, während OpenVPN immer stabil war. Zum Glück waren es im Ausland virtuelle Maschinen, so dass ich über 'Noteingänge' diese booten konnte.

Und was ist die Moral: Ich habe mich bekehren lassen, eine kleine Appliance mit OpenVPN installiert, OpenVPN von Windows auf Linux migriert (in einem neuen Subnetz, das war der Grund) und bin wieder da wo wir waren, und das auch wieder stabil.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Routing Problem (Windows Server Routing und RAS)
Frage von filou204Router & Routing5 Kommentare

Hi zusammen, ich habe ein Routing-Problem und hoffe hier auf Hilfe. Hier mal die Sittuation: Weil die DSL Leitung ...

Windows Server
Windows Server 2008 - Routing und Ras
gelöst Frage von KlaraFallWindows Server7 Kommentare

Hallo alle zusammen, wir sind gerade dabei, den als VPN-Server genutzten Server 2003 durch einen Server 2008 zu ersetzen. ...

Windows Server
Routing und Ras bei Windows Server 2012 R2
gelöst Frage von BlacksGoodWindows Server12 Kommentare

Moin Moin! Ich hab grade folgendes Problem und hab grade wohl ein Brett vorm Kopf oder bin einfach nur ...

Windows Server
Server 2008 Ras u Routing
Frage von opc123Windows Server4 Kommentare

Hallo, Brauche mal hilfe bezüglich des Routing. Habe zwar paar anleitungen gefunden. Aber keine die mir weiter hilft. Mein ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...