Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server Port nicht verwendbar

Frage Microsoft Windows Netzwerk

Mitglied: smorod

smorod (Level 1) - Jetzt verbinden

18.12.2013 um 15:21 Uhr, 1187 Aufrufe, 3 Kommentare

Hallo liebe Administratoren,

ich habe hier ein seltsames Phänomen... Auf unseren Servern laufen unterschiedliche hauseigene Programme, welche per TCP miteinander reden.

Pro Kunde gibt es jeweils eine Instanz von den Programmen und jeder Kunde hat einen eigenen TCP Port.

wir haben nun das Problem zum Beispiel, dass der Port 10035 bereits belegt ist.
mit netstat -ano, bekommen wir jedoch kein einziges Ergebnis mit dem Port 10035.

Das gleich Problem hatten wir schon mit einem anderen Port. Serverneustarts bringen leider keine Besserung.

In den Eventlogs gibt es leider nur folgende Meldung:
Error: Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden

Hat von euch schon mal mit ein ähnlichen Problem zu tun gehabt?

Mit freundlichen Grüßen,
Smorod
Mitglied: Dobby
18.12.2013 um 15:27 Uhr
Hallo,

wir haben nun das Problem zum Beispiel, dass der Port 10035 bereits belegt ist.
Kann man denn an dem Programm (Eurem) nicht einfach einen anderen Port einstellen
und dann läuft es wieder rund?

mit netstat -ano, bekommen wir jedoch kein einziges Ergebnis mit dem Port 10035.
Wäre eventuell eine Switch mit einem Monitor Port (mirrored Port) eine Lösung, der dann
auf einen PC oder Server mit installiertem WireShark die gewünschte Information liefert?

Gruß
Dobby
Bitte warten ..
Mitglied: smorod
18.12.2013 um 17:50 Uhr
Hallo D.o.b.b.y,

vielen Dank für deine Antwort.

Den Port können wir schon ändern, das ist weniger das Problem.

Wir würden halt gerne nachvollziehen können wie dies zustande kommt.
Diese Programme liefen jetzt mehrere Monate mit diesem Port und von heute auf morgen, funktioniert dieser Port nicht mehr.

Das mit dem Monitor Port werde ich mal mit den Kollegen besprechen. Vielen Dank für den Hinweis.

LG
Smorod
Bitte warten ..
Mitglied: Dobby
18.12.2013 um 18:15 Uhr
Das mit dem Monitor Port werde ich mal mit den Kollegen besprechen.
Idealer Weise an einem Knoten also einem Core Switch aufgesetzt bzw. konfiguriert und mit dem einen
oder anderem Filter in WireShark sollte das recht schnell heraus zu finden sein, für Euch.

Den Port können wir schon ändern, das ist weniger das Problem.
Dann würde ich auch einmal schnell und wenn es nur als "Workarround" also behelfsmäßig
ist den Port ändern und dann kann man ja weiter sehen das erst einmal das Problem weg ist
wenn Ihr denn herausgefunden habt woran es lag.

Diese Programme liefen jetzt mehrere Monate mit diesem Port und von heute auf morgen,
funktioniert dieser Port nicht mehr.
Ja so sieht es in der Regel erst einmal aus, aber wenn es anders herum ist und das ganze Konstrukt
nur gerade mal so lief und dann der eigentlich schon länger vorhandene Fehler auftrat ist guter Rat immer
teuer. Ich würde die VMs mit den Programmen einmal in VLANs mit eigenen Broadcast Domains packen
und dann sehen ob der Fehler damit nicht ganz verschwunden ist. Außerdem kann man so solche Fehler
schneller eingrenzen denn über die Broadcat Domain hinaus wird der verkehr natürlich auch nicht weitergeleitet.

Ist ja nur so eine Idee von mir dazu.

Gruß
Dobby
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Hyper-V
Windows Server 2012 R2 NIC Teaming mit Lancom Switch (2)

Frage von onkel87 zum Thema Hyper-V ...

Windows Server
Mailserver auf Windows Server 2012 (10)

Frage von StefanT81 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...