Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

WMIC Abfrage funktioniert in CMD aber nicht in Batch

Frage Entwicklung Batch & Shell

Mitglied: matschbirne

matschbirne (Level 1) - Jetzt verbinden

15.11.2012, aktualisiert 19:42 Uhr, 4420 Aufrufe, 2 Kommentare

Hallo und Guten Abend zusammen,

ich komme gerade nicht weiter und obwohl ich schon das halbe Netz abgegrast habe, finde ich keine Antwort (wahrscheinlich nur weil ich gerade betriebsblind bin):

Ich will feststellen welche Prozesse innerhalb eines Pfades ablaufen, das Ganze mit WMIC in einer Batch. Im CMD funktioniert es auch, aber sobald ich es als Batch speichere nicht (getestet unter WinXP32bit/Win764bit):

01.
wmic process where "commandLine like '%net%'" get name
->liefert mir alle Prozesse in denen "net" im Pfad vorkommt.
als Batch ausgeführt aber nur "Keine Instanzen verfügbar"

Variationen davon verhalten sich identisch, also z.B.:
01.
wmic path win32_process Where "commandLine like '%net%'" get name
oder
01.
wmic process where "executablepath like '%net%'" get name
CMD geht, Batch nicht... vbs geht auch, aber warum nicht in Batch?

Bin dankbar für jeden Rat...

Viele Grüße,
matschbirne
Mitglied: DerWoWusste
15.11.2012 um 20:20 Uhr
Hi.

Editier mal auf %%net%%
...ist so in Batch.
Bitte warten ..
Mitglied: matschbirne
15.11.2012 um 20:31 Uhr
Vielen Dank, das war's...
Bitte warten ..
Ähnliche Inhalte
C und C++
gelöst IF Abfrage funktioniert nicht mehr (2)

Frage von pablovic zum Thema C und C ...

Batch & Shell
gelöst CMD Verschlüsslung ( Batch ) (12)

Frage von clragon zum Thema Batch & Shell ...

Batch & Shell
Batch, CMD - Prüfen ob ein Dienst existiert, nicht läuft (4)

Frage von RycoDePsyco zum Thema Batch & Shell ...

Batch & Shell
gelöst Batch mit Copy auf SBS2008 funktioniert nicht, auf Client geht es (9)

Frage von CyCOtt zum Thema Batch & Shell ...

Neue Wissensbeiträge
Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Windows Server

Exchange 2010 auf Windows Server 2016 und AD

(2)

Tipp von Herbrich19 zum Thema Windows Server ...

KVM

How to: Libvirt Port forwarding

(2)

Anleitung von fundave3 zum Thema KVM ...

Heiß diskutierte Inhalte
Router & Routing
über Vmware auf eine FritzBox mit IPv6 per VPN (17)

Frage von Zockervogel zum Thema Router & Routing ...

Windows Server
gelöst Netzlaufwerk RemoteApp auf Win 2012 R2 Terminalserver funktioniert nicht (12)

Frage von grenzde zum Thema Windows Server ...

Basic
Programmierung von Windows Programmen (8)

Frage von Ghost108 zum Thema Basic ...