Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

XP SP2 findet seine eigenen Standarttreiber nicht mehr

Frage Microsoft Windows Systemdateien

Mitglied: karlson

karlson (Level 1) - Jetzt verbinden

05.09.2006, aktualisiert 18.10.2012, 4076 Aufrufe, 3 Kommentare

Habe ein notebook XP SP2, dass anscheinend nicht mehr auf seine Treiberdatenbank zugreift.

Das Problem fing an mit der Installation eines USB-Sticks. Hardware-Assistemt (auf automatische Treibersuche) findet keinen Treiber (unbekanntes USB-Gerät).
Problem besteht auch bei allen anderen USB und PCMCIA-Geräten die ich versucht habe. Auch wenn man den Treiber direkt wählt, kommt die Meldung kein Treiber gefunden.

Bin jetzt wenigtstens für den USB-Stick etc. auf eine peinlich banale Lösung gekommen. Wenn man ihn unter %Systemroot%\inf suchen lässt wird der Stick erkannt und geht. Das Stellt mich allerdings nach einigen Stunden suchen nicht wirklich zufrieden, da:
1. Ich nicht der User des Rechners bin
2. z.B. alles was einen "eigenen" Treiber hat so nicht installiert werden kann (PCMCIA Wlan Karte etc.)
3. Es einfach eine unsaubere Lösung ist

Habe u.A. fogendes versucht:

- infcache.1 gelöscht (sollte doch neu angelegt werden, oder? tut aber nicht!)
- SP2 neu drüber gespielt (driver.cab und INFs werden dabei denke ich alle erneuert)
- biosupdate
- winupdate
- netzteil ab und akku raus
- regcleaner
- "treiberleichen" beseitigt

Gibt es vielleicht in der Reg einen Eintrag, der festlegt wo Win seine Harwareinformationen herholen soll?

Neuinstallation wäre keine so gute Idee....

Sorry, bin sicherlich in der falschen Kategorie gelandet. Habe aber keine richtig passende gefunden.
Vielen Dank schon mal im Vorraus für die Antworten!

Gruß
Tobias
Mitglied: ulli1966
05.09.2006 um 10:26 Uhr
Gibt es vielleicht in der Reg einen Eintrag,
der festlegt wo Win seine
Harwareinformationen herholen soll?

Hallo,
schau mal da rein:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

DevicePath = %SystemRoot%\inf (REG_EXPAND_SZ)

Was besseres fällt mir auch nicht ein.

Grüße Ulli
Bitte warten ..
Mitglied: leknilk0815
05.09.2006, aktualisiert 18.10.2012
Hi,
geh in den Gerätemanager und schmeiß mit "deinstallieren" gnadenlos alles raus, was irgendwie mit USB, PCMCIA usw. zu tun hat.
Nach einem Reboot sollte er sich reorganisieren.
Wenn das keinen Erfolg bringt, würde ich eine Reparaturinstallation laufen lassen.
Wie das geht, findest hier:
http://www.administrator.de/wissen/reparaturinstallation-windows-xp-pro ...

Gruß - Toni
Bitte warten ..
Mitglied: karlson
05.09.2006 um 12:20 Uhr
Super! Hab's hinbekommen.

In der Reg stand "systemroot%\inf..." statt "%systemroot%\inf". Danach hab ich noch mal alle nicht erwendeten, nicht erkannten und sonstigen Geräte die mit USB und PCMCIA zu tun haben im Gerätemanager deinstalliert. Hat gleich alles wieder erkannt und treiber geladen. Infcache.1 wird auch wieder angelegt und bei "treiber selbst wählen" sind auch alle Standarttreiber wieder in der Liste (war vorher leer).

Scheint also alles wieder zu funktionieren. Bleibt nur noch ein komischer Beigeschmack wie einfach ein ein Zeichen aus einem Reg-Wert verschwinden kann. Dass da jmd händisch was gemacht hat kann ich eigentlich mit Sicherheit auschließen. Alleine schon wegen den Rechten. War das evtl. ein Speicherfehler der beim schieben aufgetreten ist?
Bleibt nur zu hoffen das sowas nicht wieder auftritt.

Vielen Dank auf jeden Fall für eure Antworten!!!

Werde mir gleich mal ein Image von der Installation ziehen. Btw weiß jmd wie ich in regelmäßigen Abstanden ein Backup von der Reg auf einen Server schiebe oder vom Server holen lasse? Da muss ich doch erstmal in eine reg-Datei exportieren, oder?

Gruß
Tobias
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows 7
Wsus client findet am wsus server nicht alle updates (3)

Frage von endurance zum Thema Windows 7 ...

Outlook & Mail
Spam von angeblich eigenen internen Adressen (6)

Frage von JensDND zum Thema Outlook & Mail ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
RODC über VPN - Verbindung weg (10)

Frage von stefan2k1 zum Thema Windows Server ...