Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zertifikatfehler

Frage Netzwerke Netzwerkmanagement

Mitglied: hajowe

hajowe (Level 2) - Jetzt verbinden

24.06.2010 um 16:13 Uhr, 5315 Aufrufe, 5 Kommentare

Hallo und einen lieben Gruß an Alle.

Ich habe ein eigenes Zertifikat erstellt um per Internetexplorer mit https auf einen Server zugreifen zu können.

Jetzt ist aber das Problem das wenn man eigene Zertifikate nutzt, die von keiner CA Stelle beglaubigt sind der Internetexplorer immer
vor dem Öffnen der Verbindung eine Nachricht ausgibt und darauf hinweist das das Zertifikat nicht sicher sei.

Dann muss man ihm immer anklicken das er dennoch laden soll.

Alle meine Versuche dem Internetexlorer dieses als akzeptabel in seinen Zertifikatsspeicher zu geben waren bisher erfolglos.

Kann mir Jemand sagen was ich falsch mache und ob es überhaupt machbar ist das er nichts sagt bzw. dieses akzeptiert.

Danke für Eure Bemühungen
Mitglied: sniffnase
24.06.2010 um 16:25 Uhr
Das ist mit self-signed certificates nicht so einfach.. aber es geht.

Wie genau hast du das Zertifikat erstellt?
Wurde es Ausgestellt für den FQDN des Servers zu dem du dich verbinden möchtest?

Du musst es in den Zertifikatspeicher 'Vertrauenswürdige Stammzertifizierungsstellen' vom COMPUTERKONTO importieren.
(MMC öffnen - Snap-in Zertifikate - Lokales COMPUTERkonto)

Wird der Server über die gleiche URL angesprochen die auch im Zertifikat vermerkt ist?
Bitte warten ..
Mitglied: hajowe
24.06.2010 um 16:53 Uhr
Hallo Sniffnase,

nein ganz so einfach ist es wiederum auch nicht da die Seite bez. der Aufruf sich ändert.

Es ist ein Lotus Notes Domino Server.
Dort wurde eine CA eingerichtet und SSL aktiviert.
Damit hat man dann wieder die Möglichkeit sich per https auf seine Maildatenbank zu verbinden.

Aufruf: https:\\servername\mail\Maildatenbankname

Der Maildatenbankname ist natürlich abhängig vom Benutzer und somit jedesmal verschieden.
Ausgestellt ist das Zertifikat auf den DNS-Namen also Kurzfom nicht FQDN (ohne Domainnamen und Topleveldomäne)
Bitte warten ..
Mitglied: sniffnase
24.06.2010 um 18:18 Uhr
Zitat von hajowe:
Hallo Sniffnase,

nein ganz so einfach ist es wiederum auch nicht da die Seite bez. der Aufruf sich ändert.

Ich sagte ja es ist nicht ganz so einfach

Es ist ein Lotus Notes Domino Server.
Dort wurde eine CA eingerichtet und SSL aktiviert.
Damit hat man dann wieder die Möglichkeit sich per https auf seine Maildatenbank zu verbinden.

Aufruf: https:\\servername\mail\Maildatenbankname


es muss ja nur der domainname übereinstimmen, also das was hinter https:// steht, oder ändert sich der servername auch ständig? dann musst du die zertifikate aller dieser server von deiner CA erstellen lassen
Die Zertifikate können dann auch über GPO Verteilt werden.

Der Maildatenbankname ist natürlich abhängig vom Benutzer und somit jedesmal verschieden.
Ausgestellt ist das Zertifikat auf den DNS-Namen also Kurzfom nicht FQDN (ohne Domainnamen und Topleveldomäne)


Welche Zertifikatfehler bekommst du genau?
Dass die URL nicht mit dem Namen übereinstimmt, oder dass das Zertifikat von keiner vertrauenswürdigen Zertifizierungsstelle kommt? (hast du evtl. einen screenshot?)
Hast du bereits versucht das Zertifikat zu exportieren und wie von mir oben beschrieben zu importieren?
Was für einen webserver verwendest du?
Bitte warten ..
Mitglied: hajowe
25.06.2010 um 10:35 Uhr
Es kommt dassdas Zertifikat von keiner vertrauenswürdigen Zertifizierungsstelle kommt
Exportiert und importiert habe ich auch schon

Webserver ist der von Lotus Domino Enterprise.

Es könnte auch sehr wohl vorkommen das der Servername ändernt, nämlich dann falls Notes auf den Clusterserver umschaltet.
Klar das dieser dann auch ein eigenes selbsterstelltes Zertifikat benötigt.
Bitte warten ..
Mitglied: hajowe
14.07.2010 um 16:07 Uhr
Na da hier denke ich nichts weiteres kommt werde habe ich es, obwohl noch nicht mal als gelöst markiert.
Denke das ich mich zu gegebener Zeit nochmal darum kümmere
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...