Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

kein Zugriff auf Maxtor Shared Storage II per VPN

Frage Netzwerke

Mitglied: Janni

Janni (Level 2) - Jetzt verbinden

10.10.2008, aktualisiert 13.10.2008, 6073 Aufrufe, 5 Kommentare

Moinsen,

wird per VPN (OpenVPN) auf das Büronetz zugegriffen ist leider keine Verbindung mit dem NAS (Maxtor Shared Storage II) möglich. Dies beinhaltet sämtliche Verbindungen, sowie auch Pings, etc.. Im Büro selber ist der Zugriff auf den NAS kein Problem.

Ein klein wenig zum Rahmen:
Büro:
Netz: 192.168.69.0
Subnetz: 255.255.255.0

VPN:
Netz 192.168.68.0
Subnetz: 255.255.255.0

NAS/ Maxtor Shared Storage II
IP: 192.168.69.72
Subnetz: 255.255.254.0
Ordner: öffentlicher Zugriff
neueste Firmware (3.1.28)

Das arbeiten per OpenVPN-Verbindung im Netz des Büros ist problemlos möglich. Hier ist der Zugriff auf alle Rechner gegeben (zum Beispiel auf den Server 192.168.69.1).

Komischerweise müsste selbst ohne NAT, etc. der Zugriff aus dem Netz 192.168.68.0 durch die Subnetmaske auf den NAS möglich sein.

Hat Jemand eine Idee ?

Und Danke schon einmal.
Mitglied: Arch-Stanton
10.10.2008 um 08:16 Uhr
falsche Subnetzmaske beim NAS?

Gruß, Arch Stanton
Bitte warten ..
Mitglied: Janni
10.10.2008 um 08:35 Uhr
Die 255.255.254.0 sollte eigentlich das 192.168.68.0er Netz mit abdecken .... funktioniert aber auch mit einem 255.255.0.0 nicht.
Bitte warten ..
Mitglied: aqui
10.10.2008 um 21:14 Uhr
Nein, das ist voelliger Unsinn, denn die Clients haben ja noch eine 24 Bit Subnetzmaske und fuer die ist das NAS schlicht und einfach in einem anderen IP Netz bzw. fuer sie im falschen Netz und ohne Router nicht zu erreichen !
Du machst auch einen erheblichen Denkfehler, denn der OpenVPN Server routet das .68er Netz ja in eurer lokales Netzwerk !!!

Ausserdem hast du somit inkonsistente Subnetzmasken in deinem .69er Netzwerk was ein absolutes NO GO ist in einem IP Netz !!! Abgesehen davon ist es mehr als fraglich ob das NAS mit CIDR IP Adressen umgehen kann ?!

Das solltest du also schnellstens wieder rueckgaengig machen !!!

Du hast nichts anderes als ein simples und banales Routing Problem, sonst nix.
Vermutlich hat das NAS schlicht und einfach gar keinen Gateway Eintrag. Oder wenn doch, dann hat es den falschen !!
Wenn du das NAS Gateway auf die IP Adresse des OpenVPN Servers einstellst sollte es anstandslos funktionieren.

Mit einem Traceroute oder Pathping vom Client kannst du ja sofort sehen wo der Datenfluss haengenbleibt und da ist auch meist das Problem !!!
Kannst du auf andere Geraete im .69er netz vom VPN Client pingen ???
Bitte warten ..
Mitglied: Janni
11.10.2008 um 01:29 Uhr
Kannst du auf andere Geraete im .69er netz vom VPN Client pingen ???

Ja, kann ich und ich kann wunderbar auf sie zugreifen.

Du machst auch einen erheblichen Denkfehler, denn der OpenVPN Server routet das .68er Netz ja in
eurer lokales Netzwerk !!!
Soll er ja

Ausserdem hast du somit inkonsistente Subnetzmasken in deinem .69er Netzwerk was ein absolutes NO GO
ist in einem IP Netz !!! Abgesehen davon ist es mehr als fraglich ob das NAS mit CIDR IP Adressen
umgehen kann ?!
Warum sollte er das nicht ?


Und ja, beim NAS ist der Gateway und der DNS auf dem VPN Server gesetzt, sollte also eigentlich gehen (wenn man sich die theoretischen Werte anschaut). Naja soweit gedacht, geht ja leider trotzdem nicht ...... also mache ich irgendwo einen Denk-, bzw. Einstellungsfehler....
Bitte warten ..
Mitglied: Janni
13.10.2008 um 13:52 Uhr
Lösung:

Wenn auf den NAS der Arbeitsgruppenname falsch geschrieben ist, dann geht auch der Zugriff aus einem anderen Subnet nicht ... warum auch immer. Ist der Arbeitsgruppenname gleich der Domäne, dann geht auch der Zugriff.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Hosting & Housing
Günstiger Aktiv-Passiv Cluster für Linux-VMs ohne shared Storage (2)

Frage von EDVMan27 zum Thema Hosting & Housing ...

Router & Routing
Kein Zugriff auf NAS über VPN bei einigen Providern (9)

Frage von ChrisXmas zum Thema Router & Routing ...

Router & Routing
gelöst Site to Site VPN mit PfSense - Zugriff auf Remote Netze nicht möglich. (6)

Frage von RRESEARCH zum Thema Router & Routing ...

Router & Routing
gelöst Zugriff vom Terminalserver auf lokalen Netzwerdrucker ( VPN ) (8)

Frage von takvorian zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (13)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Viren und Trojaner
Wie werde ich den Mist "fanli90" wieder los? (12)

Frage von Taumel zum Thema Viren und Trojaner ...