Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anbindung eines iPhone an einen Cisco Router mit dynamischer ISP Adressse via IPSec VPN über den iPhone Cisco Client

Mitglied: mayjalin

mayjalin (Level 1) - Jetzt verbinden

22.01.2013, aktualisiert 12:59 Uhr, 5479 Aufrufe, 3 Kommentare, 1 Danke

Hallo,

hier ist eine Konfiguration eines Routers, der IPSec zu einem iPhone schaft. Das iPhone wird in diesem Beispiel mit einem DynDNS Namen konfiguriert, der mit einem DynDNS Client auf einem Client im LAN aktuallisiert wird.
01.
aaa new-model 
02.
03.
aaa authentication enable default group tacacs+ enable 
04.
aaa authorization network CRYPTO_ISAKMP_CLIENT local 
05.
06.
username {MyUsername} secret {MySecret} 
07.
08.
crypto logging session 
09.
10.
crypto isakmp policy 1 
11.
encr aes 256 
12.
authentication pre-share 
13.
group 2 
14.
lifetime 3600 
15.
crypto isakmp keepalive 10 
16.
crypto isakmp nat keepalive 20 
17.
crypto isakmp xauth timeout 90 
18.
19.
crypto isakmp client configuration group CRYPTO_ISAKMP_CLIENT 
20.
key {MyVpnKey} 
21.
dns {MyInternalDNS} 
22.
domain {MyInternalDomainName} 
23.
pool VPN-POOL 
24.
save-password 
25.
26.
crypto ipsec security-association lifetime seconds 86400 
27.
crypto ipsec security-association idle-time 3600 
28.
29.
crypto ipsec transform-set VPN-TRANSFORMSET esp-aes 256 esp-sha-hmac 
30.
31.
crypto dynamic-map CRYPTO_ISAKMP_CLIENT 1 
32.
set transform-set VPN-TRANSFORMSET 
33.
reverse-route 
34.
35.
crypto map STATIC_CRYPTO_MAP local-address Dialer0 
36.
crypto map STATIC_CRYPTO_MAP client authentication list CRYPTO_ISAKMP_CLIENT 
37.
crypto map STATIC_CRYPTO_MAP isakmp authorization list CRYPTO_ISAKMP_CLIENT 
38.
crypto map STATIC_CRYPTO_MAP client configuration address respond 
39.
crypto map STATIC_CRYPTO_MAP 1 ipsec-isakmp dynamic CRYPTO_ISAKMP_CLIENT 
40.
41.
interface Vlan{MyVlanId} 
42.
ip address {MyInternalIpAddress} {MyInternalSubnetmask} 
43.
ip nat inside 
44.
ip virtual-reassembly 
45.
ip tcp adjust-mss 1412 
46.
47.
interface Dialer0 
48.
description "-> WAN" 
49.
ip access-group 101 in 
50.
ip address negotiated1 
51.
ip mtu 1452 
52.
ip nat outside 
53.
ip virtual-reassembly 
54.
encapsulation ppp 
55.
dialer pool 1 
56.
dialer-group 1 
57.
ppp authentication chap callin 
58.
ppp chap hostname {MyProviderUsername} 
59.
ppp chap password {MyProviderPassowrd} 
60.
crypto map STATIC_CRYPTO_MAP 
61.
62.
ip local pool VPN-POOL 10.0.0.250 10.0.0.254 
63.
64.
ip route 0.0.0.0 0.0.0.0 Dialer0 
65.
66.
ip nat inside source list 1 interface Dialer0 overload 
67.
68.
access-list 1 permit {MyInternalNetwork} {MyInternalWildCard} 
69.
access-list 101 remark ---> Internet LAN 
70.
access-list 101 permit icmp any any echo-reply 
71.
access-list 101 permit icmp any any time-exceeded 
72.
access-list 101 permit icmp any any unreachable 
73.
access-list 101 permit udp any any eq isakmp 
74.
access-list 101 permit udp any any eq non500-isakmp 
75.
access-list 101 deny icmp any any 
76.
access-list 101 deny ip 10.0.0.0 0.255.255.255 any 
77.
access-list 101 deny ip 172.16.0.0 0.15.255.255 any 
78.
access-list 101 deny ip 192.168.0.0 0.0.255.255 any 
79.
access-list 101 deny ip 127.0.0.0 0.255.255.255 any 
80.
access-list 101 deny ip host 255.255.255.255 any 
81.
access-list 101 deny ip host 0.0.0.0 any 
82.
access-list 101 deny ip any any 
83.
84.
dialer-list 1 protocol ip permit
Mitglied: aqui
24.01.2013, aktualisiert 16.06.2013
Kleine kosmetische Konfig Korrektur:
Bei Dialer Interfaces sollte man möglichst vermeiden ip route 0.0.0.0 0.0.0.0 Dialer0 zu nutzen, denn das nagelt die Route auf ein statisches Interface. PPPoE (oder andere Dial Protokolle) nutzt aber immer ein virtuelles dynamisches Interface !
Besser also die default Route auch dynmaisch mit dem Interface zu wechseln indem man die obige statische Route sinnvoller mit:
ppp ipcp route default
unter dem Dialer Interface ersetzt !
Beispiel siehe hier:
https://www.administrator.de/contentid/179345
Bitte warten ..
Mitglied: mayjalin
24.01.2013 um 21:40 Uhr
Hallo aqui,

ansich ist es ein guter Ansatz den Du bringst. Aber leider wird dies in meiner IOS Version leider nicht unterstützt, daher habe ich die statische Route gesetzt und die dyn. Route zum VPN Client, die auto. bei der Einwahl erzeugt wird, zieht in diesem Fall vor der default Router.
Bitte warten ..
Mitglied: aqui
25.01.2013 um 21:42 Uhr
Kann eigentlich nicht sein ?! Ist in den letzten 10 Jahren ! in jedem IOS implemetiert das PPP supportet. Sollte also auch bei dir der Fall sein ?!
Bitte warten ..
Ähnliche Inhalte
Netzwerke

IPsec VPN für mobile Benutzer auf der pfSense Firewall einrichten

Anleitung von aquiNetzwerke10 Kommentare

Allgemeine Einleitung Das folgende Tutorial ist eng angelehnt an das hiesige Standort_VPN_Praxis_Tutorial bei Administrator.de und ergänzt dieses um die ...

Netzwerke

IPsec VPN Praxis mit Standort Kopplung zw. Cisco, IPCop, pfSense, FritzBox und mehr

Anleitung von aquiNetzwerke20 Kommentare

Allgemeine Einleitung Das folgende Tutorial ist eine Erweiterung des hier bei Administrator.de schon bestehenden IPsec_VPN_Grundlagen_Tutorials und soll in loser ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgbornSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Windows Server
NTFS Berechtigungen Ordnerstruktur
Frage von hukahu23489Windows Server11 Kommentare

Hallo, ich bin seit kurzem in einer neuen IT-Abteilung und bin über das Berechtigungskonzept des Unternehmens sehr schockiert. Ich ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...