Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NetBIOS via DHCP-Option deaktivieren verursacht Fehler bei PXE-Boot

Tipp Netzwerke LAN, WAN, Wireless

Mitglied: dog

dog (Level 4) - Jetzt verbinden

13.11.2014, aktualisiert 16:18 Uhr, 2939 Aufrufe, 2 Danke

Symptome


  1. Beim Starten des PCs via PXE erscheint die Fehlermeldung: PXE-E55: proxyDHCP did not reply to request on port 4011
  2. Auf dem WDS-Server ist Port udp/4011 geöffnet und in der Firewall freigegeben.
  3. Mit WireShark o.Ä. lässt sich nicht erkennen, dass der PXE-Client einen Verbindungsaufbau versucht.
  4. Vom DHCP-Server wird die Option NetBIOS via TCP/IP (de-)aktivieren verteilt.

Ursache


Neben den normalen, standardisierten, DHCP-Optionen gibt es noch die Option 43, welche für herstellerspezifische Erweiterungen verwendet wird. Da die Hersteller die Verwendung der Option nicht untereinander abstimmen müssen, kann es zu Konflikten kommen. Ein solcher sind die Optionen PXE: Multicast-Server IP (pxe.mtftp-ip) und Microsoft: NetBIOS über TCP/IP (msft.nbt). Beide haben den Code 0x01 und sind 4 Bytes lang.

Lösung


Entweder muss die NetBIOS-Option wieder aus dem DHCP-Server entfernt werden, wenn PXE verwendet werden soll -- oder es muss ein DHCP-Server eingesetzt werden, der Optionen auf Basis der DHCP Vendor-Class-Id setzen kann (z.B. ISC DHCP). Generell sollte die Option 43 immer nur an die Clients verteilt werden, die sie auch verstehen können/sollen, da es sonst zu unerwünschten Effekten kommen kann.
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Linux
LTSP: PXE Boot funktioniert nicht (23)

Frage von Fenris14 zum Thema Linux ...

Windows Installation
PXE Boot-Von CD Starten (2)

Frage von STITDK zum Thema Windows Installation ...

Windows Server
Treiber für PXE Boot mit Realtek gesucht (5)

Frage von tobivan zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...