Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Batch Sprungmarke geht nicht

Mitglied: Errator

Errator (Level 1) - Jetzt verbinden

18.06.2007, aktualisiert 10:57 Uhr, 7363 Aufrufe, 6 Kommentare

Hallo,

ich lasse per GPO beim Anmelden am Server folgende batch ausführen:


[code]
net use I: \\fileserver\abteilung$\alle
net use Z: \\scannerpc\fax
net use N: \\fileserver\abteilung$\qm-um
net time \setsntp:192.168.19.254


if %username% == mario.luft GOTO ML
if %username% == olaf.lehmann GOTO OL
if %username% == kathrin.listing GOTO KL
if %username% == kerstin.herfurth GOTO KH
if %username% == anke.kitze GOTO AK

:ML
net use G: \\192.162.1.8\share$
net use P: \\fileserver\startcenter


:OL
net use G: \\192.162.1.8\share$
net use P: \\fileserver\startcenter
net use S: \\fileserver\abteilung$\technik

:KL
net use G: \\192.162.1.8\share$
net use P: \\fileserver\startcenter

:KH
net use G: \\192.162.1.8\share$
net use P: \\fileserver\startcenter

:AK
net use G: \\192.162.1.8\share$
net use P: \\fileserver\startcenter

*Namen exemplarisch*
[/code]


Nun habe ich das Problem, dass egal wer sich anmeldet (also kein User der hier aufgeführt wird. Immer die Laufwerke vom ersten Sprungbefehl (ML) verbunden bekommt.

Ich weiss leider nicht wo der Fehler ist.

mfg

Mario
Mitglied: Notavailable
18.06.2007 um 10:35 Uhr
Hi!

AFAIK werden die Einsprungpunkte sowieso abgearbeitet. D.h. Er passiert deine if's, und wenn keine davon zutrifft, geht er an die einzelnen Abschnitte.
Mach einfach ein
goto END
nach die if's und ein
:END
ganz ans Ende.
Damit bekommt jemand, auf den das nicht zutrifft, gar nix aus dem unteren Abschnitt.
Eine alternative wäre ein CASE Schalter.

HTH
Bitte warten ..
Mitglied: bastla
18.06.2007 um 10:41 Uhr
Hallo Errator!

Eine mögliche Fehlerquelle wäre die Groß-/Kleinschreibung der Usernamen, daher besser "if /i" verwenden. Abgesehen davon sollte nach jedem Block ein Sprung über die restlichen Blöcke hinweg vorgesehen werden, also etwa so:
01.
net use I: \\fileserver\abteilung$\alle 
02.
net use Z: \\scannerpc\fax 
03.
net use N: \\fileserver\abteilung$\qm-um 
04.
net time \setsntp:192.168.19.254 
05.
 
06.
if /i "%username%"=="mario.luft" GOTO :ML 
07.
if /i "%username%"=="olaf.lehmann" GOTO :OL 
08.
if /i "%username%"=="kathrin.listing" GOTO :KL 
09.
if /i "%username%"=="kerstin.herfurth" GOTO :KH 
10.
if /i "%username%"=="anke.kitze" GOTO :AK 
11.
goto :eof 
12.
 
13.
:ML 
14.
net use G: \\192.162.1.8\share$ 
15.
net use P: \\fileserver\startcenter 
16.
goto :Weiter 
17.
 
18.
:OL 
19.
net use G: \\192.162.1.8\share$ 
20.
net use P: \\fileserver\startcenter 
21.
net use S: \\fileserver\abteilung$\technik 
22.
goto :Weiter 
23.
 
24.
 
25.
:KL 
26.
net use G: \\192.162.1.8\share$ 
27.
net use P: \\fileserver\startcenter 
28.
goto :Weiter 
29.
 
30.
 
31.
:KH 
32.
net use G: \\192.162.1.8\share$ 
33.
net use P: \\fileserver\startcenter 
34.
goto :Weiter 
35.
 
36.
:AK 
37.
net use G: \\192.162.1.8\share$ 
38.
net use P: \\fileserver\startcenter 
39.
goto :Weiter 
40.
 
41.
:Weiter 
42.
::oder auch Ende
Grüße
bastla

P.S.: Beim Posten von Code "<" statt "[" zur Kennzeichnung verwenden ...

[Edit] Die von Notavailable erwähnte Möglichkeit, dass kein Benutzername zutrifft, sollte vielleicht etwas ausführlicher als in unseren beiden Vorschlägen (einfach Batch beenden) behandelt werden. [/Edit]
Bitte warten ..
Mitglied: Errator
18.06.2007 um 10:45 Uhr
Danke für die Hinweise.

@bastla

Was bewirkt das "/i"?
Bitte warten ..
Mitglied: bastla
18.06.2007 um 10:49 Uhr
Hallo Errator!

Versuch einmal "if /?" (wird dort allerdings "/I" geschrieben - ist in dem Fall aber egal ) ...

Grüße
bastla
Bitte warten ..
Mitglied: onegasee59
18.06.2007 um 10:49 Uhr
Hallo,
hat sich mit bastla' Posting erledigt

gruß
Bitte warten ..
Mitglied: Errator
18.06.2007 um 10:57 Uhr
Danke. Thema erledigt. Problem gelöst.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Via MsgBox Sprungmarke in Batch auswählen

gelöst Frage von BustedDiceBatch & Shell6 Kommentare

Hallo zusammen brauch mal wieder eure Hilfe bei einem Batch. Ich möchte via MsgBox mit dem Button OK oder ...

Batch & Shell

Batch kehrt zur Sprungmarke zurück, obwohl es pingen soll?

Frage von BrotkastenBatch & Shell2 Kommentare

Guten Tag zusammen, ich bin derzeit am Schreiben einer Batch, die eben bestimmte Komponente anpingen soll, die man per ...

Batch & Shell

Batch: SET geht nicht?!

gelöst Frage von SlainteMhathBatch & Shell3 Kommentare

Moin, ich steh gerade auf dem Schlauch bei einer Batch (unter Windows 7) Mein Code ergibt erwarten würde ich ...

Batch & Shell

Batch mit Copy auf SBS2008 funktioniert nicht, auf Client geht es

gelöst Frage von CyCOttBatch & Shell9 Kommentare

Moin Moin, ich glaube ich bin einfach zu doof okok bitte nicht Antworten ;-) Also ich habe eine Batch ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein interessanter Beitrag dazu: Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10 Anscheinend ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs11 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)10 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...