Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bug bei Komma als Delims in FOR-Schleife !

Mitglied: evinben

evinben (Level 2) - Jetzt verbinden

09.08.2012, aktualisiert 21:14 Uhr, 3681 Aufrufe, 4 Kommentare

Hallo,

wenn Komma als Trennzeichen in einer FOR-Schleife verwendet wird, dann wird die Zeichenfolge nicht in einzelnen Tokens aufgeteilt:
01.
:Start this Batch with arguments als following:  
02.
:Bug_bei_Komma_als_Delims.bat 1,5,9,85 /enable /disable /switch 
03.
 
04.
@echo off 
05.
 
06.
set Arg=%* 
07.
set NewLine=1 
08.
:M1 
09.
for /f "tokens=%NewLine% delims=," %%d in ('echo %Arg:"=%') do echo %%d & set /a NewLine+=1 & goto :M1 
10.
 
11.
pause >nul
Da es ein Tool sein wird, soll es in diesem Fall - soweit es technisch machbar wäre - in den zu übergebenden Argumenten Kommas als Trennzeichen verwendet werden. Leider streitet da CMD mit Komma und Semikolon sehr stur. Bei Verwendung vieler anderen Zeichen geht es auf Anhieb problemlos und die Zeichenfolge wird in mehreren Tokens aufgeteilt – jeder Token auf separater Zeile, genauso wie angestrebt - ausgegeben.
Mit Komma würde es zwar auch halb-halb funktionieren, wenn nach dem ein Leerzeichen folgen würde (delims=, "), es werden jedoch unerwünschte neue Token erzeugen, da in der verarbeiteten Zeichenfolge Leerzeichen enthalten sind (siehe oben die übergebenen Argumente).

Ich bin ratlos und würde mich riesig über eure Hilfe freuen!

Gruß
evinben
Mitglied: rubberman
09.08.2012 um 21:32 Uhr
Hallo evinben!

So bekomme ich das zum Fliegen:
- snip -
01.
:M1 
02.
setlocal EnableDelayedExpansion 
03.
for /f "tokens=%NewLine% delims=," %%d in ('echo !Arg:^"^=!') do endlocal & echo %%d & set /a NewLine+=1 & goto :M1
- snip -

Grüße
rubberman
Bitte warten ..
Mitglied: 60730
09.08.2012, aktualisiert um 21:35 Uhr
moin,

Ich bin ratlos und würde mich riesig über eure Hilfe freuen!

  • was macht denn Probleme?
  • und wenn was in ner Batch Probleme macht, was macht man dann garantiert weg - wenns drin war?

Ist es denn wirklich ein Bug bei Komma als Delims in FOR-Schleife !?
Oder vielelicht doch eher ein Bug woanders?
Was sagt denn das echo? Eben - da kommts so nicht an...

:Start this Batch with arguments als following:
:Bug_bei_Komma_als_Delims.bat 1,5,9,85 /enable /disable /switch

cd %~dp0
set Arg=%*
echo %Arg%>notabug.ini
set NewLine=1
:M1
for /f "tokens=%NewLine% delims=," %%d in (notabug.ini) do echo %%d & set /a NewLine+=1 & goto :M1
pause >nul
del notabug.ini


Gruß
Bitte warten ..
Mitglied: bastla
09.08.2012, aktualisiert 10.08.2012
Hallo @All!

Übersehe ich etwas, oder ist eigentlich nur
for %%d in (%Arg%) do echo %%~d
gewünscht? Wenn alles ab 85 als nur ein Argument gelten soll:
Bug_bei_Komma_als_Delims.bat 1,5,9,"85 /enable /disable /switch"
Weiterer Ansatz:
01.
@echo off & setlocal 
02.
set "Args=%*" 
03.
 
04.
for %%d in (%Args: =§%) do ( 
05.
    set "Arg=%%d" 
06.
    setlocal enabledelayedexpansion 
07.
    echo !Arg:§= ! 
08.
    endlocal 
09.
)
[Edit] ... und gar nicht so weit vom ursprünglichen Versuch entfernt und ohne weitere Kunststücke:
for /f "tokens=%NewLine% delims=," %%d in ("%Arg:"=%") do echo %%d & set /a NewLine+=1 & goto :M1
BTW: Soferne in den Parametern auch die üblichen Verdächtigen (Sonderzeichen) vorkommen sollten, würde am ehesten noch T-Mos Variante (vorzugsweise mit Zwischenspeicherung in "%temp%" und Ausgabe "echo %%~d") passen ...
[/Edit]

Grüße
bastla
Bitte warten ..
Mitglied: Biber
09.08.2012, aktualisiert um 22:03 Uhr
Moin evinben,

Bei Verzicht auf Carets und DelayedExpansion zB:

01.
:Start this Batch with arguments als following:  
02.
:Bug_bei_Komma_als_Delims.bat 1,5,9,85 /enable /disable /switch 
03.
 
04.
@echo off & setlocal 
05.
 
06.
set "Arg=%*" 
07.
set "Arg=%Arg:"=%" 
08.
set NewLine=1 
09.
:M1 
10.
for /f "tokens=%NewLine% delims=°" %%d in ("%Arg:,=°%") do echo [Token %Newline%:] %%d & set /a NewLine+=1 & goto :M1
Output bei zwei Parametervariationen:
d:\temp>Bug_bei_Komma_als_Delims 1,5,9,85  /enable /disable ; /switch 
[Token 1:] 1 
[Token 2:] 5 
[Token 3:] 9 
[Token 4:] 85  /enable /disable ; /switch 
 
d:\temp>Bug_bei_Komma_als_Delims 1,5,9,"85  /enable /disable ; /switch" 
[Token 1:] 1 
[Token 2:] 5 
[Token 3:] 9 
[Token 4:] 85  /enable /disable ; /switch
Aber bastlas Hinweis ist zielführender - eigentlich kannst du es viel einfacher mit einer "FOR ohne /F"-Anweisung lösen.

Weil... eine gültige CMD-Parameterliste per FOR/F-Anweisung in einzelne gültige CMD-Parameter zu trennen....ähhm.

Grüße
Biber
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batch Schleife als FOR-SCHLEIFE
gelöst Frage von mp2711Batch & Shell2 Kommentare

Mit den FOR-Schleifen habe ich mich leider bislang zu selten auseinander gesetzt, aber da ich sonst gerade nicht weiter ...

Batch & Shell

FOR Schleife mit LOOP und nachfolgender FOR Schleife

gelöst Frage von miczarBatch & Shell6 Kommentare

Hallo zusammen, ich habe ein Problem mit einem Batchfile. Situation: im Netzwerk ist kein WINS mehr vorhanden und so ...

Batch & Shell

FOR Schleife läuft nicht

gelöst Frage von sugramBatch & Shell4 Kommentare

Hallo Ich glaube ich sehe den Wald vor lauter Bäumen nicht. Aber ich bekomme die FOR Schleife nicht zum ...

Batch & Shell

For Schleife kaputt?

gelöst Frage von Peter32Batch & Shell5 Kommentare

Hallo, ich finde den Fehler nicht irgendwie bekomme ich ständig denselben Inhalt in "Name.txt" und kann dann nicht weiterarbeiten ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 16 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 22 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

SAN, NAS, DAS
Qnap TS-453S Pro - Anbindung Active Directory
Frage von JuckieSAN, NAS, DAS13 Kommentare

Hallo zusammen, ich habe hier eine Qnap TS-453S Pro die sich mal so absolut gar nicht in das Active ...