Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Datenherkunft per vba im Unterformular ein- und ausstellen Laufzeitfehler 3211

Mitglied: bumbum

bumbum (Level 1) - Jetzt verbinden

07.01.2010, aktualisiert 14:54 Uhr, 11708 Aufrufe, 4 Kommentare

Hallo zusammen,
ich habe in Access ein Hauptformular(frm_Hauptformular) mit einem Unterformular(frm_Unterformular). In dem Unterformular ist ein Button, der das Formular frm_Saisonkurve_suche öffnen soll. In diesem Formular kann man einen Datensatz mit einem Doppelklick aus einem Listenfeld auswählen.
Beim Doppelklick wird folgender Code ausgeführt:

Forms!frm_Unterformular!frm_Unterformular.RecordSource = ""
DoCmd.RunSQL ("delete * from tbl_TEMP_Saisonkurve")
DoCmd.OpenQuery "TEAbf_TempSK" --> Tabellenerstellungsabfrage(erstellt die Tabelle tbl_TEMP_Saisonkurve)
Forms!frm_Unterformular.RecordSource = "tbl_TEMP_Saisonkurve"
Forms!frm_Unterformular.Refresh

Mein Problem:

Es erscheint immer der "Laufzeitfehler 3211" und ich habe auch in anderen Foren geschaut aber keine Lösung gefunden, auch die Hilfe war nicht sehr hilfreich,
aber da mir hier schon oft geholfen wurde wende ich mich an euch.

LG BumBum
Mitglied: dog
07.01.2010 um 16:07 Uhr
DoCmd.RunSQL ("delete * from tbl_TEMP_Saisonkurve")

Ein Stern in einem DELETE Statement ist AFAIK Fehl am Platze.

http://www.devguru.com/technologies/t-sql/7122.asp
Bitte warten ..
Mitglied: bumbum
08.01.2010 um 07:23 Uhr
Hallo dog,
erstmal danke, ich habe es geändert. Doch jetzt kommt die nächste Fehlermeldung (Laufzeitfehler 2450: Microsoft Office Access kann das Formular 'frmUnterformular' nicht finden, auf das in einem Makroausdruck oder in einer Virtual Basic- Programmzeile verwiesen wird.)
Die Markierung für den Fehler ist auf der folgenden Zeile:

Forms!frm_Unterformular!frm_Unterformular.RecordSource = ""

Dazu ist zu sagen, wenn ich nur das Unterformular öffne, dann den Button klicke, der das Formular frm_Saisonkurve_suche öffnet und den Datensatz per Doppelklick auswähle, dann funktioniert alles alles ohne Probleme.

lg bumbum
Bitte warten ..
Mitglied: Pjordorf
08.01.2010 um 07:41 Uhr
Hallo bumbum,

du bist sicher, das das hier "Forms!frm_Unterformular!frm_Unterformular.RecordSource =" so richtig ist?

Peter
Bitte warten ..
Mitglied: bumbum
08.01.2010 um 08:51 Uhr
Hallo, tut mir leid, das ist natürlich ein Fehler, der Zeile steht oben auch schon Falsch.

"Forms!frm_Unterformular!.RecordSource ="

bumbum
Bitte warten ..
Ähnliche Inhalte
Basic

VBA: Pfad nicht gefunden Laufzeitfehler 76

gelöst Frage von YannoschBasic2 Kommentare

Hi! Ich bekomme hier den Fehler Laufzeitfehler 76 "Pfad nicht gefunden" der Pfad "C:\" existiert aber. Woran kann das ...

Webentwicklung

Sharepoint Laufzeitfehler

gelöst Frage von Florian86Webentwicklung1 Kommentar

Guten Tag, ich habe seit einigen Tagen einen Laufzeitfehler beim öffnen der Sharepointseite. Unsere Konstellation: Frontendserver SQL Server auf ...

Verschlüsselung & Zertifikate

Fingerprint von Aussteller-CA-Zertifikat

gelöst Frage von Philipp711Verschlüsselung & Zertifikate3 Kommentare

Hallo, ich beschäftige mich mal wieder intensiver mit dem Thema "SSL-Zertifikate". Dabei fällt mir folgendes auf: Unser Proxy hält ...

Windows Server

Zertifikate nur für die lokale Domäne ausstellen

gelöst Frage von backslashWindows Server3 Kommentare

Hallo, kann man die Domänen Web Server Zerifikatsasustellung auf eine bestimmte Domäne begrenzen ? Beispiel: Domäne: test.local CA wurde ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 25 MinutenHumor (lol)

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 13 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 13 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 16 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...