Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2010 MailboxExportRequest lässt Elemente aus.

Mitglied: emeriks

emeriks (Level 4) - Jetzt verbinden

15.09.2014, aktualisiert 19.09.2014, 1464 Aufrufe, 9 Kommentare

Hi,
wenn ich mit Befehlen wie

01.
New-MailboxExportRequest -mailbox 'Dummy' -priority normal -name 'Mig_Export_Full_Dummy_1' -acceptlargedataloss -baditemlimit 1000 -filepath \\Server\Share\Dummy_Full_1.pst
Postfächer exportiere, dann habe ich viele Postfächer dabei, für die er mir im

01.
Get-MailboxExportRequestStatistics -IncludeReport
zwar keine "BadItems" meldet, aber viele Reportzeilen wie

01.
35 Elemente werden kopiert, 30.66 KB (31,398 bytes). 3 Elemente werden übersprungen, 686 B (686 bytes).
In den erzeugten PST fehlen diese Elemente dann auch tatsächlich. Dumm besonders dann, wenn mal "1 Element" gleich ein ganzer Ordner ist, mit vielen Elementen drin, die dann aber im Report nicht erwähnt werden.

Hat jemand ne Idee
- woran das liegen kann, dass er diese Elemente auslässt, ohne diese als "BadItem" zu melden
- wie ich ihn dazu bewegen kann, tatsächlich alles zu exportieren

Ein Export mit Outlook hat bei diversen Stichproben hingegen problemlos funktioniert. Alle Elemente sind hier enthalten. Nur kann ich bei einer Intra-Forest-Migration schlecht 1500 Mailboxen von Hand mit Outlook exportieren.

E.



Mitglied: Dani
15.09.2014 um 15:15 Uhr
Moin,
wird der Report ausführlicher wenn du die Parameter -acceptlargedataloss -baditemlimit 1000 weglässt bzw. den letzteren auf 0 setzt?!


Gruß,
Dani
Bitte warten ..
Mitglied: emeriks
15.09.2014 um 15:52 Uhr
Hi Dani,
nö, leider nicht. BadItemsEncountered immer noch Null und die Logeinträge mit den ausgelassenene Elementen auch. Die erzeugte PST ist bis auf 's Byte identisch groß zu der vorherigen.

E.
Bitte warten ..
Mitglied: Komabaer
15.09.2014 um 18:33 Uhr
Mal ne blöde Frage, wieso verwendest du überhaupt die Parameter -acceptlargedataloss und -baditemlimit?
Bitte warten ..
Mitglied: emeriks
16.09.2014, aktualisiert um 09:50 Uhr
@Komabaer
Wenn Elemente defekt sind, dann sind sie defekt. Dann bekomme ich sie mit Powershell eh nicht exportiert.Wenn ich aber ein Postfach von 20 GB habe, dass mir bei 90% wegen des 51. "BadItems" den Export abbricht, dann ist das ärgerlich, weil es mich zeitlich weit nach hinten wirft. Also lieber gleich mit diesem Parameter.
Wenn die Elemente futsch sind, dann kann ich besser damit argumentieren, wenn sie bei einer Migration nicht übernommen werden können. Meistens schlägt dann ja auch der Export mit Outlook fehl.
Aber wenn Elemente übergangen werden, ohne dass es einen Grund dafür zu geben scheint, und ohne dass man das in einer einfachen Statistik (ohne -IncludeReport) sehen kann, dann lindert das mein Vertrauen in die Angaben, die mir Exchange liefert, massiv. Dann kann ich mich auf keine "Erfolgreich" Meldung mehr verlassen.

E.
Bitte warten ..
Mitglied: Dani
16.09.2014 um 11:05 Uhr
Moin,
sehr seltsam... was gibt der Befehl "Get-MailboxExportRequestStatistics -Identity <XYZ> | fl" aus?


Gruß,
Dani
Bitte warten ..
Mitglied: colinardo
16.09.2014, aktualisiert um 11:11 Uhr
Hallo Emeriks,
ich kenne dieses Verhalten nur für den Import von PSTs. Dort gibt es dieses Verhalten wenn eine Mail größer ist als die in der Policy für die maximale Größe von zu versendenden Mails. Eventuell probierst du mal aus, diese Einstellung auch temporär für den Export hoch zu stellen. Eventuell bringt das den gewünschten Erfolg.

Grüße Uwe
Bitte warten ..
Mitglied: Dani
16.09.2014 um 11:14 Uhr
Hi Uwe,
daran habe ich auch schon gedacht. Aber wieder verworfen, da das Objekt bereits im Exchange-Postfach liegt und somit das Limit kein Grund sein dürfte, oder?


Gruß,
Dani
Bitte warten ..
Mitglied: colinardo
16.09.2014, aktualisiert 19.09.2014
Zitat von Dani:
daran habe ich auch schon gedacht. Aber wieder verworfen, da das Objekt bereits im Exchange-Postfach liegt und somit das Limit kein Grund sein dürfte, oder?
Versuch macht kluch
Bitte warten ..
Mitglied: emeriks
19.09.2014 um 14:33 Uhr
@colinardo,
ja, das kenne ich. Da setzt man aber temporär den Schwellwert nach oben und gut ist. Aber gut, dass wird davon gesprochen haben. Somit konnte ich das auch noch auischließen:
Ich habe für das alte Postfach die Sende-Limits erhöht (1GB), hat aber nichst geändert. Der Export bleibt identisch.

E.
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Exchange 2010 - Gelöschte Elemente wiederherstellen (auf dem Exchange-Server)

Frage von HimpkeExchange Server5 Kommentare

Hallo Ihr Lieben :) Ich hoffe, mich kann hier jemand von euch mit Praxis-wissen unterstützen :) Ich lerne gerade ...

Exchange Server

Exchange Server 2010 lässt sich nicht installieren

Frage von kschwarzerExchange Server3 Kommentare

Hallo liebe Community, ich hab da ein kleines oder ehr großes Problem. Ich habe auf einem Windows Server 2008 ...

Outlook & Mail

Gesendete Elemente werden in Outlook 2010 nicht aktualisiert

Frage von mart1nOutlook & Mail

Hallo zusammen, kennt jemand das Problem das die gesendeten Elemente im Outlook nicht aktualisiert werden? Hintergrund ist folgender. Wir ...

Exchange Server

Exchange 2010 - öffentlicher Ordner lässt sich nicht erstellen

gelöst Frage von chb1982Exchange Server1 Kommentar

Hallo zusammen, ich hänge gerade in eine Migration von SBS2003 auf Exchange 2013 fest. Aktuell habe ich als Zwischenschritt ...

Neue Wissensbeiträge
Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 1 StundeWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgborn vor 2 StundenMicrosoft2 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 2 TagenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 2 TagenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1017 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)13 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall11 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Server-Hardware
Server für Exchange 2016, Kaufberatung
Frage von MazenauerServer-Hardware10 Kommentare

Guten Tag werte Gemeinde, Vorab: Ich dachte es gab mal einen separaten Bereich für solche Anfragen, habe ich leider ...