Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Netzwerkproblem ESXi-Server

Mitglied: vogster

vogster (Level 1) - Jetzt verbinden

18.03.2013 um 21:20 Uhr, 2211 Aufrufe, 6 Kommentare

Hallo Forum,
ich habe ein Problem mit meinem ESXi-Testsystem, vielleicht kann mir jemand helfen.

Auf meinem ESXi 5.1 Server sind 3 einfache CentOS 6.3 OS installiert.

TestPCA: Minimal-Installation, 1 Netzwerkkarte (192.168.1.150)
TestPCB: Minimal-Installation, 1 Netzwerkkarte (192.168.1.160)
TestFW: Basis-Server-Installation, 2 Netzwerkkarten (192.168.1.170, .171)

Am dem ESXi habe ich in der Netzwerkkonfiguration 2 virtuelle Switsche installiert.

vSwitch1: TestPCA und Netzwerkkarte 1 von TestFW
vSwitch2: TestPCB und Netzwerkkarte 2 von TestFW
Die Einstellungen sind alle Standard.

Vom TestPCA kann ich beide Netzwerkkarten des TestFW pingen.
Vom TestPCB kann ich keine Netzwerkkarte des TestFW pingen.

Woran kann das liegen? Eigentlich habe ich erwartet, dass ich vom TestPCA die erste NIC und vom
TestPCB nur die zweite NIC pingen kann.

Die Testsysteme sind frisch aufgesetzt, die NIC´s wurden während der Installation konfiguriert.
Lediglich der Parameter onboot=yes wurde in den ifcfg-ethx modifiziert.

Packe ich alle NIC´s auf mein erstes oder zweites virtuelles Switch, dann erreiche ich alle Adressen.
Also müsste das Problem doch an den Switches oder NIC-Einstellungen der VM´s liegen, oder?
Mein ESXi läuft auf einem VMWarePlayer5 auf einem Win7-64.

Vielen Dank für Eure Tipps!
Vogster
Mitglied: SamvanRatt
18.03.2013 um 22:51 Uhr
Hi
entweder verstehe ich deinen Ansatz nicht (du hast die Netzwerkwaske vergessen mit anzugeben) oder du gehst davon aus dein CentOS fungiert automatisch als Hub auf den beiden NICs bloß weil sie im selben Subnetz liegen.
Was passiert denn wenn du das ganze logisch differenzierter aufbaust: TestPCA 192.168.0.10/24; TestPCB 192.168.1.10; TestFW 192.168.0.1/24 und .1.1/24; sofern du IPforwarding aktiviert hast läuft der Server als Router und schickt die Pakete ins richtige Netz.
In Deiner Konstellation gäbe es keinen Grund wieso der TestFW was durch seinen IP Stack jagen sollte; ist ja das selbe Netz einfach nur (logisch) redundant angebunden.
Gruß
Sam
Bitte warten ..
Mitglied: Lochkartenstanzer
19.03.2013, aktualisiert um 08:00 Uhr
^^Zitat von vogster:
TestPCA: Minimal-Installation, 1 Netzwerkkarte (192.168.1.150)
TestPCB: Minimal-Installation, 1 Netzwerkkarte (192.168.1.160)
TestFW: Basis-Server-Installation, 2 Netzwerkkarten (192.168.1.170, .171)

Am dem ESXi habe ich in der Netzwerkkonfiguration 2 virtuelle Switsche installiert.

vSwitch1: TestPCA und Netzwerkkarte 1 von TestFW
vSwitch2: TestPCB und Netzwerkkarte 2 von TestFW
Die Einstellungen sind alle Standard.

Vom TestPCA kann ich beide Netzwerkkarten des TestFW pingen.
Vom TestPCB kann ich keine Netzwerkkarte des TestFW pingen.

Woran kann das liegen? Eigentlich habe ich erwartet, dass ich vom TestPCA die erste NIC und vom
TestPCB nur die zweite NIC pingen kann.

Schau Dir die Netzwerkkonfiguration genau an! Und Siehst Du es? Mal es Dir auf, so wie es in einem realen Netzwerk wäre. Da soltel es sofort ins auge springen.


(Hint: Nics in verschiedenen Netzwerken benötigen auch verschiedene IP-Netze!)

lks

PS: Wenn Du es immmer noch auf dem Schlauch stehst: aqui hat da was dazu.


Nachtrag: Die Überschrift ist irreführend. ESXi macht alles richtig. Das Problem ist die Konfiguration der NICs in den VMs, also eher PBKAC.
Bitte warten ..
Mitglied: max
19.03.2013 um 10:09 Uhr
Hi @vogster,

wie die beiden anderen User schon geschrieben haben. Entweder du benutzt "einen" vSwitch für alle Netzwerkkarten (also
für das gesamte 192.168.0.1/24 Netz), oder wenn du unbedingt "zwei" vSwitche haben willst -> dann musst du auch zwei unterschiedliche Netze benutzen, also z.B. ein 192.168.1.1/24 Netz und ein 192.168.2.1/24 Netz.

Gruß
max
Bitte warten ..
Mitglied: vogster
19.03.2013 um 11:17 Uhr
Hi zusammen,

habe das Problem erkannt, nun funktioniert das auf meinem ESXi auch so, wie ich wollte.
Der war dann natürlich nicht schuld, sondern die IP-Cfg, wie schon beschrieben.
Der Hintergrund ist mir noch nicht ganz klar, da werde ich das verlinkte Dokument mal durchgehen!

Danke, Vogster
Bitte warten ..
Mitglied: max
19.03.2013, aktualisiert um 11:27 Uhr
Hi,

Wie genau hast Du es denn jetzt gelöst?
Wenn es dann erledigt ist, bitte auf "Frage als gelöst markieren" oben rechts im Menü klicken.

Gruß
max
Bitte warten ..
Mitglied: vogster
25.03.2013 um 18:21 Uhr
Hi,

ich habe die Netze so angepasst, wie es muss.
192.168.0.150 <-> 192.168.0.160; 192.168.1.170 <-> 192.168.1.161

Grüße, Vogster
Bitte warten ..
Ähnliche Inhalte
Vmware
Esxi server
gelöst Frage von ddjangoVmware3 Kommentare

moin habe mir nen esxi-server 5.5 aufgesetz und nen win7pro als client aufgesetzt. nach nem update war der client ...

Router & Routing
VLAN Netzwerkproblem
gelöst Frage von letstryandfindoutRouter & Routing4 Kommentare

Hallo zusammen, ich habe ein kleines Problem bei einem Netzwerk und finde meinen Fehler einfach nicht. Hier aber mal ...

Server-Hardware
Neuen ESXI Server kaufen
Frage von geforce28Server-Hardware15 Kommentare

Hallo Leute, ich bin auf der Suche nach einem günstigen Server der für VMware ESXi Server Software zur Virtualisierung ...

Vmware

Neuen günstigen ESXi Server, was muss man haben?

Frage von liptoniceVmware14 Kommentare

Hallo, ich möchte für ein kleines Büro mit 5 Clients einen neuen Server aufstellen. Darauf soll ESXi 5.5 U2 ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Windows Server
NTFS Berechtigungen Ordnerstruktur
Frage von hukahu23489Windows Server11 Kommentare

Hallo, ich bin seit kurzem in einer neuen IT-Abteilung und bin über das Berechtigungskonzept des Unternehmens sehr schockiert. Ich ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...