Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Office 2010 Home and Business Silent Install

Mitglied: mijacd

mijacd (Level 1) - Jetzt verbinden

27.06.2014, aktualisiert 13:24 Uhr, 4109 Aufrufe, 7 Kommentare

Hallo miteinander,

ich versuche nun schon seit mehreren Tagen Office 2010 H&B unbeaufsichtigt zu installieren. Ich habe dazu die Config.xml aus den SingleImage.WW ordner genommen und angepasst:

"<Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />"
Einen Lizenkey habe ich auch angegeben mit dem Schalter PIDKEY.

Nun funktioniert das ganze auch ganz gut bis zum Dialog "Anpassen der Installation". Er bringt mir immer wieder diesen Dialog. Habe mir die Setup.lg mal angeschaut und in dieser werden alle Schalter aus der XML geparst außer der "Display Level".

Hat vielleicht jemand von euch schonmal Home and Business silent installiert und kann mir Hinweise geben.

Vielen Dank
Mitglied: certifiedit.net
27.06.2014 um 09:40 Uhr
Hallo Mijacd,

ich hab im Hinterkopf, dass dies nicht geht. Nutze mal die Suche.


DIe Version heisst ja nicht ohne Grund "Home (und Business)".

Grüße,

Christian
Bitte warten ..
Mitglied: DerWoWusste
27.06.2014, aktualisiert um 11:40 Uhr
Moin.
Es geht, haben wir gemacht. Beispiel
01.
<Configuration Product="SingleImage"> 
02.
	<Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" /> 
03.
	<!--    you _have to_ enter a valid key here!   --> 
04.
	<PIDKEY Value="Dein-Key-hier-rein" />  
05.
	<!--    enter a serverpath to get a installlog of all clients    --> 
06.
	<Logging Type="standard" Path="\\server\software\user\MS-Programme\Office2010HaB\installlogs" Template="%computername%.log" /> 
07.
	<!--    automatically activate product during installation - not tested if works with single licenses    -->! 
08.
	<Setting Id="AUTO_ACTIVATE" Value="1" /> 
09.
	<!-- <USERNAME Value="Testuser" /> --> 
10.
	<COMPANYNAME Value="Firmenname" /> 
11.
	<!-- <INSTALLLOCATION Value="%programfiles%\Microsoft Office" /> --> 
12.
	<!-- <LIS CACHEACTION="CacheOnly" /> --> 
13.
	<!-- <LIS SOURCELIST="\\server\software\user\MS-Programme\Office2010HaB" /> --> 
14.
	<!-- <DistributionPoint Location="\\server\software\user\MS-Programme\Office2010HaB" /> --> 
15.
	<!--    choose what to install    --> 
16.
	<OptionState Id="ACCESSFiles"  State="Absent" Children="force" /> 
17.
	<OptionState Id="EXCELFiles"   State="Local"  Children="force" /> 
18.
	<OptionState Id="OneNoteFiles" State="Local" Children="force" /> 
19.
	<OptionState Id="OUTLOOKFiles" State="Local" Children="force" /> 
20.
	<OptionState Id="PPTFiles"     State="Local"  Children="force" /> 
21.
	<OptionState Id="PubPrimary"   State="Absent" Children="force" /> 
22.
	<OptionState Id="SHAREDFiles" State="Local" Children="force" /> 
23.
   	<OptionState Id="TOOLSFiles" State="Local" Children="force" /> 
24.
	<OptionState Id="WORDFiles"    State="Local"  Children="force" /> 
25.
	<!-- <Setting Id="Reboot" Value="IfNeeded" /> --> 
26.
</Configuration>
Bitte warten ..
Mitglied: mijacd
27.06.2014 um 12:05 Uhr
Hi,

vielen Dank für das XML. So in etwa sieht meins auch aus jedoch funktioniert auch das von die veröffentlichte nicht. Sobald ich das Setup starte popt das Office Fenster auf und sagt das es alle nötigen Informationen Sammelt. Und dann bleibt er stehen bei Anpassen oder Installieren. Es kommt mir vor als würde er das Display Level="none" nicht verarbeiten.

Gruß
Bitte warten ..
Mitglied: DerWoWusste
27.06.2014 um 12:45 Uhr
Wir nutzen dieses xml und es geht (Stand jetzt). Lass mich mal kurz drüber nachdenken.
Bitte warten ..
Mitglied: DerWoWusste
LÖSUNG 27.06.2014, aktualisiert um 13:24 Uhr
Kann es wohl sein, dass Du das Setup gar nicht korrekt aufrufst? Musste so machen:
setup.exe /config \\server\software\user\MS-Programme\Office2010HaB\Konfigs\konfigdatei.xml
Bitte warten ..
Mitglied: mijacd
27.06.2014 um 13:24 Uhr
Hi,

vielen Dank für die Antwort.
Tatsächlich funktioniert es so wie du geschrieben hast.
Es gibt jedoch dann eine Sache die ich nicht verstehe. Wenn ich die Setup.exe aufrufe dann ruft er doch automatisch die xml im SingleImageWW auf. Warum funktioniert das dann nur wenn ich das ganze über den Cmd mache ??

Gruß
Bitte warten ..
Mitglied: DerWoWusste
27.06.2014 um 13:57 Uhr
Um eine angepasste xml zu nutzen MUSS es so wie genannt aufgerufen werden.
Wenn man es deployen will, geht man so vor: Ordner mit xml-Dateien, eine pro Rechnername, die Lizenznummer jeweils an den Rechnernamen angepasst.
setup.exe /config \\server\share\konfigdateien\%computername%.xml
Dies als Startskript und ab dafür. Natürlich noch sicherstellen, dass es nicht mehrfach (bei jedem Start) aufs Neue ausgeführt wird
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Office Installation als Silent Install
Frage von 2SeitenMicrosoft Office7 Kommentare

Hallo Zusammen, Ich versuche gerade eine "Silent" Installation für Office 2013 zu machen. Dazu starte ich die setup.exe mit ...

Microsoft

Per Skript Office 2010 Home and business silent deinstallieren

gelöst Frage von DerWoWussteMicrosoft5 Kommentare

Moin Kollegen. Wer hat eine als funktionierend getestete silent-Deinstallation von office 2010 HaB auf Lager? Beendet erfolglos mit Rückgabewert ...

Windows Installation

Silent Install Samsung Magician

Frage von Dpole86Windows Installation7 Kommentare

Hallo zusammen Wir als Systemhaus verbauen in allen unseren Rechnern SSDs von Samsung mit der dazugehörigen Software. bei 100 ...

Windows Tools

OpenVPN 2.4 Silent install

gelöst Frage von geocastWindows Tools1 Kommentar

Guten Abend zusammen Da nun OpenVPN nach Jahren endlich mal ohne Adminrechte funktioniert (als die Route hinzufügen). Wollte ich ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement14 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...