Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Rewrite in htaccess greift nicht

Mitglied: infowars

infowars (Level 2) - Jetzt verbinden

08.02.2012 um 13:16 Uhr, 3659 Aufrufe, 1 Kommentar

Tach,
ich habe hier einen Apache laufen, in der .htaccess folgender Inhalt:

order allow,deny
allow from all
RewriteEngine on
RewriteCond %{HTTP_USER_AGENT} ^ChinaClaw [OR]
RewriteRule ^(.*) http://%{REMOTE_ADDR}/ [R=301,L]
RewriteCond %{HTTP_REFERER} viagrashop4usa\.com [NC]
RewriteRule .* - [F]

Jetzt lese ich in der Log das nur einmal 404 ausgegeben wird, dann 200 :

95.132.122.122 - - [08/Feb/2012:03:19:01 +0100] "GET /register.php HTTP/1.0" 404 2271 "http://www.viagrashop4usa.com" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:02 +0100] "GET / HTTP/1.0" 200 12119 "http://meineadresse/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:03 +0100] "GET /index.php HTTP/1.0" 302 - "http://meineadresse/index.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:04 +0100] "GET /news.php HTTP/1.0" 200 138468 "http://meineadresse/news.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:05 +0100] "GET /register.php HTTP/1.0" 200 34574 "http://meineadresse/register.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:06 +0100] "GET /securimage_show.php HTTP/1.0" 200 3220 "http://meineadresse/register.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:07 +0100] "GET /index.php HTTP/1.0" 200 12119 "http://meineadresse/index.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:08 +0100] "GET /index.php HTTP/1.0" 200 12119 "http://meineadresse/index.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:09 +0100] "GET /index.php HTTP/1.0" 302 - "http://meineadresse/index.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"
95.132.122.122 - - [08/Feb/2012:03:19:10 +0100] "GET /news.php HTTP/1.0" 200 138468 "http://meineadresse/news.php" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FunWebProducts; .NET CLR 1.1.4322; PeoplePal 6.2)"

Habe ich was falsch gemacht, oder liegt es einfach daran das sich der Referer ändert ?

Danke für Antworten !
Mitglied: Arano
08.02.2012 um 14:47 Uhr
Hi,

ob du was falsch gemacht hast, kann ich dir nicht so direkt sagen - ich tu mich mit Rewrites auch immer etwas schwer.
Aber ein zwei Dinge fielen mir auf:
  • Das [OR] dient doch zum "verknüpfen" von mehrere Bedingungen __hintereinander__. Bei dir folgt nach dem [OR] bereits eine Regel.
  • 404 ist der Statuscode von "Not found", 403 wäre der von "Forbidden" ! Also scheint das sowieso schon mal nicht zu funktionieren...
  • Das der Referer sich ändert ist ja klar, schließlich war er vor dem __zweitem__ Seitenaufruf bereits einmal auf deiner eigenen und nennt diese auch als Referer.
  • Warum testest du nicht den USER_AGENT - wie in dem Test davor auch - auf die existens von "FunWebProducts" ? Das scheint sich nicht zu ändern und die beiden ließen sich dann auch mit [OR] verbinden ;)
  • Die erste "Weiterleitung" auf die IP des Aufrufers... was soll das bringen !?

Danke für die Antworten !
  1. Noch ist nicht gesagt, das es mehrere Antworten geben wird :-P
  2. Bedanken kannst du dich hinterher wenn es geklappt hat, du uns davon berichtest und die Frage auf gelöst setzt ;)
Danke das sie mein Haus gebaut haben, ist wirklich schön geworden - so dann lasst uns mal den ersten Spatenstich machen... so ein Schwachsinn

Apache-HTTP - mod_rewrite - RewriteCond
w3c - HTTP/1.1 Status Code Definitions


~Arano
Bitte warten ..
Ähnliche Inhalte
PHP
mod rewrite in der .htaccess Datei
Frage von DerEisigePHP1 Kommentar

Hallo ich bin mittlerweile am verzweifeln Ich bekomme mod_rewrite in der .htaccess Datei nicht hin. Ich bin soweit das ...

Apache Server
Htaccess RewriteRule greift nicht
gelöst Frage von Mean1312Apache Server4 Kommentare

Hallo zusammen, ich habe einige Tutorials durchgelesen, aber irgendwie bekomme ich es nicht hin, meine konkrete RewriteRule umzusetzen (die ...

Apache Server

Htaccess greift nicht, wird einfach ignoriert?

Frage von PanubuApache Server3 Kommentare

Hallo zusammen, ich habe auf meinem Websever einen .htaccess-File liegen (bzw. steht in der sites-available/default), welcher eine HTTPS-Verbindung erzwingt. ...

Apache Server

htaccess Problem mit mod rewrite (apache2, debian)

gelöst Frage von janek26Apache Server1 Kommentar

Hallo Community, ich habe ein problem mit meinem Webserver. Irgendwie ließt er die .htaccess nicht richtig ein. manche links ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs10 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)8 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...