Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Squidguard blockt alle Seiten

Mitglied: istike2

istike2 (Level 2) - Jetzt verbinden

25.10.2011 um 01:42 Uhr, 5569 Aufrufe

Hallo,

ich habe auf pfSense Squid und Squidguard installiert. Neben der Tatsache, dass ich keine Blacklists installieren kann, werden - aus Cachegründen - auch normale Seiten blockiert. In diesem Fall bekommen ich diese Fehlermeldung:

27e1f6d23913679d4011cf5ae725d82e - Klicke auf das Bild, um es zu vergrößern

Hier sind die Logs des Filters:

----- Proxyfilter: -----------

  1. Do not edit manually !
http_port 10.1.1.250:3128
icp_port 0

pid_filename /var/run/squid.pid
cache_effective_user proxy
cache_effective_group proxy
error_directory /usr/local/etc/squid/errors/German
icon_directory /usr/local/etc/squid/icons
visible_hostname localhost
cache_mgr admin@localhost
access_log /dev/null
cache_log /var/squid/log/cache.log
cache_store_log none
shutdown_lifetime 3 seconds
  1. Allow local network(s) on interface(s)
acl localnet src 10.1.1.0/255.255.255.0
forwarded_for off
uri_whitespace strip

cache_mem 100 MB
maximum_object_size_in_memory 32 KB
memory_replacement_policy lru
cache_replacement_policy lru
cache_dir null /tmp
minimum_object_size 0 KB
maximum_object_size 10 KB
offline_mode off

  1. No redirector configured



  1. Setup some default acls
acl all src 0.0.0.0/0.0.0.0
acl localhost src 127.0.0.1/255.255.255.255
acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901 9999 3128 1025-65535
acl sslports port 443 563 9999
acl manager proto cache_object
acl purge method PURGE
acl connect method CONNECT
acl dynamic urlpath_regex cgi-bin ?
acl unrestricted_hosts src '/var/squid/acl/unrestricted_hosts.acl'
cache deny dynamic
http_access allow manager localhost

http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !safeports
http_access deny CONNECT !sslports

  1. Always allow localhost connections
http_access allow localhost

request_body_max_size 0 KB
reply_body_max_size 0 deny all
delay_pools 1
delay_class 1 2
delay_parameters 1 -1/-1 -1/-1
delay_initial_bucket_level 100
delay_access 1 allow all

  1. Custom options
redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf
redirector_bypass on
redirect_children 3
  1. These hosts do not have any restrictions
http_access allow unrestricted_hosts
  1. Setup allowed acls
  2. Allow local network(s) on interface(s)
http_access allow localnet
  1. Default block all to be sure
http_access deny all

Filter Config ------

  1. SquidGuard configuration file
  2. This file generated automaticly with SquidGuard configurator
  3. (C)2006 Serg Dvoriancev
  4. email: dv_serg@mail.ru

logdir /var/squidGuard/log
dbhome /var/db/squidGuard

dest n-tv {
domainlist n-tv/domains
redirect 302:www.heise.de
}

rew safesearch {
s@(google..*/search?.*q=.*)@&safe=active@i
s@(google..*/images.*q=.*)@&safe=active@i
s@(google..*/groups.*q=.*)@&safe=active@i
s@(google..*/news.*q=.*)@&safe=active@i
s@(yandex..*/yandsearch?.*text=.*)@&fyandex=1@i
s@(search.yahoo..*/search.*p=.*)@&vm=r&v=1@i
s@(search.live..*/.*q=.*)@&adlt=strict@i
s@(search.msn..*/.*q=.*)@&adlt=strict@i
s@(.bing..*/.*q=.*)@&adlt=strict@i
}

acl {
default {
pass !in-addr n-tv all
redirect http://10.1.1.250:80/sgerror.php?url=403%20www.n-tv.de&a=%a&n=% ...
rewrite safesearch
}
}

Wenn jemand sonst bereits Erfahrungen hat wie man Shallas Blacklists auf eine pfSense-Board installiert, kann gerne Mal einen Blick auf diesen Thread werfen:

https://www.administrator.de/index.php?content=175180

Danke sehr!

Gr. I.
Ähnliche Inhalte
Netzwerkmanagement

Der Squidguard Pornfilter blockt nicht alle Schmuddelseiten

gelöst Frage von M.MarzNetzwerkmanagement8 Kommentare

Hallo zusammen, ich habe zu Testzwecken den Squid3 auf ein Debian 8.6 installiert um diesen später im Betrieb produktiv ...

Firewall

Pfsense mit squidguard

Frage von letstryandfindoutFirewall7 Kommentare

Hallo zusammen, ich habe auf einem ALIX Board eine pfsende installiert mit Squidguard. Das ganze läuft soweit auch, die ...

Suse

SquidGuard filtert CSS

gelöst Frage von killtecSuse3 Kommentare

Hallo, Squidguard scheint irgendwie die CSS zu filtern. Wenn ich squidguard raus nehme, wird die Seite korrekt dargestellt, lasse ...

Router & Routing

LANCOM-ROUTER Blockt

gelöst Frage von ChontaRouter & Routing7 Kommentare

Hallo, da unser Telefonanschluss DSL Technisch umgestellt wird, musste ein neuer Router her. Da wir derzeit ein Konsortioum aus ...

Neue Wissensbeiträge
Utilities
Teamviewer 14 Verbindungsprobleme mit Proxy
Tipp von PeterleB vor 4 StundenUtilities

Nach dem Umstieg von Version 13 auf 14 wollte sich TV nicht mehr mit dem Netz verbinden, ignorierte offenbar ...

Administrator.de Feedback
Unsere Datenbank wurde umgestellt
Information von Frank vor 8 StundenAdministrator.de Feedback5 Kommentare

Hallo User, ich habe in der Nacht unsere Datenbank umgestellt. D.h. neue Version (MySQL 8) und andere Örtlichkeit. Sollte ...

Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 2 TagenSonstige Systeme6 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 3 TagenDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Heiß diskutierte Inhalte
Windows 10
Programm unter Windows 10 automatisch mit administrativen Rechten starten
Frage von GrafmulderWindows 1017 Kommentare

Hallo zusammen! Zur Situation: Ich benutze Windows 10 Pro für Workstations (Build 1803) mit zwei Konten. Einem Administratorkonto und ...

LAN, WAN, Wireless
Empfehlung Powerline Adapter
Frage von AgilolfingerLAN, WAN, Wireless15 Kommentare

Hallo Zusammen, ich brauche eine Empfehlung von euch. Ich möchte in einem privaten Haushalt eine Powerline Lösung einrichten. Allerdings ...

Microsoft
Schulungs-Microsoft-Konten zentral verwalten
Frage von thejarneMicrosoft9 Kommentare

Hallo zusammen, wir haben bei uns in der Firma 12 Computer-Arbeitsplätze für EDV-Schulungen, wo u.A. auch Computer-Basics-Kurse (wie verwende ...

Windows 10
TeamViewer bzw. AnyDesk - Schwarzes Fenster
Frage von Questionmark93Windows 108 Kommentare

Hallo, hat schon jemand Erfahrung gemacht mit Teamviewer und Anydesk? Mir zeigt es bei einem Bekannten ein schwarzes Fenster ...