Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Startscripte werden nur manchmal ausgeführt (Windows Server 2008)

Mitglied: AquaSchaf

AquaSchaf (Level 1) - Jetzt verbinden

17.08.2011 um 10:20 Uhr, 5563 Aufrufe, 6 Kommentare

Hallo,

ich betreue eine kleine Domäne mit 13 Clients und einem Windows 2008 Server. Ich hatte damit begonnen, Software automatisiert über Start-Scripte zu verteilen. Da ich dieses zum 1. Mal mache, war ich etwas misstrauisch und habe versucht das in irgendeiner Form zu loggen. Habe schließlich einfach ein echo "%Computername% hat blablabla instaliert" -> \\server\Ordner\Datei.txt an die Installations-.bat Datei angehängt.

Dabei fiel mir schließlich auf, dass nach einem Neustart von allen Rechern, sich nicht alle Computer in die Datei eintrugen. Nach etwas herumprobieren kam ich auf ca 65% der Rechner, die anscheinend das Start-Script ausführen. Warum die restlichen dies nicht tun, verstehe ich nicht, besonders da es nicht immer die gleichen sind (manche jedoch öfter als andere).

Ich habe mir zuerst die Gruppenrichtlinienereignisse angeschaut. Dort konnte ich auf dem ersten Blick nichts feststellen. Bei "Zuletzt ausgeführt" des Scriptes war entweder kein Wert oder der Wert von einem vorherigen Versuch eingetragen.
Die Einstellungen "Beim Neustart des Computers und bei der Anmeldung immer auf das Netzwerk warten" und "Anmeldeskripts gleichzeitig ausführen" sind aktiviert.
Darüber hinaus ist bei der Einstellung "Maximale Wartezeit für Gruppenrichtlinienskripts" der Wert 0 eingetragen.

Gerne stelle ich auch weitere Daten zur Verfügung, die bei der Lösung des Problems hilfreich sein könnten.
Ich würde gerne verstehen warum es zu diesem Verhalten kommt und freue mich deshalb sehr auf hilfreiche Antworten
Mitglied: Metzger-MCP
17.08.2011 um 11:29 Uhr
Hi,

Schau mal nach, ob es ohne die Installation geht, sowas wie.

Script anfang
echo "%Computername% hat am %date% um %time% erfolgreich das Scripte ausgeführt" >> \\serverip\Freigabe\Datei.txt
Script ende

wenn das bei allen geht, kann es an der Installationquelle / Zugriffe liegen, dann kommt man schon mal ein Schritt weiter ...

MFG Uwe
Bitte warten ..
Mitglied: AquaSchaf
17.08.2011 um 11:57 Uhr
Das hatte ich auch probiert (vergessen zu erwähnen). Der Fehler scheint von dem jeweiligen Skript und deren Anzahl unabhängig zu sein. Entweder werden alle ausgeführt, oder keine.

Aber vielen Dank für den Hinweis mit %time%. Kannte diese Variable noch nicht und hatte immer irgendetwas krudes versucht.
Bitte warten ..
Mitglied: DerWoWusste
17.08.2011 um 13:44 Uhr
Hi.

Ein paar Gedanken dazu:
"Anmeldeskripts gleichzeitig ausführen" sind aktiviert.
Startskripte sind keine Anmeldeskripte. Anmeldeskripte laufen nach der Anmeldung mit Userrechten (Konto:%username%), Startskripte beim Rechnerstart mit Systemrechten (Konto: %computername%). Diese Option gibt es aber auch für Startskripte.
Software automatisiert über Start-Scripte verteilen
Warum nicht über MSI-Pakete? Man kann mit Tools wie WIWW (vinsvision) sogar Batches in MSI-Pakete einwickeln
-Das Skript muss in jedem Fall ohne Rückfragen ablaufen. Kommen Rückfragen, hält es an.
Ich habe mir zuerst die Gruppenrichtlinienereignisse angeschaut
Wo? rsop.msc?
65% der Rechner...nicht immer die gleichen
D.h. 65% machen es zuverlässig und 35% mehr oder weniger unzuverlässig?

Wirf auch einen Blick aufs Logging: http://www.google.de/search?hl=de&q=group+policy+logging&oq=gro ...
Bitte warten ..
Mitglied: AquaSchaf
17.08.2011 um 17:30 Uhr
Startskripte sind keine Anmeldeskripte. Anmeldeskripte laufen nach der Anmeldung mit Userrechten (Konto:%username%), Startskripte
beim Rechnerstart mit Systemrechten (Konto: %computername%). Diese Option gibt es aber auch für Startskripte.

Da habe ich glatt überlesen. Die gleiche Option für Startskripte habe ich noch nicht gefunden. Ist die Einstellung eigentlich denn überhaupt sinnvoll in diesem Zusammenhang?

Warum nicht über MSI-Pakete? Man kann mit Tools wie WIWW (vinsvision) sogar Batches in MSI-Pakete einwickeln
Ich kenne dieses Tool nicht (es scheint auch keine Webseite mehr dazu zu geben). In diesem Fall habe ich mit den Mitteln von Office die Installation automatisiert und dann die setup.exe mit einem Startscript mit den benötigten Parametern aufgerufen. Mir sind keine einfacheren Wege bekannt, ich würde sie aber gerne kennen lernen


-Das Skript muss in jedem Fall ohne Rückfragen ablaufen. Kommen Rückfragen, hält es an.
Ich habe es mit diversen Skripten probiert. Am schluss mit echo "hello". Von daher liegt es definitv nicht an den Skripten.

> Ich habe mir zuerst die Gruppenrichtlinienereignisse angeschaut
Wo? rsop.msc?
Nein, mit gpresult /h.

> 65% der Rechner...nicht immer die gleichen
D.h. 65% machen es zuverlässig und 35% mehr oder weniger unzuverlässig?
Nein. Keiner ist wirklich zuverlässig. Aber es gibt (nach ca 15 Testläufen) Computer welche eine wesentlich höhere Erfolgsrate aufweisen als andere. Im Durchschnitt führen ca 2/3 ihre Skripte aus. Allerdings scheint sich die Rate ständig zu verringern.


Das hat mich auf die Idee gebracht mal etwas in die Ereignisanzeige zu schauen und anscheinend findet sich dort einen Hinweis auf den Fehler. Bei allen Computer, die ihre Skripte NICHT ausführen, wird folgende Meldung bei Systemstart geloggt. (Kann ich hier irgendwie Bilder hereinstellen?)

" Ereignis 1129

Bei der Verarbeitung der Gruppenrichtlinie ist aufgrund fehlender Netzwerkkonnektivität mit einem Domänencontroller ein Fehler aufgetreten. Dies kann eine vorübergehende Bedingung sein. Es wird eine Erfolgsmeldung generiert, wenn die Verbindung des Computers mit dem Domänencontroller wiederhergestellt wurde und wenn die Gruppenrichtlinie erfolgreich verarbeitet wurde. Falls für mehrere Stunden keine Erfolgsmeldung angezeigt wird, wenden Sie sich an den Administrator."

Heißt das, ein Netzwerkproblem ist aufgetreten? Bisher konnte sich jeder Rechner problemlos einloggen und auf Freigaben zugreifen. Versuche mir morgen einmal das Netzwerk genauer anzuschauen.
Bitte warten ..
Mitglied: DerWoWusste
17.08.2011 um 22:04 Uhr
Zu der Policyverarbeitung: Hab nochmal nachgesehen: Startskripte laufen per default immer vor der Anmeldung zu Ende - somit keine Anpassung notwendig.
Zu WIWW: stimmt, die offizielle Seite ist dicht. Wenn Du magst, kannst Du mir per PN eine Mailadresse senden und bekommst die .exe.
Zu gpresult /h: Nimm rsop und schau nach Problemen (Rechtsklick auf Computerkonfig machen ->Eigenschaften).
Zum Logging: Ja, evtl. Konnektivitätsprobleme. Nimm doch ein Testlab (Testdomäne) und schau, wie es da läuft. Was willst Du sonst machen? Wenn die DNS-Einträge auf die DCs weisen, dürfte es keine Probleme geben.
Bitte warten ..
Mitglied: Rico55
30.11.2011 um 15:03 Uhr
"DerWoWusste" hat Recht.
Das hört sich stark nach Konnektivitätsproblemen an.
Bitte warten ..
Ähnliche Inhalte
Windows Server

Startscript wird nicht überall ausgeführt

Frage von Thor01Windows Server5 Kommentare

Hallo, habe einer bestehenden Domäne einige neue PCs hinzugefügt und diese in die passenden OUs gesteckt. Verwunderlich ist jetzt, ...

Ubuntu

Startscripts in -etc-profile.d werden vor der Anmeldung ausgeführt

gelöst Frage von adm2015Ubuntu6 Kommentare

Hallo zusammen. Ich verwende derzeit die Ubuntu Version 17.10 bzw. im Test 18.04. Ich habe meine Anmeldescripte in dem ...

VB for Applications

Shell Befehl funktioniert manchmal, manchmal nicht

Frage von donky2000VB for Applications4 Kommentare

Hallo zusammen, wenn ich neue PCs installiere rufe ich die zu instllierenden Programme per Makro aus Excel 2010 auf. ...

Windows Server

Startscript erfordert bei Windows Clients aufeinmal andere Rechte

Frage von staybbWindows Server1 Kommentar

Hallo zusammen, wir haben bei uns ein Startscript als .cmd auf dem Domäncontroller liegen, welches von Windows 7 und ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 19 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 22 StundenAdministrator.de Feedback16 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Windows Netzwerk
Backup über WAN
Frage von petereWindows Netzwerk11 Kommentare

Hallo, ich muss aus einem entfernten WAN (synchrone 1Gbit) Daten sichern. Dabei handelt es sich sowohl um wenige große ...