Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VMware Server und Broadcom VLAN

Mitglied: dog

dog (Level 4) - Jetzt verbinden

19.01.2009, aktualisiert 09:55 Uhr, 6911 Aufrufe, 6 Kommentare

Hallo,

ich habe ein Netzwerkproblem mit VMware Server 2.0 und einer Broadcom BCM5708C Netzwerkkarte.

Der Host hat mehrere virtuelle Netzwerkkarten für verschiedene VLANs.
Das "VMware Bridge Protocol" ist bei allen Karten außer der Physikalischen (die auch keine IP hat) aktiviert.

Ein Gast braucht nun Zugriff auf 2 der VLANs.
Dazu habe ich in der Konsole zwei virtuelle Netzwerkkarten (bridged) angelegt und im Gast beide mit einer statischen IP konfiguriert -> Kein Zugriff nach Außen.

Dann habe ich im Virtual Network Editor die Regeln etwas expliziter gesetzt und die betreffenden Adapter des Hosts an VMnet Adapter gebunden und ein Subnet für jeden Adapter konfiguriert -> auch keine Änderung.

Was mache ich falsch?

Grüße

Max
Mitglied: aqui
19.01.2009 um 10:29 Uhr
Hier steht was du dazu wissen musst:

http://www.vmware.com/pdf/esx3_vlan_wp.pdf
Bitte warten ..
Mitglied: dog
19.01.2009 um 11:02 Uhr
Hallo,

das bezieht sich soweit ich gesehen habe nur auf den ESX Server - Ich benutze aber den "normalen" Vmware Server, der selbst ja nicht "VLAN-aware" ist.

Grüße

Max
Bitte warten ..
Mitglied: RoterFruchtZwerg
19.01.2009 um 14:10 Uhr
Möglicherweise verwirft der VLAN Treiber des Hosts Pakete mit einer MAC Adresse die nicht von einem der VLAN Adapter stammt?
Wirf doch mal Wireshark an und schau ob du die Pakete der VMs überhaupt am VLAN Adapter des Hosts mitsniffen kannst. Wenn ja, überprüf mit einem weiteren PC, ob diese auch tatsächlich aufs Netz gegeben werden und ob sie dort mit dem VLAN Tag versehen sind.
Bitte warten ..
Mitglied: aqui
19.01.2009 um 16:42 Uhr
Das ist klar das das dann nicht geht !!!
VLAN getaggte Pakete nach 802.1q werden an normalen (untagged) Ports immer verworfen und umgedreht !!!
Die Frame Formate sind nicht kompatibel !!
Bitte warten ..
Mitglied: dog
19.01.2009 um 17:31 Uhr
Moment. So wie ich das verstehe sollte der Broadcom Treiber die VLAN-Tags aus der Gleichung rausziehen. Sprich einkommende getaggte Pakete werden zu normalen und auf eine der virtuellen Netzwerkkarten verteilt und ausgehende Pakete werden je nach virtueller Karte mit einem Tag versehen. Somit sollten die VLANs also für Windows und VMware eigentlich egal sein solange die richtige Netzwerkkarte für das richtige Subnet benutzt wird...

Allerdings habe ich mir grade mal mit Wireshark den Traffic des Hosts angeschaut und dort haben alle ausgehenden TCP/UDP Pakete eine fehlerhafte Checksum (was aber in der Praxis noch zu keinen Problemen geführt hat).

Ich glaube, ich sollte doch mal irgendwo die 70€ für eine Intel PRO Karte auftreiben.

Morgen werde ich aber erstmal versuchen Wireshark irgendwie in den Gast zu bekommen und schauen was dort so ankommt.

Grüße

Max
Bitte warten ..
Mitglied: RoterFruchtZwerg
19.01.2009 um 17:52 Uhr
Du siehst das schon richtig, die virtuellen Adapter sind ja dazu da die VLANs in (für das OS) virtuelle separate Netze aufzuteilen. Es sollten also keine VLAN Tags auf den virtuellen Adaptern zu sniffen sein. Die Frage ist aber, wo setzt der Treiber an und klebt das VLAN Tag davor... da kann es schon sein, dass es mit VMware Probleme gibt.

Aber du hast jetzt die virtuellen Adapter mit gesnifft, was kam dabei raus? Kommen Daten der VMs auf die virtuellen Adapter?

Und wegen der Checksumme, google mal nach "TCP/UDP Checksum offload", da gibt es oft eine Option in den Hardwareeigenschaften der Adaptern, wo man das umstellen kann.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

VLAN mit pfSense Routing: Server als Mitglied in mehreren VLANs

Frage von RuuderLAN, WAN, Wireless1 Kommentar

Hallo Profis, ich möchte einen Server (PXE Boot Umgebung Client / Server) als Mitglied in mehreren VLANs einrichten. Am ...

Windows 7

Mobile Broadcom APN via Console ändern

gelöst Frage von today12Windows 78 Kommentare

Hallo liebe Leute, ich brauch unbedingt Hilfe von euch, da ich schon nicht mehr weiß, nach was ich suchen ...

Router & Routing

PfSense: Zugriff auf Server von anderem VLAN

Frage von mabue88Router & Routing3 Kommentare

Hi, habe mal wieder ein Problem an dem ich hänge pfSense mit mehreren VLANs. In einem VLAN (ID 1) ...

Netzwerke

Zugriff auf Server von verschiedenen VLANs aus

gelöst Frage von Kroeger02Netzwerke7 Kommentare

Hallo zusammen, ich habe folgende Konstellation (Habe sie auf auf das nötigste der zugehörigen Komponenten reduziert). VLAN1 10.4.0.254 (10.4.0.0/24) ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 7 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 9 StundenAdministrator.de Feedback10 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...