Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Xampp Webserver

Mitglied: fruchttiger

fruchttiger (Level 1) - Jetzt verbinden

25.12.2005, aktualisiert 23.10.2012, 5832 Aufrufe, 16 Kommentare

Ich habe Probleme diesen Apache zum laufen zu bekommen

Hallo ich habe einen Windows 2003 Server " root "
ich komme mit dem Web einfach nicht klar " muss noch übe n"

Ich wollte daher xampp benutzen aber wenn ich den Apache starten will kommt immer folgende Meldung siehe Bild.
könnte mir jemand sagen was das ist und wie ich das hinbekomme ?

Oder gibt es eine sehr gute Seite wo ich nach lesen kann wie man php sql usw auf dem Server administriert bzw benutzt ?

Ich habe den Server von Server4you.de und es sollte alles installiert sein wie sql peal usw aber ich bekomm damit nichts zum laufen !


PS : Frohe Weihnachten


9f4ecb166a799ccb754196d1a86671f2-unbenannt - Klicke auf das Bild, um es zu vergrößern
Mitglied: 10545
25.12.2005 um 17:00 Uhr
Gehe in die HTTPD.CONF und suche Dir dort die Zeile, die mit LISTEN beginnt.
(Darüber steht als Hinweis folgender Text: <tt>
  1. Change this to Listen on specific IP addresses as shown below to
  2. prevent Apache from glomming onto all bound IP addresses (0.0.0.0)</tt>)

Neben dem Listen solltest Du nun Deine IP des Rechners angeben: 127.0.0.1
oder gleich mit Port:
Listen 127.0.0.1:80

Gruß, Rene

<div align="center" style="width:100%; vertical-align:middle; background:silver; height:20px; border-style:solid; border-width:thin; border-color:#000000" dir="ltr" lang="de"><font size="1">Footer: Nutzt die Bewertungsfunktion. Ihr helft damit den Usern! Siehe <a href="https://www.administrator.de/Unsere_Top-User_kommen_in_die_ct_Zeitschrif ..." target="_blank"> hier!</a></font></div>
Bitte warten ..
Mitglied: fruchttiger
25.12.2005 um 17:09 Uhr
zuerst einmal danke das jemand antwortet ,
aber leider bekomme ich nun die Fehlermeldung mit der IP 127.0.0.1
ich habe einmal nur die IP eingegeben und einmal mit Port beides mal das selbe Problem .

Ich werde ncoh mal dulle hier .
Bitte warten ..
Mitglied: 10545
25.12.2005 um 17:37 Uhr
Poste mal bitte Deine <tt>ipconfig /all</tt> hier, dann finden wir das "Übel" schon.

Gruß, Rene

PS:
· Hast Du auf der Maschine noch sonstige Serverdienste auf (virtuellen) IP´s laufen?
· Wieviele NIC´s sind in dem Rechner (ok, sehe ich mit IPCONFIG )?
· (Windows-)Firewall deaktiviert, angepasst?
Bitte warten ..
Mitglied: fruchttiger
25.12.2005 um 19:23 Uhr
wie bekomm ich nun das Bild hier rein ?

Ich hoffe man sieht es

http://62.75.222.233/Ipconfig.JPG
Bitte warten ..
Mitglied: IceBeer
25.12.2005 um 20:01 Uhr
Hallo Leute,

die Meldung sagt lediglich das auf der Kiste schon ein Webserver läuft. IIS ausmachen und freuen...

MfG IceBeer
Bitte warten ..
Mitglied: 10545
25.12.2005 um 20:06 Uhr
Moin,

die Meldung sagt lediglich das auf der Kiste
schon ein Webserver läuft. IIS ausmachen
und freuen...
Arghh! Natürlich, klar ...(Server 2003) ...

Zum Screenshot Nr.: 2:

Da Du eine öffentliche IP-Anbindung hast, sollte es reichen, wenn Du unter"LISTEN" nur
<tt>Listen 80</TT> einstellst (um wieder den "Urzustand" herzustellen).

Gruß, Rene
Bitte warten ..
Mitglied: fruchttiger
25.12.2005 um 20:29 Uhr
so also soweit so gut !
DANKE

aber wie benutzt man dieses IIS ?
Ich sag mal normale http Seiten liefen ja
nur php und sql gingen irgendwie nicht bzw ich weis nicht wo ich was machen muss.

Ich würde mich natürlich dafür intressieren diese Sache zu benutzen nur wo kann man da ordentlich nach lesen ? " am besten deutsch "

nun nutz ich erst einmal xampp
Bitte warten ..
Mitglied: IceBeer
25.12.2005 um 20:35 Uhr
Hallo,

was meinst du mit: "er wie benutzt man dieses IIS ?"

Der IIS stellt generell, unter anderem, einen Webserver zur Verfügung wie der XAMPP auch.
Allerdings weiß ich nicht was der IIS alles kann, standardmäßig glaub nur asp.
In wie weit und wie man dem IIS php etc beibringen kann weiß ich nicht.

Ansonsten kopiert man seine Webseite einfach in den in der Konfig definierten Pfad und gut.
SQL-Datenbanken werden über php oder asp angebunden, wenn dein IIS kein php kann dann gehen die Seiten auch nicht.

MfG IceBeer
Bitte warten ..
Mitglied: 16568
25.12.2005 um 21:39 Uhr
Wenn Du XAMPP weiterhin nutzen willst (und das rate ich Dir als gebranntes Kind des IIS), dann solltest Du den IIS deinstallieren/deaktivieren.

XAMPP bietet meiner Meinung nach nämlich sehr viele Vorzüge...



Lonesome Walker
Bitte warten ..
Mitglied: fruchttiger
25.12.2005 um 21:43 Uhr
also ich bin mit xampp bisher sehr zufrieden aber warum keine neuen Sachen kennenlernen ?

xampp ist doch kostenlos oder irre ich mich ?
Bitte warten ..
Mitglied: IceBeer
25.12.2005 um 22:11 Uhr
Hallo,

ich bin auch ein Fan vom XAMPP... Ja ist kostenlos...
www.apachefriends.org

MfG IceBeer

[edit: daher kannte ich auch die nette meldung das schon was auf port 80 läuft]
Bitte warten ..
Mitglied: fruchttiger
25.12.2005 um 22:51 Uhr
so alles was ich will / brauche läuft !
DANKE

Ich habe da aber noch eine frage die da wäre man kommt auf den Server ja per Remote Tool " eingebaut in xp "
In meiner firma sind die Ports leider dicht gemacht , also kann ich von dort aus auch nicht auf den Server .
Ich habe aber gehört das es ein Tool gibt das es ermöglicht per Web auf den Server zu kommen.
" halt eine Internetseite aufrufen und man hat so ziemlich das selbe als wäre man mit dem Remotetool auf dem Server "

kennt so etwas wer oder könnt man mir andere möglichkeiten aufzählen ?

danke für eure mühe aber ich bin gerade am anfang mit dem Server
Bitte warten ..
Mitglied: 16568
25.12.2005 um 23:06 Uhr
http://www.remotelyanywhere.com

Das nutze ich.

Oder Du nimmst den Klassiker, VNC, mit dem kann man via Java auch mit http darauf zugreifen.

Beide erfordern jedoch 1-mehrere Ports, die geöffnet sein müssen/angepaßt werden müssen...


Lonesome Walker
Bitte warten ..
Mitglied: fruchttiger
26.12.2005 um 20:38 Uhr
das werde ich mal testen aber ich denke mal das auch da der Port auf unserer Firma dicht ist

Ich habe aber noch eine Frage die da wäre
ich habe eine de Adresse bekommen wenn ich diese nun aufrufe lande ich genau im xampp Ordner und nicht in dem wo die HP liegt

wo muss ich festlegen das wenn man die URL aufruft man in xammp\htdocs\page landet und nicht auf localhost ?
Bitte warten ..
Mitglied: 16568
26.12.2005 um 21:03 Uhr
Eigentlich müsste acuh dieser Thread *closed* sein, weil das zum Thema Webserver gehört.

Lösch mal alles aus Deinem Root-Verzeichnis, außer dem xampp-verzeichnis.


LSW
Bitte warten ..
Mitglied: fruchttiger
26.12.2005 um 21:08 Uhr
was soll ich da löschen habe den xampp auf c:
Bitte warten ..
Ähnliche Inhalte
Apache Server
PfSense und XAMPP
gelöst Frage von micsonApache Server2 Kommentare

Hallo, zuerst wünsche ich euch allen ein frohes Osterfest! Folgendes Problem: Habe pfSense auf einem ALIX-Board laufen. Dort hängt ...

Hyper-V
Netzwerklastenausgleich auch mit Xampp ?
Frage von RasmusenHyper-V8 Kommentare

Hi, ich habe derzeit einen physikalischen Windows2008 R2 Server und einen HyperV Host mit 2 Win2012R2 VMs am laufen. ...

Hosting & Housing

XAMPP Website über Internet erreichbar machen

Frage von ShaddyHosting & Housing36 Kommentare

Vorwort (BITTE LESEN): -Ich weiß, dass es Sicherheitsbedenken gibt, wenn ich XAMPP vom Internet aus erreichbar mache. -Ich möchte ...

Internet

Xampp - Appache Dienst geht nicht!

gelöst Frage von FengShuiInternet9 Kommentare

Hallo zusammen, ein kleines Problem mit dem Appache Start. Heute habe ich Xampp installiert und nachdem habe ich den ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 4 StundenGoogle Android2 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 5 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 8 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server39 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing18 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

CPU, RAM, Mainboards
32 gb RAM zu wenig?
Frage von pcguyCPU, RAM, Mainboards13 Kommentare

Hallo zusammen, mein PC verfügt über 32GB Ram. Nun kriege ich bei grossen Dateien im Illustrator die Fehlermeldung das ...