Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anwendung im Netzwerk wieder i.l.d. Tages immer langsamer

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Ati

Ati (Level 1) - Jetzt verbinden

10.02.2005, aktualisiert 11.02.2005, 5482 Aufrufe, 10 Kommentare

Guten Morgen,
ich bin neu hier und weiß nicht ob mein Problem hier überhaupt richtig plaziert ist. Es handelt sich um folgendes. Ich habe eine Access-Anwendung für meine Firma geschrieben und diese in Frontend und Backend aufgeteilt. Das Frontend wird lokal auf dem Client ausgeführt das Backend liegt auf dem Server. Wenn ich jetzt morgens diese Anwendung starte und ein spezielles Formular öffnen will, dauert es so 2-3 Sekunden. Je später am Tag ich nun diese Anwendung starte um so länger dauert das öffnen (bis zu 40 Sek.). Erst dachte ich es liegt daran das tagsüber ja alle User im Netzwerk rumfuchteln, als ich aber mal abends hier alleine war und es nochmal testete dauerte es trotzdem Ewigkeiten. Ich vermute jetzt mal das tagsüber irgendwas auf dem Server "aufläuft" was die Performance so stark beeinflußt.
Hatte hier vielleicht jemand mal ein ähnliches Problem, oder kann mir jemand einen Tip geben was wir mal untersuchen sollten????

Danke im voraus
Ati

P.S. bei uns kommt ein Windows 2000 Server zum Einsatz
Mitglied: phpchris
10.02.2005 um 10:46 Uhr
Moin moin,

also, was ich checken würde, ist ob auf dem Server, wo dein Backend läuft, ein OnAccess-Virenscanner läuft.
Wenn ja, schließe das Verzeichnis aus, in dem sich das Backend befindet.

Weiter solltest du mal im Netzwerk checklen, ob bei den Clients eine Funktion "Netzlaufwerke schützen" oder so ähnlich eingeschaltet ist.

Das war die Ursache für Netzwerk-Ausbremsung bei den meisten meiner Kunden.
Bitte warten ..
Mitglied: Ati
10.02.2005 um 12:42 Uhr
Danke für Deine Antwort. Das mit dem Scanner geb ich zwar mal weiter aber ich mein nicht das sowas bei uns läuft.
Das mit dem "Netzlaufwerke schützen" kenn ich gar nicht. Wo befindet sich die Option und was mich interessieren würde ist was die Funktion genau bewirkt.

Ati
Bitte warten ..
Mitglied: phpchris
10.02.2005 um 12:47 Uhr
Einige Virenscaner haben ein "Feature" mit dem Netzlaufwerke, also Freigaben auf anderen Servern, die al Netzlaufwerke verbunden sind, automatisch mitgescannt werden, sobald sich dort eine Datei verändert.
Das hat zur Folge, dass sich mehrere User (bzw. deren Virenscanner) gleichzeitig auf eine Datei stürzen, sobald diese sich verändert.
Ein Virenscanner sperrt den zugriff für andere Programme, während er eine Datei durchsucht.
So kann es kommen, dass die Datei erst nach so einigen Sekunden endgültig für eine Anwendung freigegeben wird.
Bitte warten ..
Mitglied: Ati
10.02.2005 um 12:56 Uhr
Sorry da war ich auf dem Holzweg. Das mit dem OnAccess-Scanner muß ich doch nochmal hinterfragen, sieht so aus als ob es einer ist (Kaspersky Antii-Virus 3.5.133.0). Die Einstellung auf den Clients sind meines Wissens alle gleich und da habe ich mal meine Einstellung kontrolliert und dort sind Netzlaufwerke ausgeklammert. Es erscheint mir auch seltsam das es daran liegen soll, da ja auch spät abends wenn keiner mehr hier ist die Anwendung so langsam startet und da sind ja sämtliche Clients ausgeschaltet. Wenn ich hier einen Denkfehler habe bitte aufklären.

Ati
Bitte warten ..
Mitglied: phpchris
10.02.2005 um 13:04 Uhr
Nein, einen Denkfehler hast du nicht.
Ich dachte bloß, da du ja schreibst "i.L.d.Tages", dass tagsüber, also wenn mehrere Leute die Rechner anhaben, die Anwendung langsam wird.

Wenn der Virenscanner auch auf dem Server läuft, versuch mal diesn Pfad, wo dein Programm läuft aus dem On-Access-Scanner auszuschließen.
Bitte warten ..
Mitglied: gemini
10.02.2005 um 21:07 Uhr
Der Rest des Netzwerkes läuft normal?
Ist die Datenbank schon mal stabil gelaufen?

Die Datenbank ist also den ganzen Tag offen und viele User machen viele Transaktionen.
Wann wird sie denn komprimiert?

Anderer Ansatz: Besteht die Möglichkeit, dass durch einen Programmierfehler irgendwelche Speicher vollaufen bzw. Variablen nicht geleert werden etc. pp?
Bitte warten ..
Mitglied: Ati
11.02.2005 um 06:26 Uhr
"Der Rest des Netzwerkes läuft normal?"
Naja was man so normal nennt. Spaß beiseite eigentlich läuft der Rest normal.

"Ist die Datenbank schon mal stabil gelaufen?"
Das ist es ja.... morgens läuft sie normal. D.h. für mich auch stabil.

"Die Datenbank ist also den ganzen Tag offen und viele User machen viele Transaktionen."
Eben nicht. Es handelt sich hierbei um eine hausgemachte Information über unsere Logistik! D.h. es werden eigentlich nur Daten abgefragt und nicht eingegeben.

"Wann wird sie denn komprimiert?"
Das wird speziell gar nicht gemacht, da es sich hierbei um ein Fe und mehrere Access-DB´s als Be handelt. Könnte aber mal ein Ansatz sein.

"Anderer Ansatz: Besteht die Möglichkeit, dass durch einen Programmierfehler irgendwelche Speicher vollaufen bzw. Variablen nicht geleert werden etc. pp?"
Einen Programmierfehler habe ich als erstes vermutet, paßt aber nicht mit der Tatsache zusammen das morgens alles normal läuft. Zum Thema Variablen kann ich nur sagen das ich in dieser Anwendung kaum mit Variablen arbeite, da ja nur Daten angezeigt (Formulare+Unterformulare) werden. Ich habe zwar einige optimierungen vorgenommen (z.B. die dartsellung eines Unterformulares als Snapshot statt Dynaset) was auch leicht was gebracht hat, aber wie gesagt der Knaller ist das irgendwie alles noch nicht.
Leider seh ich hier nicht die Möglichkeiten was hochzuladen, sonst würd ich Euch mal meine geistige Erfindung zur Verfügung stellen, da ich ja bestimmt nicht frei von Fehlern bin.

Ati
Bitte warten ..
Mitglied: Ati
11.02.2005 um 06:29 Uhr
Was eventuell wichtiges habe ich noch vergessen. Und zwar wird unser Server jeden morgen um 5.oo Uhr neu gestartet, was für mich einIndiz ist das es am Server liegen könnte. Weshalb sollte sonst nach einem Neustart alles wieder normal funktionieren???

Ati
Bitte warten ..
Mitglied: gemini
11.02.2005 um 07:32 Uhr
Das sehe ich auch so.

Kannst du den Server einmal nicht durchstarten, wie sich die DB dann verhält.
Evtl. gibt auch der Systemmonitor etwas her.

Den Virenscanner würd ich jetzt mal ausschließen.
Da wäre die DB imho den ganzen Tag langsam; der Scanner prüft ja morgens ganuaso wie abends.
Bitte warten ..
Mitglied: Ati
11.02.2005 um 12:01 Uhr
So jetzt wird es kompliziert. Also unser Warenwirtschaftssystem läuft auf einer Alpha-Anlage unter OpenVMS. Mit einer speziellen Software (Pathworks) habe wir die Möglichkeit über den Explorer auf diverse Verzeichnisse der Alpha-Anlage zuzugreifen (Netzlaufwerk). Jetzt ist es aber passiert, das unser Server Abends bzw. Nachts aus unerfindlichen Gründen diese Verbindung verliert. Nach Tagen des Suchens und Testens haben wir uns für die "Kreuzknobelschaltung" mit dem zeitgesteuerten Neustart ausgedacht. Deswegen kann ich den Neustart auch nicht auslassen.

Ati
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst Mikrotik Router in Netzwerk einbinden (3)

Frage von Cyberurmel zum Thema Router & Routing ...

Netzwerkmanagement
gelöst Gäste Netzwerk im Simulator einrichten (4)

Frage von WinLiCLI zum Thema Netzwerkmanagement ...

Windows Netzwerk
Große Abweichung der Übertragungsraten im WinServer2012 Netzwerk (3)

Frage von sineplan zum Thema Windows Netzwerk ...

LAN, WAN, Wireless
gelöst Maschinen per WLAN ins Netzwerk bringen (6)

Frage von laster zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Administrator.de Feedback

Umgangsformen auf der Seite

(7)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(10)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows Server
Windows Server 2016 RDS Remoteapp Anzeigefehler (11)

Frage von qlnGenius zum Thema Windows Server ...

Windows Server
Festplatten Ruhezustand Windows Server 2016 (10)

Frage von ahaeuser zum Thema Windows Server ...