Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache unter Xampp startet nicht

Frage Linux Apache Server

Mitglied: Corraggiouno

Corraggiouno (Level 2) - Jetzt verbinden

28.01.2011 um 23:34 Uhr, 10934 Aufrufe, 5 Kommentare

hi,

hat von euch jemand eine Idee warum der Apache unter Xammp nicht startet?
Nutze Windows 7 PRof. 64bit. Folgende Fehlermeldung bekomme ich, beim Versuch den Apache Service zu starten

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
Syntax error on line 501 of C:/Program Files (x86)/xampp/apache/conf/httpd.conf:

SSLSessionCache: Invalid argument: size has to be >= 8192 bytes

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .

Kann mir jemand weiterhelfen? Habe die Benutzerkontensteuerung deaktiviert; der MySQl-Dienst läuft aber!
Mitglied: Petrof
29.01.2011 um 06:32 Uhr
Moin,

aus einem anderen Forum:

Eventuell ist die UAC daran schuld. Wenn die Benutzerkontensteuerung aktiviert ist und man ein anderes Verzeichnis als c:\xampp wählt (z.B. unter Programme) funkt Win7 da oft dazwischen was die zu installierenden Dienste angeht. Vermutlich fehlt da die Berechtigung irgendwie. Versuche mal eine Neuinstallation ohne die UAC sofern die aktiviert ist.


Dort hat es geholfen Xampp direkt unter C: zu installieren.

Gruß
Peter
Bitte warten ..
Mitglied: Corraggiouno
29.01.2011 um 11:56 Uhr
genau das habe ich gemacht; xampp sauber deinstalliert die UAC deaktiviert...........und xampp neuinstalliert: der Apache Dienst läst sich dennoch nicht starten.....................MySQL-Dienst lässt sich starten bzw. ist gestartet
In der Ereignisseanzeige unter Windows wird mit folgendes angegeben:
The Apache service named reported the following error:
SSLSessionCache: Invalid argument: size has to be >= 8192 bytes .

...........und wenn ich den Dienst unter der /Verwaltung in Windows starten möchte.............dann wird mit diese Meldung noch angezeigt:

Apache 2.2 auf Lokaler computer konnte nicht gestart werden. Weitere Informationen finden Sie im Systemereignisprotokoll

Kann mir jemand sagen, woran das liegt bzw. weiterhelfen, wie ich den Dienst Apache zum Starten bekomme?
Bitte warten ..
Mitglied: Arano
29.01.2011 um 13:02 Uhr
Moin moin

Erklärt mir doch bitte beide einmal warum ihr an die UACdingsbubs denkt und alles neu installiert ? (vielleicht mal Windows neu installieren, das hat auch schon so manche Fehler behoben - vermutet man)

In der Fehlermeldung steht doch wo es hängt, was hängt und das sogar auf die Zeile genau !
Syntax error on line 501 of C:/Program Files (x86)/xampp/apache/conf/httpd.conf:
SSLSessionCache: Invalid argument: size has to be >= 8192 bytes
"Ein Fehler in Zeile 501 der Datei "httpd.conf" (in C:\Program Files (x86\xampp\apache\conf)"
httpd.conf - was könnte das wohl für eine Datei sein...
httpd = Hypertext Transfer Protokol Deamon, aha, ein Webserver... vermutlich der Apache
conf wie configuration
...also eine Datei die sich "Apache konfiguration" nennt enthält in Zeile 501 einen Fehler.
AHAA, es handelt sich also um einen Konfigurationsfehler des Webservers, was für ein Fehler ?
"SSLSessionCache: Invalid argument: size has to be >= 8192 bytes"
Der an die Directive "SSLSessionCache" übergebene Wert __sollte__ größer oder gleich 8192 bytes sein.

Hast du schon mal in die Dokumentation geguckt ?
Apache HTTP Server: mod_ssl - SSLSessionCache

Und was steht bei dir in der httpd.conf in Zeile 501 ?


~Arano

Mein Tip: Installiere dir deinen Web- und Datenbankserver sowie PHP lieber selber, mit den original Installationspaketen direkt von den Herstellern UND verstehe mit was du da arbeitetest ;)
Bitte warten ..
Mitglied: Corraggiouno
01.02.2011 um 21:34 Uhr
in meiner httpd.conf steht folgendes:

<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLSessionCache "shmcb:logs/ssl.scache(512000)"
SSLSessionCacheTimeout 300
</IfModule>

Was muss ich da genau ändern?
Bitte warten ..
Mitglied: Arano
02.02.2011 um 19:39 Uhr
Hallo.

Genau kann ich dir das auch nicht sagen

Zuerst könntest du es mal mit einer absoluten Pfadangabe versuchen z.B:
SSLSessionCache "shmcb:C:/Programme/xamp/logs/ssl.scache(512000)"

Und wenn das nicht hilft, habe ich hier noch etwas gefunden das die gleiche Fehlermeldung auf einem 64bit System produzieren kann:
Apache Wiki - SSLSessionCache


~Arano
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...