Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Autodiscover einrichten auf Exchange 2007

Frage Microsoft Exchange Server

Mitglied: ckbaxter

ckbaxter (Level 1) - Jetzt verbinden

09.10.2009, aktualisiert 11:17 Uhr, 16565 Aufrufe, 15 Kommentare, 1 Danke

Hi Leute ich brauch mal Hilfe;)

Folgende Situation:

Bei einen Kunden steht ein Exchange 2007 der auf nen Windows 2008 installiert, funktioneirt soweit ganz gut, nun habe ich RPC over HTTPS eingerichtet, funktioniert auch soweit bis auf den Abwesentheitsassistent, da kommt beim Aufruf die Meldung: "Ihre Abwesenheitseinstellung können nicht angezeigt werden, da der server zurzeit nicht verfügbar ist. Versuchen Sie es später erneut.", auch wenn ich Outlook im selben Netz aufrufe (Rechner ist nicht in der Domäne) kommt diese Meldung.

Habe jetzt im Internet recherchiert das ich Autodiscover richtig konfigurieren muss, damit das funktioniert. Mein Problem ist aber das der Server über eine DynDns Adresse erreichbar ist. Aber die eigentliche Mail Adresse geht auf eine andere Domain, wir holen die E-Mails mittels POPBeamer ab, deshalb ist Mail Adresse anders als der DynDns Name. Wenn ich nun im Outlook "E-Mail Autokonfiguration testen" mache (per RPC over HTTPS), will er immer https://autodiscover.domain.de/autodiscover/autodiscover.xml auflösen aber das geht ja nicht, weil mein Server ja auf die dyndns Adresse horcht. Wie kann ich das Problem lösen? Im Prinzip muss ja das Autodiscover auf https://name.dyndns.org/autodiscover/autodiscover.xml gehen, oder? Manuell ist https://name.dyndns.org/autodiscover/autodiscover.xml im Webbrowser erreichbar. Habe keine richtige Idee mehr.

Intern funktioniert das ganze auch nicht.

Wäre sehr dankbar für eure Hilfe.
Mitglied: Kubelkubel
09.10.2009 um 12:08 Uhr
Hi,

du musst ein sogenanntes SAN-Zertifikat erstellen.
Bei diesem SAN-Zertifikat kannst du mehrere DNS-Namen für OWA/ActiveSync und natürlich auch für Autodiscover angeben.
Dem entsprechend vergibst du beim erstellen dieses Zertifikates mehrere DNS Namen für Autodiscover, also einmal interner dnsname und einmal dyndnsname.
Intern legst du, falls noch nicht vorhanden, auf deinem DNS einen Host A Eintrag für Autodicover an.
Bitte warten ..
Mitglied: ckbaxter
09.10.2009 um 16:53 Uhr
hast du vllt eine Schritt für Schritt Anleitung dafür?
Bitte warten ..
Mitglied: filippg
10.10.2009 um 17:29 Uhr
Hallo,

ein anderes Zertifikat wird erstmal überhaupt nichts helfen - das Problem ist ja nicht, dass OL über ein ungültiges Zertifikat stolpert, sondern dass es schlicht den falschen Host versucht. Um das zu lösen gibt es mehrere Ansätze
1. Wenn es nur um Clients geht, die in der Domäne sind kannst du im DNS einen SCP auf den richtigen Server anlegen
2. Dem Kunde gehört die Domain ja wohl - dann kannst du im DNS einen SRV-Record eintragen lassen
3. Du kannst über einen Registry-Key und eine XML-Datei den Client dazu anweisen unter einer ganz anderen URL zu suchen. Erfordert leider Anfassen aller Clients.
Weiteres dazu findet sich z.B. unter http://www.msexchangefaq.de/e2007/autodiscover.htm

Gruß

Filipp
Bitte warten ..
Mitglied: ollembyssan
11.10.2009 um 11:56 Uhr
*ohne die h(t)tps !Klammern! im Shell schreiben:

Set-ClientAccessServer
-AutoDiscoverServiceInternalUri h(t)tps://name.domain.local/Autodiscover/Autodiscover.xml

set-AutodiscoverVirtualDirectory
- InternalUrl h(t)tps://name.domain.local/Autodiscover/Autodiscover.xml
- ExternalUrl h(t)tps://name.dyndns.org/Autodiscover/Autodiscover.xml

set-AutoDiscoverVirtualDirectory `
-Websitename "Autodiscover (Default Web Site)" `
-ExternalUrl "h(t)tps://name.domain.local/autodiscover/autodiscover.aspx" `
-InternalURL "h(t)tps://name.dyndns.org/autodiscover/autodiscover.aspx"
Bitte warten ..
Mitglied: ckbaxter
11.10.2009 um 19:31 Uhr
ich kann aber auch einen CNAME von autodiscover.domain.tld auf den DynDNS-Name erstellen? sollte auch funzen oder?

danke ollembyssan diese schritte habe ich alle schon durch, aber bis jetzt funktioniert es noch nit ganz, werd morgen nochmal danach schauen.
Bitte warten ..
Mitglied: filippg
11.10.2009 um 19:58 Uhr
Hallo,

ich glaube, den CNAME "mag" Outlook nicht, bin mir aber nicht sicher -> einfach mal ausprobieren. Spannend ist dann natürlich, ob das Zertifikat auf autodiscover.domain.tld oder auf den dyndns-Name (der ja beim Resolve des CNAME geliefert wird) ausgestellt sein muss.

Gruß

Filipp
Bitte warten ..
Mitglied: ckbaxter
12.10.2009 um 09:51 Uhr
So habe jetzt den CNAME erstellt, der löst jetzt auch richtig auf, aber funktionieren tut es immer noch nicht.

Ist es normal das die autodiscover.xml auf dem Server leer ist? Da steht nur <!-- This is a placeholder file --> drin.
Bitte warten ..
Mitglied: Kubelkubel
12.10.2009 um 11:49 Uhr
wie auch immer
Bitte warten ..
Mitglied: ckbaxter
12.10.2009 um 15:03 Uhr
Ich habe jetzt mal auf https://www.testexchangeconnectivity.com/ das Autodiscover getestet, er scheitert am Zertifikat...

Validating certificate name
Certificate name validation failed

Additional Details
Host name autodiscover.name.tld does not match any name found on the server certificate CN=name.dyndns.org, OU=DUMMY, O=DUMMY, L=DUMMY, S=DUMMY, C=DE

Aber wie stelle ich nun im Windows 2008 ein Zertifikat aus was auf beide Domains (name.tld und name.dyndns.org) ausgestellt ist?

Das dyndns.org Zertifikat brauch ich für RPC over HTTPS.

Grüße
Bitte warten ..
Mitglied: Kubelkubel
14.10.2009 um 19:57 Uhr
HAAAAAAALLLLLLOOOOO......SSSSSSSSAAAAAAAAANNNN-Zertifikat....
habe ich dir doch schon gesagt....maaaaaaaan

mit dem SAN-Zert kanst du einem "Dienst" meeeeeehrrerererererer DNS-Namen verpassen...
Bitte warten ..
Mitglied: ckbaxter
15.10.2009 um 07:50 Uhr
Hi,

das habe ich doch schon probiert, schon kurz nachdem du mir das geschrieben hast, bei mir is ein SAN Zertifikat installiert, es läuft auf 3 Domainnamen und das wird mir auch im Browser angezeigt und es geht trotzdem nicht....der test im Outlook schlägt trotzdem fehl und der test auf https://www.testexchangeconnectivity.com/ schlägt auch fehl.....
Bitte warten ..
Mitglied: Kubelkubel
19.10.2009 um 12:09 Uhr
Du musst autodiscover mehrere DNS namen verpassen, unteranderem auch den externen.
Das SAN-Cert MUSS den externen Namen haben!

Gruß
Bitte warten ..
Mitglied: ckbaxter
19.10.2009 um 18:57 Uhr
Wie geb ich denn dem autodiscover mehrere DNS namen? Benutze Win 2008 SBS..

das san cert haben ich mir über den certsrv schon geholt, extra erstellen muss man das san cert auf den server nicht oder? bin wie auf msyfaq.de vorgegangen
Bitte warten ..
Mitglied: Kubelkubel
28.10.2009 um 09:55 Uhr
Bischen suchen:

Hier wird beschrieben wie du ein SAN-Zert für OWA einrichtest.
Packst einfach die Autodiscover-DNS-Namen mit bei - mehrfach - also externen und internen DNS-Namen.

http://www.msexchange.org/articles_tutorials/exchange-server-2007/high- ...

leider ist die Beschreibung bei MSXFAQ nicht ganz richtig.


Wichtig ist der Bereich innerhalb des Befehles: -DomainName

Hier kannst du für die jeweiligen Dienste mehrere DNS-Namen vergeben.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

DSL, VDSL
Fritzbox Exchange 2007 UM Gateway mit Freetz (2)

Frage von Herbrich19 zum Thema DSL, VDSL ...

Exchange Server
gelöst Zertifikatsfehler nach Migration von Exchange 2007 zu Exchange 2013 (2)

Frage von Tommy1983 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 Migration auf Exchange 2016 (3)

Frage von Tommy1983 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (22)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...