Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Autorun von CD und DVD funktioniert nicht

Frage Microsoft

Mitglied: ahstax

ahstax (Level 2) - Jetzt verbinden

28.02.2012 um 10:18 Uhr, 10328 Aufrufe, 4 Kommentare

Beim Einlegen einer CD startet die Autorun-Funktion nicht.

Hallo,

ich habe eine CD, auf der sind folgende Dateien

  • autorun.inf
  • index.html

Inhalt der autorun.inf ist:

01.
[autorun] 
02.
open=index.html
Lege ich die CD ins Laufwerk, fängt sie an zu rotieren, aber die Autostart-Funktion eben nicht. Es wird auch nicht das kleine Fenster "autoplay" mit der suchenden Taschenlampe und dem Fortschrittsbalken angezeigt. Dieses erscheint jedoch, wenn ich eine SD-Karte in den Kartenleser einlege.

Folgende EInstellungen sind mir bekannt, geprüft bzw vorgenommen, der letzte ist bei mir nicht verfügbar:

  • Rechtsklick auf das Laufwerk auf den Register "Eigenschaften" -> Autoplay
  • Autoplay aktivieren mit Tweak UI: AutoPlay-Eigenschaften -> Types.
Aktivieren Sie hier nun mindestens Autoplay für CD und/oder DVD und eventuell noch Autoplay für entfernbare Laufwerke ("Wechseldatenträger").
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom -> Autorun -> 1
  • Systemsteuerung -> Verwaltung -> Dienste -> ShellHardware Erkennung aktivieren
  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095
-und-
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095
Der richtige Wert für diese beiden Registrierungsschlüssel lautet 0x00000095.
  • „gpedit.msc“ (Gruppenrichtlinien) starten. Öffnen Sie unter »Computerkonfiguration« und »Benutzerkonfiguration« jeweils den Zweig »Administrative Vorlagen | System«. Klicken Sie in der rechten Fensterhälfte doppelt auf »Autoplay deaktivieren«, kreuzen Sie »Deaktiviert« an und bestätigen Sie mit »OK«.
  • Systemsteuerung -> System -> Gerätemanager -> "CD-ROM" -> Doppelklicken auf das CD-ROM -> Einstellungen -> „Automatische Benachrichtigung beim Wechsel“ aktivieren


TweakUI zeigt, dass Autoplay für alle Laufwerke aktiviert ist.
Einen Autoplay Handler speziell für ini-Dateien kann ich nicht finden, wüsste aber auch nicht, wie genau der aussehen müsste.


AutoFix.exe von MicroSoft sagt nach Ende des Test, dass ein Fehler aufgetreten sei, der aber nicht zu beheben sei:

AutoFix [V5.2.3790.67]
Time [2012-02-28 10:05:31]
Microsoft Windows Version [5.1 (Service Pack 3) <2600>]

Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
Result [AutoStart Setting]: OK
Result [The Shell Hardware Detection service is running.]: OK

Test [Policies] - Instance [D:\, Drive Type: 5]:
Result [HKCU\...\Policies!NoDrives]: OK {Absent}
Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Absent}
Result [HKLM\...\Policies!NoDrives]: OK {Absent}
Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}
Result [Driver level policies]: OK {
HKLM\...\Services\cdrom!Autorun (Present) <Allows>
HKLM\...\Services\cdrom\Parameters!Autorun (Absent) <Allows>
HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) <Not set>
HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) <Not set> }

Test [Drive Notification] - Instance [D:\, Drive Type: 5]:
Result [Legacy Notification]: OK
Result [AutoPlay V2 Notification]: Problems {
Service (Silent)
Shell (Deaf) }
>> Repair << [Autoplay V2 Event]
Step: No steps to take.
Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.
>> Required action: The wizard found problems but cannot fix them -> None



Client:
Win XP Prof. SP3
Laufwerk:
NEC DVD+-RW ND-3650A

Tja... weiß jemand Rat???
Falls noch Infos fehlen bitte nachhaken...


Grüße aus Stuttgart,
Andreas
Mitglied: DevTig
28.02.2012 um 10:58 Uhr
Hi,

M$ hat hierzu einen netten Artikel Autorun.inf Entries.
Und dann gäbe es noch den hier Enabling and Disabling AutoRun
Vielleicht. helfen die weiter.

Grüße
DevTig

Edit:
Noch was gefunden speziel zu HTML
http://aktuell.de.selfhtml.org/artikel/programmiertechnik/autorun/
Bitte warten ..
Mitglied: ahstax
28.02.2012 um 12:36 Uhr
Unter der Voraussetzung, dass ich das alles richtig verstanden und nachvollzogen habe...:

keine Verbesserung...
Wobei das mit der shelexec.exe schon cleverer ist und übernommen wurde...
Bitte warten ..
Mitglied: cardisch
28.02.2012 um 13:35 Uhr
Mahlzeit,
Hast du noch einen Virenscanner, der den Autostart unterdrückt ?!

Gruß

Carsten
Bitte warten ..
Mitglied: ahstax
29.02.2012 um 10:14 Uhr
Tach...

den hab ich gerade testweise mal deaktiviert...

gleiches Ergebnis. Es öffnet sich noch nicht mal ein Explorerfenster, wie das auf anderen PCs der Fall ist...

Grüße,
Andreas
Bitte warten ..
Ähnliche Inhalte
Verschlüsselung & Zertifikate
gelöst Wie funktioniert ein HTTPS Proxy? Ist das zeitgemäß? (4)

Frage von flyingKangaroo zum Thema Verschlüsselung & Zertifikate ...

Netzwerkgrundlagen
gelöst Frage zu CSMA - CD und Basisbandübertragung (3)

Frage von p.wofl zum Thema Netzwerkgrundlagen ...

IDE & Editoren
gelöst Benutzeranmeldung CMD funktioniert nicht (4)

Frage von Justinpk zum Thema IDE & Editoren ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Firewall
Welche Firewall ? (18)

Frage von Cyberurmel zum Thema Firewall ...

Windows Server
gelöst Einzelnes Windows Update über GPO deinstallieren (16)

Frage von lordofremixes zum Thema Windows Server ...

Windows Server
GPO zum Deinstallieren von Office Update wird nicht ausgeführt (15)

Frage von lordofremixes zum Thema Windows Server ...