Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Barcodes werden falsch erfasst

Frage Hardware Peripheriegeräte

Mitglied: Sauerkrautwurst

Sauerkrautwurst (Level 1) - Jetzt verbinden

17.12.2011 um 16:01 Uhr, 3923 Aufrufe, 4 Kommentare

Hersteller: Datalogic
Typ: Memor
Barcode-Typ: Code 128
Problem tritt bei allen fünf Scannern auf

Hallo zusammen,

geplant ist, Barcodes im Lager auszulesen. Ein PHP-Skript übernimmt dabei den Daten-Transfer/Abgleich mit meiner DB2. Soweit so gut. Alles funktioniert wunderbar, doch:

Wenn Barcodes gescannt werden, erfassen die Scanner den eigentlichen Code auch richtig, doch am Anfang der Zeichenkette wird jedesmal ein "]0C" gesetzt. Als Beispiel also:
Der Inhalt des Barcodes lautet 12345678. Der Scanner erfasst den Barcode aber mit ]0C12345678. Soweit so gut, ich könnte im Skript jeweils vorgeben, die ersten drei Stellen zu streichen, hätte aber lieber eine
richtige Lösung.

Hat da schonmal jemand Erfahrung mit sammeln können oder einen Tipp, wo ich ansetzen könnte?

Danke und Schneematschige Grüße an alle.
Mitglied: StefanKittel
17.12.2011 um 16:49 Uhr
Hallo,
sieht aus wie ein Escape-Code. Also ein Steuerzeichen.
Der Hersteller des Barcode-Lesers, oder stellvertretent die Dokumentation, müßte Dir sagen können was das zu bedeuten hat.
Evtl. auch der Typ des Barcodes.
Stefan
Bitte warten ..
Mitglied: wiesi200
LÖSUNG 17.12.2011, aktualisiert 01.04.2014
Hallo,

bei uns läuft auch so ein Teil.
Sollte man am Scanner einstellen können, ist meiner Meinung nach aber nicht Standard. Setzt ihn eftl. mal auf Werkseinstellung zurück.
Bitte warten ..
Mitglied: Sauerkrautwurst
17.12.2011 um 17:15 Uhr
Danke euch beiden. Ich werd morgen mal schauen, was sich da machen lässt!
Bitte warten ..
Mitglied: Sauerkrautwurst
22.12.2011 um 07:59 Uhr
Die Scanner auf Werkseinstellungen zurück zu setzten hat funktioniert. Danke!
Bitte warten ..
Ähnliche Inhalte
Windows Server
IP-Einstellungen werden falsch angezeigt (5)

Frage von schlumpf90 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Subnetting Musterlösung falsch!? (5)

Frage von pokerfacejb zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...