Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch - Prozent wird zu Tilde

Frage Entwicklung Batch & Shell

Mitglied: Der-Phil

Der-Phil (Level 2) - Jetzt verbinden

07.05.2009, aktualisiert 09:43 Uhr, 6213 Aufrufe, 4 Kommentare

Hallo,

ich habe hier ein eigenartiges Problem auf einem Windows XP SP3 Rechner:

In der Batch Datei soll der Befehl
for /f %i in (adtmp2.txt) do @echo %~i
ausgeführt werden.

An der Konsole kommt jedoch nur ein:
for /f ~i
an.


Ich habe das Problem derzeit grundsätzlich bei Variablen, dass das "%" nicht richtig ausgewertet wird.


Könnt ihr mir einen Tipp geben, woran das liegen kann?

Vielen Dank für euere Hilfe

Gruß
Phil
Mitglied: LotPings
07.05.2009 um 11:44 Uhr
In einer Batchdatei müssen die For Variablen immer doppelte %% Zeichen erhalten

Siehe auch
For /?

Gruß
Bitte warten ..
Mitglied: Der-Phil
07.05.2009 um 16:02 Uhr
...peinlich...

Vielen Dank für die Hilfe.

Phil
Bitte warten ..
Mitglied: Biber
07.05.2009 um 16:16 Uhr
<OT>
Zitat von Der-Phil:
...peinlich...

Ach was, Der_Phil,

noch zwei oder drei Bundestagswahlen und die SPD hat auch zwei Prozentzeichen...

Und denen ist auch nichts peinlich...

Grüße
Biber
</OT>
Bitte warten ..
Mitglied: LotPings
07.05.2009 um 17:07 Uhr
Zitat von Biber:
Und denen ist auch nichts peinlich...
Und dann behaupten sie auch noch: ... und das ist auch gut so.
Bitte warten ..
Ähnliche Inhalte
Viren und Trojaner
Malwarebytes: Fast 40 Prozent der Firmen von Ransomware betroffen

Link von runasservice zum Thema Viren und Trojaner ...

Batch & Shell
Werte vergleichen die nicht 100 Prozent gleich sind (4)

Frage von functionstrut zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Internet
gelöst Jeden morgen Internet-Probleme (56)

Frage von pjrtvly zum Thema Internet ...

Server-Hardware
HP DL380 G7: Booten vom USB via USB 3.1-PCI-e Karte möglich? (24)

Frage von Paderman zum Thema Server-Hardware ...

LAN, WAN, Wireless
gelöst IP Adressen - Modem - Switch - Accesspoint (22)

Frage von teuferl82 zum Thema LAN, WAN, Wireless ...

Windows 7
Bluesreens unternehmensweit (22)

Frage von SYS64738 zum Thema Windows 7 ...