Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch - Prozent wird zu Tilde

Frage Entwicklung Batch & Shell

Mitglied: Der-Phil

Der-Phil (Level 2) - Jetzt verbinden

07.05.2009, aktualisiert 09:43 Uhr, 6159 Aufrufe, 4 Kommentare

Hallo,

ich habe hier ein eigenartiges Problem auf einem Windows XP SP3 Rechner:

In der Batch Datei soll der Befehl
for /f %i in (adtmp2.txt) do @echo %~i
ausgeführt werden.

An der Konsole kommt jedoch nur ein:
for /f ~i
an.


Ich habe das Problem derzeit grundsätzlich bei Variablen, dass das "%" nicht richtig ausgewertet wird.


Könnt ihr mir einen Tipp geben, woran das liegen kann?

Vielen Dank für euere Hilfe

Gruß
Phil
Mitglied: LotPings
07.05.2009 um 11:44 Uhr
In einer Batchdatei müssen die For Variablen immer doppelte %% Zeichen erhalten

Siehe auch
For /?

Gruß
Bitte warten ..
Mitglied: Der-Phil
07.05.2009 um 16:02 Uhr
...peinlich...

Vielen Dank für die Hilfe.

Phil
Bitte warten ..
Mitglied: Biber
07.05.2009 um 16:16 Uhr
<OT>
Zitat von Der-Phil:
...peinlich...

Ach was, Der_Phil,

noch zwei oder drei Bundestagswahlen und die SPD hat auch zwei Prozentzeichen...

Und denen ist auch nichts peinlich...

Grüße
Biber
</OT>
Bitte warten ..
Mitglied: LotPings
07.05.2009 um 17:07 Uhr
Zitat von Biber:
Und denen ist auch nichts peinlich...
Und dann behaupten sie auch noch: ... und das ist auch gut so.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
Batch zum bearbeiten mehrerer CSV (3)

Frage von Matzus87 zum Thema Batch & Shell ...

Batch & Shell
Batch-Variable nach Stichworten aus TXT Datei durchsuchen (3)

Frage von Markus5579 zum Thema Batch & Shell ...

Batch & Shell
Dateinamen nach Zeichnen abschneiden - Batch-Shell (9)

Frage von cberndt zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...