Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Broadcasts über mehrer C-Netze (Router) hinweg (Cisco Devices)

Frage Netzwerke LAN, WAN, Wireless

Mitglied: UsualSuspect

UsualSuspect (Level 1) - Jetzt verbinden

05.10.2009 um 17:46 Uhr, 9041 Aufrufe, 9 Kommentare

Ist es möglich mit einer Broadcast Adresse mehrere Class C Netze über Router hinweg zu erreichen (einschließlich dem eigenen)?

Hi,

ich hoffe die Frage ist nicht ganz so dumm wie sie sich anhört. Aber ich habe folgendes Szenario:

Mehrere Class-C Netze:
192.168.0.0 /24
192.168.1.0 /24
192.168.2.0 /24
192.168.3.0 /24

Vorgaben:
- Ein Client soll einen Broadcast absetzen der alle Netze erricht (einschließlich seinem eigenen).
- Die weiterleitung der all-broadcst-adresse (255.255.255.255) ist nicht aktzeptabel.
- Jedes Netz befindet sich in einem eigenen VLAN 2-X

Was ich bisher getestet habe:

Auf dem C3760´:
ip directet Broadcast auf allen VLAN Interfaces

Ergebniss:
Der Broadcast funktioniert wenn ich das Netz mit der Broadcastadresse betimme z.B:
192.168.1.255 oder 192.168.2.255
Dadurch kann ich jedoch nur gezielt in ein netz Broadcasten und nicht in jedes.
Mein Gedanke war die Addresse 192.168.255.255 zu verwenden.
Da der "Absenderechner" sich in einem Class C Netz befindet interpretiert er die Broadcastadresse 192.168.255.255 jedoch als eine Adresse in einem anderen Netz und schickt diese an seinen Gateway (Catalyst 3760).
Diesem ist das Netz 192.168.255.0 nicht bekannt und verwirft das packet.
Die Einstellung
ip broadcast-address 192.168.255.255
auf den VLAN Interfaces zu konfigurieren hat leider nichts gebracht.

Was habe ich übersehen? Vielen Dank an die Netzer vorweg ;)
Mitglied: dog
05.10.2009 um 22:46 Uhr
Stichwort: ip helper-address
Bitte warten ..
Mitglied: UsualSuspect
06.10.2009 um 11:27 Uhr
Hi,

erstmal danke für das Stichwort und den Link (welchen ich mir gleich zu gemüte führen werde)
ich wollte euch mal "zeigen" was bisher eingerichtet wurde:




interface GigabitEthernet0/1
description DC-1
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/2
description DS-1
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/9
description DS-2
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/10
description DC-2
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description XXXXX
ip address 192.168.0.250 255.255.255.0
ip broadcast-address 192.168.0.255
ip helper-address 192.168.0.255
ip helper-address 192.168.255.255
ip directed-broadcast
!
interface Vlan3
description YYYYYYY
ip address 192.168.1.250 255.255.255.0
ip broadcast-address 192.168.1.255
ip helper-address 192.168.1.255
ip helper-address 192.168.255.255
ip directed-broadcast
!
ip forward-protocol udp 10003



Mein ziel ist es nun aus einem der Netze UND/ODER aus dem Netz 192.168.3.0 /24 ein UDP Packet mit dst.port 10003 an die 192.168.255.255 zu senden. Dieses Packet soll nun weitergeletet oder geflooted werden an alle Netze 192.168.1.0, 192.168.2.0 UND 192.168.3.0.
In diesem Netz muss das UDP Packet natürlich dst.ip 192.168.1.255 bzw. 192.168.2.255 bzw. 192.168.3.255 bekommen da die Clients es verwerfen und nicht als "für sie bestimmt" ansehen.
Ich gehe bisher davon aus das dafür die konfiguration der
ip broadcast-adresse 192.168.X.255
zuständig ist.
Sprich:

Client:
UDP Packet
dst.ip 192.168.255.255
dst.protokoll 10003

-> Router schickt das packet die interfaces VLAN 2 und VLAN 3
UDP Packet
dst.ip 192.168.1.255
dst.protokoll 10003
UND
UDP Packet
dst.ip 192.168.2.255
dst.protokoll 10003

Wo ist mein Denkfehler bzw. was habe ich falsch verstanden?
Bitte warten ..
Mitglied: aqui
06.10.2009 um 11:43 Uhr
Die Helper Adressen auf die gleichen IP Adressen des VLAN zeigen zu lassen ist doch vollkommener Blödsinn !!
Im eigenen VLAN wird doch so oder so jeder Broadcast an jeden Port geforwardet, das ist ja nun mal Standard bei Broadcast Paketen an das netz oder global Broadcasts. Das kannst du dir mit einem Wireshark Sniffer ja auch problemlos ansehen !!
Vermutlich hast du hier den Sinn oder die Funktion von Broadcast Paketen nicht verstanden oder auch die Beschreibung des ip-helper Kommandos nicht richtig gelesen

Sinnvoll wäre es so:

interface Vlan2
description XXXXX
ip address 192.168.0.250 255.255.255.0
ip helper-address 192.168.1.255
!
interface Vlan3
description YYYYYYY
ip address 192.168.1.250 255.255.255.0
ip helper-address 192.168.0.255

Damit werden alle 192.168.0.0er Broadcasts in das 192.168.1.0er Netz geforwardet und alle 192.168.1.0er Broadcasts in das 192.168.0.0er Netz.
So wird ein Schuh draus !

Bedenke bitte das das nur für bestimmte Broadcast Typen bzw. Ports funktioniert (TFTP, Domain Name System (DNS), Time, NetBIOS, ND, BOOTP or DHCP). Wenn deine Broadcasts dort nicht aufgeführt sind (und das sieht bei Port 10003 ganz danach aus !) musst du sie über das ip forward-protocol udp Kommando entsprechend dem System noch bekanntmachen mit diesem Port !!
Bitte warten ..
Mitglied: UsualSuspect
06.10.2009 um 12:01 Uhr
Hi,

merci erstmal ;)
ich muss zugeben ich habe den IP Helper falsch interpretiert, dachte die Konfiguration innerhalb des interfaces zeigt an welche Adresse die Broadcasts in dieses interface weitergeleitet werden (für DHCP Server z.B.) nicht wohin Broadcasts von diesem Interface kommend weitergeleitet werden sollen...

und siehe da es funktioniert (teilweise ;)

local-broadcasts (192.168.1.255) werden nun an die anderen Netze 192.168.2.255 und 192.168.3.255 weitergeleitet.

Mein Problem ist jedoch das ich gerne Broadcasts (192.168.255.255 Welches ja ein Class-B Broadcast wäre) an alle Netze Weiterleiten möchte.
Ich weiß es klingt unsinnig, ist aber so, da eine Broadcastadresse in einer Datenbank konfiguriert wird auf die alle Clients aus verschiedenen netzten zugreifen.

Was macht also ein Client mit der IP 192.168.1.100 /24?
er will eine IP NAchricht an 192.168.255.255 schicken -> merkt das die Zieladresse nicht in seinem Netz ist (Class B / C) und schickt die Nachricht direkt an seinen Default-Gateway. Innerhalb des IP PAcketes auf Layer 2 steht damit die directe MAC des Routers und nicht mehr FFFF....
Jetzt habe ich gerade (durch dienen link) gelesen das die Ziel.dst MAC-Address immer FFFF... sein muss.

Gibt es also einen weg auf dem Router Ankommende Packete auf einem Interface 192.168.1.0 /24 mit dst.IP 192.168.255.255 an alle Interfaces weiter zuleiten?

Ich hoffe ich konnte mich verständlich ausdrücken :/

Merci nochmal für die bisherige hilfe, hat mir einiges gebracht im verständniss von ip helper!
Bitte warten ..
Mitglied: aqui
06.10.2009 um 14:54 Uhr
.
"...Was macht also ein Client mit der IP 192.168.1.100 /24?...er will eine IP NAchricht an 192.168.255.255 schicken -> "

Wenn er das so machen würde wäre das definitiv ein Bug im TCP IP Stack dieses Rechners !!
Das darf so niemals passieren, denn der Rechner hat ja wie du oben schreibst ganz klar eine 24 Bit Subnetzmaske ! Kein anderer Rechner in diesem Segment würde diese BC Adresse verstehen ! So oder so ist nur die MAC Adresse des Broadcast Pakets relevant in einem IP Segment !
Mit diese Maske darf der Client also folglich niemals Broadcast Pakete an eine Adresse wie 192.168.255.255 senden !!! Er kann immer nur entweder ein Netzwerk Broadcast senden das seiner festgelegten Maske entspricht nämlich 192.168.1.255 oder aber ein All Station Broadcast an die 255.255.255.255 niemals aber an eine nicht konforme Adresse 192.168.255.255. !
In der Beziehung stimmt also schon mal was grundsätzlich nicht bei dir bzw. wäre de facto nicht TCP/IP konform !
Wenn dein Client CIDR Masken supportet (ohne A, B oder C Kategorie), dann könnte er eine 16 Bit Maske haben und dann wäre 192.168.255.255 wieder eine korrekte und gültige Broadcast Adresse in diesem Netz...wohlgemerkt mit 16 Bit Maske !! Niemals aber mit einer 24 Bit Maske !

Nochwas: Broadcasts werden niemals im IP Protokoll an Gateway oder Router Adressen direkt verschickt !!
Sie sind immer nur für das lokale Segment also für die lokale Collision Domain gedacht !
Was du oben beschreibst das Broadcasts an Router gehen ist also ein Märchen und zeugt eher davon das du die ganze Problematik nicht durchschaust.
Im Gegenteil: Router sind ja genau dafür da Brodcast Domains zu segmentieren...der Sinn eines Routers !
Hier solltest du dann mal weiterlesen:
http://de.wikipedia.org/wiki/Broadcast

Deine abschliessende Frage: "...Gibt es also einen weg auf dem Router Ankommende Packete auf einem Interface 192.168.1.0 /24 mit dst.IP 192.168.255.255 an alle Interfaces weiter zuleiten?.." stellt sich also gar nicht erst weil in einem TCP/IP Segment mit einer 24 Bit Maske dieses Broadcast Paket gar nicht erst auftaucht bzw. auftauchen darf !!
Ein Wireshark Sniffertrace sollte dir das auch unmissverständlich aufzeigen !
Bitte warten ..
Mitglied: UsualSuspect
06.10.2009 um 15:43 Uhr
So,

ich geh ungern diskussionen aus dem weg (eigentlich liebe ich Netzwerkdiskussionen), möchte aber verhindern das wir uns hier im kreis drehen. Ich verstehe und verstand von anfang an was du meinst. Es scheitert hier wohl eher an mir dir mitteilen zu können was eigentlich ziel war/ist.

Es gab einmal ein B-Netz 192.168.0.0 /16 mit Software die über Broadcast (eine Fest eingestellte Broadcastadresse 192.168.255.255) Kommuniziert hat. Es wurde beschlossen das Netz in mehrere Class C Netzte zu teilen. Jetzt gab es zwei lösungen.
1. Das Netz so zu Konfigurieren das weiterhin mit der (Broadcast)adresse 192.168.255.255 gearbeitet werden kann oder
2. Die Software umzubauen.

Software ist nicht mein Bier, ich sollte mir eine Netzwerklösung überlegen.
Wenn nun ein Rechner aus dem Class-C Netz ein IP-Packet mit der Zieladresse 192.168.255.255 los schickt geht dies an seinen Default-gateway (Da nicht im selben netz (3tes Oktet usw., denke da sind wir uns einig). Mein vorhaben war nun dem Router klar zu machen das wenn er ein Packet mit der zieladresse 192.168.255.255 bekommt dies an seine, an ihn direkt angeschlossenen Class-C Netzte weiterzuleiten mit der Zieladresse 192.168.X.255. Default wird er das packet verwerfen (Zielnetz nicht erreichbar).

Lassen wir das wort "Broadcast" mal weg (was hier anscheinend zu missverständnissen führt). Lautet die Frage:

Ist es möglich ein Ankommendes IP Packet mit der Zieladresse 192.168.255.255 (Ist in diesem fall ja tatsächlich kein Broadcast da ZielMac adresse die MAC des Routers ist) an sämtliche Class C Netze als Broadcast (in diesemfall tatsächlich Broadcast 192.168.x.255 (MacAdresse FFFF....) zu verteilen die mit 192.168.x.x anfangen.

So, ich hoffe diesmal konnte ich mich deutlich ausdrücken.

Über eine erneute Antwort würde ich mich trotz der kreiseldiskussion freuen.
Bitte warten ..
Mitglied: aqui
09.10.2009 um 11:16 Uhr
OK, verstanden eine Migration !
Vergiss doch einfach mal diese unsäglichen 192.168.x.x Adressen und lass dein 192.168.x.x Netzwerk mit der Broadcast Software genauso wie es ist mit der 16 Bit Maske !
Keep it simple stupid !!

Der RFC 1918 bietet dir (und uns allen) ja noch eine Menge weitere Private IP Netze:
http://de.wikipedia.org/wiki/Private_IP-Adresse

Segmentier dir doch nun deine neuen Netze mit 172er oder 10er Adressen !!!
Dann gehst du der ganzen Problematik mit dem Subnetting der 192.168er Adressen elegant aus dem Wege und kannst deine 192.168.255.255er Brodcast vollkommen problemlos in diese neuen IP Netze mit der IP Helper Funktion verteilen ! Alles ohne Stress und Frickelei !

Hast du über diese einfache und elegante Lösung schon einmal nachgedacht ???
Bitte warten ..
Mitglied: UsualSuspect
13.10.2009 um 12:25 Uhr
Hi,

schön das wir uns endlich einig sind. Leider lässt mir die Vorgabe keinen Spielraum bei der Adressvergabe bzw. Subnetierung. Ich muss mit der bestehenden Subnetierung und Adressen leben.

Danke soweit für die Diskussion und Hilfe bezüglich IP-Helper
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung!

(1)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
DSL, VDSL
gelöst VPN-Probleme (CISCO AnyConnect) in Zusammenhang mit Router "Vodafone EasyBox" (7)

Frage von donnyS73lb zum Thema DSL, VDSL ...

Router & Routing
Problem - Router cisco 2821 hinter Fritzbox mit WLAN (23)

Frage von Cyberurmel zum Thema Router & Routing ...

Router & Routing
VoIP hinter Cisco Router (23)

Frage von PharIT zum Thema Router & Routing ...

Netzwerkmanagement
SSH auf Cisco Router aktivieren, allerdings ohne line vty (8)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...