Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Bugzilla 4.0.1 auf Windows 2008 Server R2 System

Frage Entwicklung Datenbanken

Mitglied: ms1970

ms1970 (Level 1) - Jetzt verbinden

10.09.2013, aktualisiert 03.04.2014, 2685 Aufrufe, 12 Kommentare

Hallo zusammen,

wir benutzen schon seit Jahren Bugzilla, zuerst 3.2 dann 3.6 und seit über einem Jahr 4.0.1.

Es läuft alles wie es sein sollte, nur mittlerweile ist die Datenbank ca. 675 MB groß und Bugzilla wird immer langsamer, wenn ein neuer Bug angelegt wird.

Durchsuchen, neue User anlegen usw. geht von der Geschwindigkeit her, ist okay.

Doch das Anlegen eines neuen Bugs dauert mittlerweile so 8 Sekunden.

Der Server hat 32 GB RAM, 8 Kerne und sollte mehr als ausreichen.

Mit MySql kenne ich mich nicht so gut aus.

Kann man Bugzillia irgendwie tunen? Das man irgendwelche Standardwerte "hoch" setzt oder so?

Es ist die Version "Bugzilla-Setup-4.0.exe". Sie hat mysql 5.1.44

Hat aber die ganze Zeit über auch gereicht. Es gab und gibt keine Probleme, nur die Zeit für einen neuen Bug wird immer länger. Zur Zeit gibt es 8900 Bugs. Ist das viel?

Hier sind eine Daten aus der my.cnf:

[client]
port = 3306
socket = /tmp/mysql.sock

[mysqld]
basedir = C:/Bugzilla/mysql
datadir = C:/Bugzilla/mysql/data
bind-address = 127.0.0.1
port = 3306
socket = /tmp/mysql.sock
skip-external-locking
key_buffer_size = 16M
max_allowed_packet = 8M
table_open_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
log-bin=mysql-bin
binlog_format=mixed
server-id = 1

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

[myisamchk]
key_buffer_size = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

Die Werte sehen im Vergleich zum Arbeitsspeicher (32 GB) so klein aus. Kann man die einfach erhöhen?

Auf dem Server läuft noch ein Windows DNS-Server, eine Filezilla FTP-Server, 2 Tomcat 7 und PostgreSQL 9.1 sowie andere Dienste.

Wenn ich Bugzilla lokal auf meinem PC installiere, läuft er mit der gleichen Datenbank "normal" schnell.

Was könnte dem Bugzilla auf dem Server denn fehlen? Die Auslastung der CPU ist nur so 0-3%, der Arbeitsspeicher hat so 4 GB Verbrauch und die Netzwerkauslastung ist auch kaum der Rede wert.

Vielleicht ist das Problem irgendwas total einfaches? Hat jemand eine Idee?


Vielen Grüße

Maik


Die InnoDB ist nicht aktiviert. Die Einträge sind #deaktiviert
Mitglied: ms1970
10.09.2013 um 09:51 Uhr
Es ist doch eine neuere Version von MySQL: mysql 5.1.44
Ich vermute einfach mal, das es mit der Datenbank zu tun hat.
Bitte warten ..
Mitglied: DerWoWusste
10.09.2013 um 10:01 Uhr
Hi.

8 Kerne, 16 GB, aber was für ein Plattensystem? Wird auch eine Rolle spielen. Kannst mal SSDs testen, falls möglich.
Bitte warten ..
Mitglied: ms1970
10.09.2013 um 10:23 Uhr
Hallo,

hab jetzt mal genau nach gesehen.
Es ist ein Intel Xeon E31275 @ 3.40 GHz
Er hat ein Raid5 mit 3 Festplatten und einenm LSI MegaRAID SAS9260-4i
Und die Kiste hat sogar 32 GB RAM.
Da ist auch noch eine FTP-Server drauf installiert, aber Bugzilla ist auch beim anlegen eines Bugs langsam, wenn kein Up- oder Download statt findet.
Grüße
Maik
Bitte warten ..
Mitglied: DerWoWusste
10.09.2013, aktualisiert um 10:45 Uhr
Tja, das Raid klingt ausreichend. Monitore dennoch mal beim Anlegen die Performance von CPU und Plattensystem. Bringt das keinen Aufschluss, installiere ein nacktes Testsystem/VM und importiere die DB dort zum Gegentest.

Edit: Plattensystem, nicht RAM...
Bitte warten ..
Mitglied: Cthluhu
LÖSUNG 10.09.2013, aktualisiert 03.04.2014
Hi,

Wird eine InnoDB verwendet? Damit hatte ich letztens ein "Problem" mit der Langsamkeit beim Eintragen neuer Zeilen. Da gibts den Parameter
innodb_flush_log_at_trx_commit. Damit kann ma etwas tweaken (wird halt gefährlich bei Stromausfällen).

Mit freundlichen Grüßen

Cthluhu
Bitte warten ..
Mitglied: ms1970
25.06.2014 um 19:11 Uhr
Hallo,

jetzt ist 1/2 Jahr vergangen. Leider hat sich nichts geändert. Bugzilla ist immer noch sehr langsam. ca. 7-8 Sekunden für einen neuen Bug. Alles andere, wie z.B. Benutzer anlegen, Gruppen anlegen, usw. geht ganz normal schnell (1-2 Sekunden).

Die Datenbank ist jetzt 692 MB groß. Bugzilla wird nicht mehr so oft genutzt, deshalb ist es nicht so schnell gewachsen. Sind jetzt 833 Bugs drin, sind ja nicht so viele. Mit MySQL-Administrator hab ich mir die Config angesehen, aber nichts ungewöhnliches gefunden.

Habe auf meinem Arbeitsplatz-PC (Windows 8.1 Pro) die gleiche Installation, doch hier ist Bugzilla normal schnell. Dabei habe ich nur 8 GB RAM und eine normale SATA Platte.

Vermute das es was mit MySQL zu tun hat, aber vielleicht ist es auch was anderes. Der Server steht in einem Rechenzentrum. Ich hatte Bugzilla mal auf einem anderen Server dort installiert und dort war es auch so langsam. Hier im Büro läuft es aber auf jeder "Möhre" ausreichend schnell.

Vielleicht hat ja noch jemand eine Idee?

Ja, InnoDB wird verwendet, aber den Eintrag kann ich nirgendwo finden.

Viele Grüße

Maik
Bitte warten ..
Mitglied: DerWoWusste
26.06.2014 um 07:45 Uhr
Moin Maik.

Vielleicht hat ja noch jemand eine Idee?
Hast Du die "alten" Ideen denn verfolgt? Monitoring gemacht, Ergebnisse?
Bitte warten ..
Mitglied: ms1970
26.06.2014 um 09:54 Uhr
Moin,

der Server ist in 99% zu 99% im Leerlauf Hat also nichts zu tun. Mir fällt gerade noch ein, das dort auf dem Server noch ein Tomcat 7 läuft und PostgreSQL 9.1. Da habe ich aber nichts mit zu tun. Darf ich auch nicht abschalten.
Auf dem Server selbst, ist das Anlegen eines Bugs genauso langsam wie von einem PC von außerhalb. Auch Firefox oder Chrome oder IE, spielt keine Rolle.
Werde Bugzilla mit der Datenbank heute noch mal auf 2 anderen Rechner ausprobieren.
Viele Grüße
Maik
Bitte warten ..
Mitglied: DerWoWusste
26.06.2014 um 10:16 Uhr
Du musst erstmal einen Vergleich nackter Systeme machen.
2008 R2 installieren als VM, nur Bugzilla rauf ->Test. Das wird dann Aufschluss geben.
Bitte warten ..
Mitglied: ms1970
03.07.2014 um 17:45 Uhr
Hab ich gemacht, auf einem neuen virtuellen System ist Bugzilla sogar schneller, wenn das System nur 1 GB hat.
Auf dem Rechner laufen noch soviele andere Dienste, die ständig irgendwas schreiben.
Konnte einen Teil mal abschalten, wurde auch etwas besser aber nicht sehr viel.

Wenn ich mit dem Tool MySQL Administrator die Datenbank ansehe, steht da bei "Dienstverwaltung" "Dienst konfigurieren" unter "Konfigurationsdatei"

C:\Bugzilla\bin\..\mysql\my.cnf

Dieser Pfad ist falsch. Richtig wäre C:\Bugzilla\mysql\my.cnf

Das ist aber bei allen Bugzille - Installationen falsch, aber auf den anderen Servern ist es egal.

Ist das wichtig? Kann ich Bugzilla nicht zwingen, erst mal alles im Arbeitsspeicher zu lassen und dann erst später auf HD zu schreiben?

Viele Grüße
Maik
Bitte warten ..
Mitglied: ms1970
04.07.2014 um 11:54 Uhr
Hallo,
also ich habe den Pfad jetzt geändert. Wie immer hat sich gar nichts getan. Alle Änderunge bewirken nichts.
Nach jeder Änderung habe ich den Dienst angehalten und neu gestartet, damit die Änderungen auch wirksam werden.
Nichts. Immer gleich lahm.
EIn Kollege hatte noch die Idee, Bugzilla und die MySQL Datenbanken in eine RAM-Disk zu verschieben, da sie dort viel schneller geschrieben werden kann.
Bringt gar nichts. Ist so lahm wie eh und je.
Naja. Teste mal weiter.
Viele Güße
Maik
Bitte warten ..
Mitglied: ms1970
29.07.2014 um 10:27 Uhr
Hallo,
denke, das alles ist kein Problem von Bugzilla. In einer virtuellen Maschine mit nur 1 GB RAM läuft Bugzilla ja normal schnell. Es sei denn, die VM ist auf dem gleichen Server wie der langsame Bugzilla. Dann verdoppelt sich Zeit, die es braucht einen Bug zu schreiben.
Wir nutzen Bugzilla jetzt als VM auf einem anderen Server und gut ist.
Viele Grüße
Maik
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
SQL Fehler Beim Installieren von SQL 2008 R2 auf einem Windows 2012 Server (6)

Frage von Sv-Schneider zum Thema Windows Server ...

Windows Server
gelöst Oracle ODBC Treiber in Windows 2008 R2 (3)

Frage von kschi12 zum Thema Windows Server ...

Windows Server
gelöst Windows 2008 R2 Backup Domaincontroller als Primary DC heraufstufen (2)

Frage von adrian138 zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...