Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Charset und Kyrillische Schriftzeichen im IE

Frage Entwicklung PHP

Mitglied: Pathfinder

Pathfinder (Level 1) - Jetzt verbinden

12.02.2006, aktualisiert 16:54 Uhr, 4695 Aufrufe, 2 Kommentare

Trotz define('CHARSET', 'iso-8859-7'); keine Erkennung im IE

Hallo,

ich designe derzeit einen neuen oscommerce shop für einen griechischen Kunden.

Dabei habe ich das Problem, dass die kyrillischen Schriftzeichen im IE nicht automatisch erkannt/angezeigt werden.

In der languages/greek.php habe ich den Charset folgendermaßen definiert:
define('CHARSET', 'iso-8859-7');

Ich habe griechisch auch im IE unter Sprachen mit integriert. Die Auswahl unter Ansicht/Codierung steht auf automatische Auswahl und Westeuropäisch(ISO).
Auch habe ich in den Regions- und Sprachoptionen unter Erweitert für Programme die Unicode nicht unterstützen Griechisch eingestellt.

Ich kann Griechisch schreiben, lesen, Ordner öffnen, die Anzeigen sind alle ok auch bei griechischen Programmen.

Wechsle ich nun aber im shop auf Griechisch, bekomme ich folgende Ausgabe (kleines Beispiel):

ÊáëùóÞñèáôå Guest! Èá èÝëáôå íá åéóÝëèåôå óôï óýóôçìá; ¹ èá ðñïôéìïýóáôå íá äçìéïõñãÞóåôå Ýíáí íÝï ëïãáñéáóìü;

Gehe ich nun im IE auf Ansicht/Codierung und wechsle hier auf Griechisch (ISO) so wird alles normal (leserlich) angezeigt.
Klicke ich auf einen link (z.B. auf ein Produkt) wird die Anzeige wieder wie im Beispiel (ÊáëùóÞñèáôå).

Kann mir hier jemand sagen wo ich was im Code übersehen oder vergessen habe?

Gruss

Pathfinder
Mitglied: heyko
12.02.2006 um 14:13 Uhr
Wenn ich das Problem richtig verstanden habe ist es doch eher etwas für die osCommerce Support Foren oder nicht? Falls nicht du könntest versuchen das Charset per header() zu übertragen damit wirds funktionieren.
Bitte warten ..
Mitglied: Pathfinder
12.02.2006 um 16:54 Uhr
hmm, im oscommerce forum hab ich keine Antwort darauf finden können und bekommen.

Ich habe hier geposted weil der shop auf php und css basiert.

Das mit dem header() werd ich prüfen, danke für den Tipp.

Pathfinder
Bitte warten ..
Ähnliche Inhalte
Microsoft
gelöst Lokale Intranet Site im IE wird nicht über GPO hinzugefügt (1)

Frage von Hanuta zum Thema Microsoft ...

Exchange Server
gelöst OWA funktioniert nur im IE (18)

Frage von ketanest112 zum Thema Exchange Server ...

Administrator.de Feedback
gelöst IE Fehlermeldung und Fehldarstellung des Forums (3)

Frage von H41mSh1C0R zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Installation
Eine etwas (wirklich) speziellere Frage: Windows 10-Installation über (16)

Frage von DerFurrer zum Thema Windows Installation ...

Multimedia & Zubehör
gelöst Iphone 6 prob (12)

Frage von jensgebken zum Thema Multimedia & Zubehör ...

Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (12)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...