Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Datenrettung aus defektem NAS RAID1 (Linux)

Frage Hardware Festplatten, SSD, Raid

Mitglied: Lionheart

Lionheart (Level 1) - Jetzt verbinden

07.11.2014 um 09:35 Uhr, 1946 Aufrufe, 3 Kommentare

Hallo Leute,

ich habe hier ein QNAP TS-209 Pro II NAS in dem zwei Festplatten per RAID1 gespiegelt waren. Eine Festplatte hatte sich leider verabschiedet und beim Neuaufbau des RAID-Spiegel ist ein Fehler aufgetreten. Derzeit habe ich nun noch 1 HDD, auf der die Daten vorhanden sind.

Wenn ich diese HDD alleine ins NAS einbaue, bekomme ich die Dateien per Web-Oberfläche nicht angezeigt. Also habe ich zunächst versucht per FTP zuzugreifen. Leider ohne Erfolge da das FTP-Rootverzeichnis, welches nicht verändert werden kann, leer ist. Danach bin ich per Telnet drauf. Dort konnte ich die Daten per Telnet unter /SHARE/HDC_DATA zumindest sehen, allerdings nicht übertragen.

Offenbar verwendet QNAP ein LINUX Betriebssystem und speichert die Daten in einem EXT3 oder EXT4 Dateisystem ab. Aus diesem Grund habe ich die HDD in einer externen USB-Dockingstation per KNOPPIX Live-CD geladen um die Daten zu retten. Die Festplatte wird erkannt, wenn zunächst auch nur als /DEV/SR0 als Teil eines Linux-Arrays, auf das ich per Explorer nicht zugreifen kann. Nach einer Weile rumprobieren habe ich die HDD als /DEV/SDC gemountet und die Dateien auch unter /DEV/SDC3 angezeigt bekommen. Jetzt habe ich das Problem, dass ich kleinere Dateien (bis ca. 100-200 MB) problemlos auf meine lokale HDD kopieren kann, aber sobald ich größere Dateien (> 1 GB) kopieren möchte, immer EINGABE- / AUSGABEFEHLER erhalte. Ich kann diese Dateien nicht kopieren.

Als letzte Möglichkeit habe ich nun die HDD wieder in das NAS eingebaut und per Winscp eine SSH Verbindung aufgebaut, dort kann ich im Gegensatz zum FTP-Zugriff, in jedes Verzeichnis navigieren. Ich habe dort auch meine Dateien gefunden und bin gerade dabei diese auf meinen PC zu übertragen. Trotz Gigabit LAN ist der Datendurchsatz allerdings mit ca. 1MB/s miserabel. Bei der Datenmenge von knapp 700 GB braucht der Transfer ca. 4 Tage. Es ist eine Lösung, aber gibt es vielleicht noch eine bessere / schnellere als den SSH Datentransfer?

Woran könnten die EINGABE- / AUSGABEFEHLER unter Knoppix liegen? Wenn ich die Daten per SSH übertragen und anschließend auf meinem PC auch verwenden kann, können diese ja nicht "physikalisch" defekt sein.

Habt ihr einen Tipp?

Gruß,
lionheart
Mitglied: Lionheart
07.11.2014 um 13:27 Uhr
Hallo aqui,

danke für deine Hilfe. Ich habe das Problem inzwischen anderweitig gelöst. Ich habe die smb.config des NAS so editiert, dass ich via Samba auf die "verlorenen" Netzfreigaben zugreifen kann. Eigentlich ganz logisch... aber man muss halt erst einmal verstehen wie dieses QNAP OS tickt...

Gruß,
lionheart
Bitte warten ..
Mitglied: aqui
07.11.2014, aktualisiert um 16:37 Uhr
aber man muss halt erst einmal verstehen wie dieses QNAP OS tickt...
Wenn man weiss wie Linux tickt weis man auch wie QNAP und alle anderen NAS ticken
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
SAN, NAS, DAS
NAS RAID5 - RAID0 und Backup (7)

Frage von easy4breezy zum Thema SAN, NAS, DAS ...

Viren und Trojaner
gelöst WHM cPanel Anti Virensoftware für Linux ? (2)

Frage von xpstress zum Thema Viren und Trojaner ...

Datenschutz
NAS aufräumen (1)

Frage von Kizuko zum Thema Datenschutz ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...