Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debain (Raspbian) - Nach Update keine Sonderzeichen mehr im Apache.

Frage Linux Apache Server

Mitglied: Brennerlein

Brennerlein (Level 1) - Jetzt verbinden

19.02.2014 um 09:18 Uhr, 3146 Aufrufe, 6 Kommentare

Guten Morgen!


Ich betreibe einen Raspberry Pi B mit Raspbian (angepasstes Debian) als Betriebssystem. Darauf läuft seit ja 1 Jahr ein Apache für eine Homepage.
Gestern Abend habe ich ein Vollsicherung gefahren und danach mittels
apt-get update
apt-get upgrade
eine Aktualisierung. Als Apache an der Reihe war, fielen mir schon Fehlermeldeungen auf das er den Zeichensatz/spracheinstellngen nicht finden kann und alles auf "latin1" setzt. Ich denke das ist auch der Grund warum die Homepage keine Umlaute und Sonderzeichen mehr anzeigt.

Leider finde ich die genaue Fehlerausgabe nicht mehr in den Logs, aber ich würde dann ggf. heute Abend die Sicherung wieder einspielen und das Update wiederholen um sie zu erzeugen.

Kann man den Schriftsatz wieder herstellen oder muss man bereits beim Update etwas beachten?

Mitglied: orcape
19.02.2014 um 09:30 Uhr
Hi,
ich würde einfach die Sicherung wieder einspielen und das ganze wiederholen.
Es besteht durchaus die Möglichkeit, das er einfach beim ziehen des richtigen Zeichensatzes vom Server Probleme mit der Verbindung hatte.
Woher und wieso kannst Du jetzt sowieso nicht mehr nachvollziehen.
Dann wird nach einer gewissen Wartezeit, das Paket einfach übersprungen und das upgrade verläuft weiter.
Ein erneutes apt-get update / apt-get upgrade würde ich aber vorher trotzdem noch mal versuchen.
Im Falle eines ausgelassenen Paketes würde das dann automatisch nachinstalliert werden.
Gruß orcape
Bitte warten ..
Mitglied: Brennerlein
19.02.2014 um 09:39 Uhr
Das erneute ausführen hat leider nichts gebracht:

01.
 apt-get update 
02.
OK   http://ftp.de.debian.org wheezy Release.gpg 
03.
OK   http://ftp.de.debian.org wheezy Release 
04.
OK   http://archive.raspberrypi.org wheezy Release.gpg 
05.
OK   http://archive.raspberrypi.org wheezy Release 
06.
OK   http://ftp.de.debian.org wheezy/main armel Packages 
07.
OK   http://ftp.de.debian.org wheezy/contrib armel Packages 
08.
OK   http://archive.raspberrypi.org wheezy/main armel Packages 
09.
OK   http://ftp.de.debian.org wheezy/non-free armel Packages 
10.
OK   http://ftp.de.debian.org wheezy/contrib Translation-en 
11.
OK   http://ftp.de.debian.org wheezy/main Translation-de_DE 
12.
OK   http://ftp.de.debian.org wheezy/main Translation-de 
13.
OK   http://ftp.de.debian.org wheezy/main Translation-en 
14.
OK   http://ftp.de.debian.org wheezy/non-free Translation-en 
15.
Ign http://archive.raspberrypi.org wheezy/main Translation-de_DE 
16.
Ign http://archive.raspberrypi.org wheezy/main Translation-de 
17.
Ign http://archive.raspberrypi.org wheezy/main Translation-en 
18.
Paketlisten werden gelesen... Fertig 
19.
 
20.
 
21.
 apt-get upgrade 
22.
Paketlisten werden gelesen... Fertig 
23.
Abhängigkeitsbaum wird aufgebaut. 
24.
Statusinformationen werden eingelesen.... Fertig 
25.
Die folgenden Pakete sind zurückgehalten worden: 
26.
  alsa-base gnome-themes-standard lxde lxsession openssh-client openssh-server scratch wpasupplicant 
27.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 8 nicht aktualisiert.
Bitte warten ..
Mitglied: orcape
19.02.2014 um 10:03 Uhr
Schau Dir das mal an...
http://www.netvision-technik.de/forum/showthread.php?t=5720
...bevor Du das Backup einspielst.
Gruß orcape
Bitte warten ..
Mitglied: Brennerlein
19.02.2014, aktualisiert um 11:15 Uhr
Das hat soweit alles funktioniert, nur geholfen hat es nichts.

Jetzt ist sogar aus dem "ß" ein "ß" geworden.

Vielleiht muss ausser in der php.ini und der charset noch in weiteren als Default "ISO-8859-1" gesetzt werden....
Bitte warten ..
Mitglied: Brennerlein
19.02.2014 um 11:49 Uhr
Habs wieder hinbekommen, allerdings anders.

Ich musste in der /etc/apache2/envvars die auskommentierte Zeile
01.
#. /etc/default/locale
aktivieren
01.
. /etc/default/locale
und Apache neu starten.
Bitte warten ..
Mitglied: aqui
20.02.2014 um 10:30 Uhr
Hängt davon ab was du als Locale eingestellt hast ?? Tips dazu gibts hier:
http://www.administrator.de/contentid/191718
Bitte warten ..
Ähnliche Inhalte
Apache Server
Apache probleme nach update von php 5.3 Debian 6
gelöst Frage von cc-frauensteinApache Server10 Kommentare

Guten tag ich habe ei problem nach update von php 5.3 eines Debian 6 hier mal die Apache error. ...

Linux Netzwerk
Raspbian verweigert WLAN Verbindung nach UMTS Verbindungsaufbau
gelöst Frage von SheogorathLinux Netzwerk10 Kommentare

Moin, ich habe da mal ein unfeines Problem, das scheinbar nicht nur mein Problem ist, aber zu dem ich ...

Linux Desktop
2 USB Geräte bei Raspbian unterschiedlich behandeln
gelöst Frage von chemikusLinux Desktop11 Kommentare

Hallöchen, wir haben hier einen Raspberry Pi im Kiosk-Modus (Firefox-Browser) und 2 Kartenleser. Diese sind per USB angeschlossen und ...

Debian
Debain Problem Bei der Netzwerk Einrichtung (V-Server)
Frage von EricG95Debian4 Kommentare

Guten Tag, Ich habe mir ein v-Server gemietet mit Debian jetzt habe ich das Problem das ich eine Fehler ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 1 StundeWindows 101 Kommentar

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 3 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner2 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Brainstorming, einfachste Option 1 getrenntes LAN (mit WAN zugang)
Frage von 132954LAN, WAN, Wireless13 Kommentare

Hi, folgendes: Wir bekommen eine Glasfaser Leitung, Und das sollte Optional so aussehen: Ein Modem/Router für das WAN, ein ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...