Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DHCP funktioniert bei manchen Rechnern nicht

Frage Microsoft Windows Server

Mitglied: iamnils

iamnils (Level 1) - Jetzt verbinden

01.11.2005, aktualisiert 04.11.2005, 10264 Aufrufe, 10 Kommentare

Hallo zusammen,

habe einen 2003 SBS Prem als DHCP, DNS-Server konfiguriert. Fungiert auch als DC.
Habe alle Clients auf DHCP eingestellt, auf dem Server IP-Reservierungen anhand der MAC eingestellt.

Bei manchen Clients funktioniert die DHCP-Abfrage nun nicht. Zugriff auf das interne Netzwerk ist problemlos möglich, auch ohne Geschwindigkeitsverlust.
Das komische ist, die Rechner die über einen längeren Weg angeschlossen sind machen Probleme, die anderen nicht.

Wie kann ich dieses Problem lösen?

mfg Nils
Mitglied: filippg
01.11.2005 um 22:02 Uhr
Was ist dann der "längere Weg"? Wenn damit eine Strecke mit mehreren Switches gemeint ist: bei manchen Switches kann man das Weiterleiten von DHCP-Paketen gezielt blocken, um eben bestimmte DHCP-Server nur für bestimmte Netzsegmente (genauer: Kollisionsdomänen) einzusetzen.

Filipp
Bitte warten ..
Mitglied: iamnils
01.11.2005 um 22:07 Uhr
Hallo Filipp,

mit längerer Weg ist lediglich die Länge des Kabels gemeint. Es ist ein Gebäude mit 2 Etagen, alle Kabel sind direkt in den Keller geführt, es hängen jeweils zwischen Dose und Switch zwei Patchpanels, eins in jeder Etage, von dort aus wird weiter auf ein Patchpanel im Keller geleitet. Dieses Patchpanel ist mit dem Switch verbunden.

Also, eigentlich ne richtig einfache Konfiguration...

mfg Nils
Bitte warten ..
Mitglied: 13100
02.11.2005 um 06:03 Uhr
wie lange sind diese kabeln (max.) ?
wieviele clients, sollen mittels dhcp versorgt werden ?
die iprange vom dhcpserver is ausreichend dimensioniert ?
Bitte warten ..
Mitglied: 10545
02.11.2005 um 07:28 Uhr
... und noch ne "ganz dumme" Frage:

Läuft auf den betroffenen Clients auch der DHCP-Dienst?

Gruß, Rene
Bitte warten ..
Mitglied: iamnils
02.11.2005 um 08:04 Uhr
Hallo Rene,

naja, auf diese "ganz dumme" Frage bin ich noch nicht gekommen. Der wirft mir immer "Ungültige IP" raus...

Ich werde das mal überprüfen.

Also die Kabellängen sind vielleicht insgesamt max. 35-45m. Cat7. Bis 100m ist ja angeblich Problemlos möglich.

mfg Nils
Bitte warten ..
Mitglied: 10545
02.11.2005 um 08:18 Uhr
Hallo Nils,

>Der wirft mir immer "Ungültige IP" raus...
Wer ist "Der" ? Client oder Server?

Bei einer solchen Meldung rückt aber auch <tt>Angeldust´s</tt> Tipp immer näher
Scheint mir auch ein Problem der DHCP-Konfig zu sein (Range).

Nur zur Info: In welchem Netzwerk-Adressraum (z.B. 192.168.x.x) arbeitet Ihr und wieviele DHCP-Clients sind vorhanden (vergiss auch evtl. Drucker und Perepherie nicht!)?

Gruß, Rene
Bitte warten ..
Mitglied: iamnils
03.11.2005 um 08:48 Uhr
Hallo Rene,

"Der" ist der Client. Arbeitsraum ist 192.168.50.*. DHCP-Clients sind 10 vorhanden. Insgesamt sind ca. 15 Netzwerkgeräte vorhanden. Der DHCP-Adressbereich ist groß genug dimensioniert.

mfg Nils
Bitte warten ..
Mitglied: 10545
04.11.2005 um 08:13 Uhr
Hallo Nils,

trotz CAT7 glaube ich mittlerweile auch an ein Distanz-Problem. Der Zufall der "mehreren" Rechner ist mir zu hoch.

1.
Wie sind die NIC´s eingestellt? AutoSpeed oder fest auf (z.B.) 100 Mbit/s? Möglicherweise gibt es (bei festem Speed) auch hier (aufgrund der Distanz) Probleme?

2.
Der einzig sichere Weg, die Entfernung als "Übeltäter" oder "Unschuldigen" festzulegen:

Schnappe Dir einen Problemrechner, kabele ihn ab und schliesse ihn mal an einem Switch mit "kurzer" (also problemloser) Strecke an. Wenn es nun klappt, ist es ziemlich sicher die Strecke der Verbindung oder:

3.
Laufen alle Problemrechner auf denselben Switch? Möglicherweise hat der auch ´ne Macke ...?

Gruß, Rene
Bitte warten ..
Mitglied: filippg
04.11.2005 um 12:17 Uhr
Noch eine mögliche (zugegebenermassen nicht sehr Wahrscheinliche) Ursache (aber die anderen Vorschläge führten ja anscheinend noch zu keinem Ergebnis): Es sind von diversen Herstellern gefälschte NICs im Umlauf (kann aber auch bei schlampiger Produktion bei Originalen passieren), die dann allesamt die gleiche MAC-Adresse haben. Das führt bei DHCP zwangsläufig zu Problemen... Schau Spasseshalber mal mit "ipconfig /all", ob die Einträge unter "Physikalische Adresse" jeweils unterschiedlich sind.
Zu Rene_Ds letztem Vorschlag: auch bei AutoSpeed werden Rechner und Switch immer 100MBit aushandeln, auch wenn die Leitungsqualität nur 10 zulässt (es wird nicht die real Erreichbare Geschwindigkeit getestet, sondern einfach nach den theoretischen Fähigkeiten der Adapter gegangen), du könntest aber die Karten mal fest auf 10 einstellen. Wenn es allerdings daran läge, würde wohl auch der Zugriff sonst nicht einwandfrei (wie von dir beschrieben) funktionieren.
Bitte warten ..
Mitglied: filippg
04.11.2005 um 12:27 Uhr
Noch eine wirklich gute Idee: schau doch mal mit einem Sniffer (z.B. Packetyzer: http://www.networkchemistry.com/products/packetyzer.php, am besten wohl auf dem Server installieren) was denn da so abgeht. Ich war mal einer defekten DHCP-Implementierung aufgesessen, die einfach jedem Adapter die gleiche Adresse zuweisen wollte...
Und kannst du nochmal die Fehlermeldung posten, die kommt wenn du "ipconfig /renew all" bei einem Client eingibst?

Filipp
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 10
gelöst GPO wird bei manchen Rechnern nicht übernommen (20)

Frage von Hanuta zum Thema Windows 10 ...

LAN, WAN, Wireless
Internetverbindung funktioniert erst nach ipconfig renew (6)

Frage von Joshh1 zum Thema LAN, WAN, Wireless ...

Windows Server
DHCP-Server vor Änderung schützen (1)

Frage von cuilster zum Thema Windows Server ...

Windows Server
gelöst W2008 R2 msiinstaller funktioniert nicht mehr (5)

Frage von Alix zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...