Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DOS Programme unter Vista. Falscher Zeichensatz, wie korrigieren?

Frage Microsoft Windows Vista

Mitglied: stoecklin

stoecklin (Level 1) - Jetzt verbinden

23.02.2007, aktualisiert 18.07.2008, 20437 Aufrufe, 6 Kommentare

Wie kann man unter Vista die Datei autoexec.nt speichern?

Hallo.
Vista verhält sich in einer DOS-Anwendung wie in grauer Vorzeit. Nur US ASCII Zeichen, obwohl Länder- und Tastatureinstellungen stimmen. Bei XP war das kein Problem.

Es braucht offenbar einen Keyboardtreiber und Eintrag in der autoexec.nt.
Ich habe folgende Zeile gefunden: LH KB16 SG,,%SystemRoot%\system32\keyboard.sys, welche ich eintragen soll.

Nun zum Problem: Trotz Adminstrator und 'gezeigten' Rechten kann die Datei nicht gespeichert werden. Kann mir jemand sagen, wie ich das Problem lösen kann?

Danke und Gruss

stoecklin
Mitglied: Chibisuke
11.06.2007 um 12:00 Uhr
Hallo,

als erstes mal vielen Dank für deinen Beitrag, ich hatte nämlich das selbe Problem (Dos-Anwendung unter Vista hat englisches Tastaturlayout) und die Zeile in der autoexec.nt hats beseitigt.

Das Speichern hat in meinem Fall ohne Probleme geklappt. War mit einem Domänenadmin-Account eingeloggt der auch lokale Adminrechte hat. Ich kann mir aber fast denken woran es liegt... Auf meinem Rechner ist die Benutzerkontensteuerung deaktiviert, wenn ich mich nicht irre biegt die standardmäßig alle Änderungsversuche an Systemdateien und -ordnern an andere Stelle um und macht damit ziemliche Probleme.
Wäre einen Versuch wert, abschalten kannst du sie in der Systemsteuerung unter Benutzerkonten -> "Benutzerkontensteuerung ein- oder ausschalten"

MfG
Bitte warten ..
Mitglied: Chibisuke
22.06.2007 um 09:01 Uhr
Kurzer Nachtrag:
Nochmal zu den Schreibrechten. Musste gerade feststellen dass es unter Vista extrem umständlich ist Vollzugriff auf Systemdateien zu kriegen... Erstmal muss man den Besitzer übernehmen, alle Fenster wieder wegklicken, die Eigenschaften erneut aufrufen, und dann kann man sich erst Vollzugriff geben <.<

Und wegen der Zeile für die autoexec.nt, eine Kleinigkeit muss man noch ändern um zu 100% das deutsche Tasta-Layout zu kriegen. Nämlich das SG durch ein GR ersetzen, sonst sind einige Sonderzeichen falsch belegt (z.B. ist das Komma auf dem Nummernblock ein Punkt und ß funktioniert nicht).

MfG
Bitte warten ..
Mitglied: stoecklin
27.06.2007 um 08:46 Uhr
Vielen Dank für die Antwort.

Ich hatte das Problem in der 'Beta-Zeit. Inzwischen ist das System mit einer Final aufgesetzt. Nach etlichen Problemen mit Softwareinstallationen habe ich die 'lästigen' Sicherheitsmeldungen ausgeschaltet und der Domänenuser ist lokaler Admin. Damit geht auch die Speicherung der autoexec.nt einwandfrei. In der Beta waren die Rechte auch so, aber es funktionierte damals nicht.

Gruss stöcklin
Bitte warten ..
Mitglied: Teddy52
23.10.2007 um 20:33 Uhr
Hallo.
Vista verhält sich in einer
DOS-Anwendung wie in grauer Vorzeit. Nur US
ASCII Zeichen, obwohl Länder- und
Tastatureinstellungen stimmen. Bei XP war das
kein Problem.

Es braucht offenbar einen Keyboardtreiber
und Eintrag in der autoexec.nt.
Ich habe folgende Zeile gefunden: LH KB16
SG,,%SystemRoot%\system32\keyboard.sys,
welche ich eintragen soll.

Nun zum Problem: Trotz Adminstrator und
'gezeigten' Rechten kann die Datei
nicht gespeichert werden. Kann mir jemand
sagen, wie ich das Problem lösen kann?

Danke und Gruss

stoecklin


Lieber Peter
autoexec.nt + config.nt aus dem Windows-System32 herauskopieren und dann mit einem Editor bearbeiten und dann mit Administrator-Rechten ins Windows-System32 zurückkopieren!
..oder aber den Editor, wie auch schon bemerkt, mit Administrator-Rechten starten!
herzlich Teddy
Bitte warten ..
Mitglied: bez4bez
27.04.2008 um 10:23 Uhr
Hallo,


muss ich in der config.net auch etwas ändern? Und ist es wichtig wo genau ich das in der Datei ändern?
Änder ich das wie oben beschrieben in der autoexec.nt passiert bei der DOS Anwendung nach wie vor gar nichts, bzw gehe ich davon aus, dass die US ASCII Zeichen sich melden.


Herzlicher Gruß
bez4bez
Bitte warten ..
Mitglied: Pablo77
18.07.2008 um 20:32 Uhr
,


muss ich in der config.net auch etwas ändern? Und ist es wichtig wo genau ich das in der Datei ändern?
Änder ich das wie oben beschrieben in der autoexec.nt passiert bei der DOS Anwendung nach wie vor gar nichts, bzw gehe ich davon aus, dass die US ASCII Zeichen sich melden.


Herzlicher Gruß
bez4bez



Hallo bez4bez

Ja evtl. stelle die Files in der config.nt auf 240 statt wie Standard 40!!!
Bitte warten ..
Ähnliche Inhalte
Mac OS X
Malware startet DoS-Angriffe gegen Macs

Link von transocean zum Thema Mac OS X ...

Hyper-V
gelöst HyperV - ungültige MS-DOS Funktion (14)

Frage von Franz-Josef-II zum Thema Hyper-V ...

Batch & Shell
gelöst Unterdrücken eines DOS Fenster bei Ausführen einer Batchdatei (10)

Frage von Zockervogel zum Thema Batch & Shell ...

Windows Server
gelöst Serverabsturz nach Zugriff auf Programme auf Netzlaufwerk - Fehler 0x0000003b (5)

Frage von heisenberg4 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
Tipps für Router (ca. 100 clients, VPN) (18)

Frage von oel-auge zum Thema Router & Routing ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...