Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Download vom eigenen Server sehr langsam

Frage Internet Server

Mitglied: Fears313

Fears313 (Level 1) - Jetzt verbinden

28.03.2013, aktualisiert 14:08 Uhr, 4807 Aufrufe, 13 Kommentare

Hallo zusammen

Ich habe zuhause einen Ubuntu 12.10 Server. Diesen will ich als Streaming Server verwenden.

Wenn ich nun aber von einem externen Netz aus eine Datei von meinem Server über Port 80 ziehen möchte, lade ich mit knapp 300KByte/s. Downloadspeed ist vom Externen Netz sehr viel höher, z.B. wenn ich bei Chip was runterlade.

Der Upload von meinem Provide würde 7000KBit/s bieten, diesen habe ich auch via Speedtest.net getestet. Es laufen zwar andere Geräte im Netz zuhause aber keine die im Internet etwas machen.

Wenn ich auf dem Ubuntu Server nachschaue, ist der Upload zwischen 5 und 7 am pendeln(ich mach das via tool: nload)

Der Download bleibt aber nach wie vor bei 300-500.

Wisst ihr woran das liegen könnte?

Spezifikationen:

Server: Gigabit Netzwerkkarte
Kabel: Alle Gigabit
Provider: 100'000Kbit/s Download, 7'000Kbit/s Upload
1 Modem/Router vom Provider(Cablecom Schweiz) der direkt an der Dose sitzt, der macht nichts ausser Portforwarding
1 Asus RT-N66U Router auf welchem ich nun zum Testen QOS aktiviert habe und Port 80 mit der Source vom eigenen Server auf höchste Prio gesetzt habe.(Gebe zu da hab ich praktisch keine Ahnung ob das richtig ist, vor QoS wars noch schlimmer)

Habt ihr eine Idee?

Freundliche Grüsse

Fears
Mitglied: ChrisMoltisanti
28.03.2013 um 14:05 Uhr
Hi,

lädst Du sicher nur mit 300Kbit/s oder doch mit 300Kbyte/s?

Grüße
Bitte warten ..
Mitglied: Fears313
28.03.2013 um 14:08 Uhr
Sorry 300Kbyte/s, ich korrigiers gleich.
Bitte warten ..
Mitglied: Fears313
28.03.2013 um 14:13 Uhr
Auf dem Asus RT-N66U Router bin ich jetzt auch gerade am Monitoren, da wird tatsächlich nur mit 300KB/s gesogen ... aber ich frag mich einfach wieso? Also der Ubuntu Server sagt 3Mbit/s, der Router 300KB/s ... wo ist der Fehler?
Bitte warten ..
Mitglied: ChrisMoltisanti
28.03.2013 um 14:13 Uhr
Garantieren die Dir das? Oder sagen die "bis zu"? Kannst Du sehen, mit welcher Geschwindigkeit deren Router sich synchronisert? Wenn ich richtig gerechnet habe, müsstest du derzeit 2400-4000 Kbit/s Uplink haben. Das kann schon mal auch so hinkommen.
Alternativ kannst Du ja mal einen kleinen FTP-Server aufsetzen und damit die Geschwindigkeit testen.
Bitte warten ..
Mitglied: ChrisMoltisanti
28.03.2013 um 14:15 Uhr
Zitat von Fears313:
Auf dem Asus RT-N66U Router bin ich jetzt auch gerade am Monitoren, da wird tatsächlich nur mit 300KB/s gesogen ... aber ich
frag mich einfach wieso? Also der Ubuntu Server sagt 3Mbit/s, der Router 300KB/s ... wo ist der Fehler?

naja ungenauigkeiten in der Umrechnung, ist nicht soooo weit nebeneinader. Evtl geht noch bisschen was verloren.
Bitte warten ..
Mitglied: Fears313
28.03.2013 um 14:24 Uhr
Ich habs gerade getestet:

105.43 Mbps Download
6.27 Mbps Upload

Also ist das Maximum was ich da rausholen kann? Das kann doch irgendwie nicht sein. Ich setzt gleich mal kurz ein FTP Server auf und teste das mal da, aber ich kann mir einfach nicht vorstellen, dass ich von meinem Server nur maximum 500 KB/s runterladen kann...
Bitte warten ..
Mitglied: Lochkartenstanzer
28.03.2013 um 14:42 Uhr
moin,

Irgendwie habe ich Schwierigkeiten mit Deiner Nomenklatur, weil mir nicht ganz klar ist, welches System von wo die Daten zieht.

Ich versuche mal zusammenzufassen, was ich herauslese:

  • Du hast eine leitung mit 100Mbps downklink und 7Mbps uplink?

Das läßt maximale Übertragung von ca. 10MB/s für downloads und 700kB/s für uploads erwarten. In der Realität läuft das darauf hinaus, daß die werte selten erreicht werden, aber man kann abschätzen, was auf keinen fall geht.

  • Du hast bei Dir einen (Ubuntu-)Server in Netz stehen, auf den Du von außerhaltb zugreifst und "nur" 300kB/s erreichst.

Das sieht doch schon ganz gut aus. Du kannst zumindest die Hälfte der Bandbreite des uplinks nutzen. jetzt wäre natürlich die frage, festzustellen, wo der Engpaß sitzt. Du könntest mal einfach im gleichen LAN versuchen zu schauen, auf wlche Werte Du kommst.

lks

PS: Mit was mißt Du die Übertragungsraten. Um einigermaßen verläßliche werrte zu haben, sollte tools wie z.B. netio o.ä. benutzen.
Bitte warten ..
Mitglied: Fears313
28.03.2013 um 14:58 Uhr
Sorry ich bin gerade in der Technik drin und um da wieder korrekte deutsche Sätze zu bauen dauert ein wenig.

Du hast soweit korrekt Zusammengefasst. Ich frage mich einfahc ob 300KB/s reichen um einen Film zu streamen. Wenn der Film sagen wir 1.4GB gross ist und 2h dauert(Ja ich weiss miese Qualität aber irgendwo muss man ja anfangen um die richtige Quali für den Film zu finden) Kann man den Film schauen mit diesem Speed?

Vielen Dank für eure Antworten mir ist schon einiges klar geworden(Umrechnungsfehler usw.)
Bitte warten ..
Mitglied: Ravers
28.03.2013 um 15:12 Uhr
Hi,

learning by doing
Aber beachte: Montag Abend ab 23 Uhr hast du vermutlich weit höheren Upload als Sonntagsnachmittag.

Daher wird ja auch immer "bis zu" verkauft (außer im Business-Bereich wo die Werte dann garantiert werden, Qualität des Netzes meist auch besser)).
Und die max. Raten bekommst du idR. nie!

greetz
Ravers
Bitte warten ..
Mitglied: XenClient
28.03.2013 um 15:17 Uhr
Hey,

das kann ich dir leider nicht Beantworten ob dafür der Speed reicht. Ich würde dir einfach mal Empfehlen das ganze Auszuprobieren. Ich meine die Umgebung steht du musst ja nur einmal nen Film versuchen darüber zu gucken. Es könnte Funktionieren, könnte aber auch gut Ruckeln. Versuch mal (wirklich nur versuchsweise) dein Antiviren Programm zu Deaktivieren, evtl. kommst du auf eine höhere Geschwindigkeit, das ist aber wirklich mit Vorsicht zu genießen.

Gruß XenClient
Bitte warten ..
Mitglied: Lochkartenstanzer
28.03.2013, aktualisiert um 15:21 Uhr
Zitat von Fears313:
wir 1.4GB gross ist und 2h dauert

Da fragen wir Doch einfach Adam Riese:

1,4GB/2h = 1433,6MB/120min = 1468006,4kB/7200s = 1468006,4/7200 kB/s = 203,9kB/s

Du könntest also Glück haben.

lks

PS: Werte auf eine Nachkommastelle gerundet.
Bitte warten ..
Mitglied: Fears313
28.03.2013 um 15:37 Uhr
Das hat mir sehr geholfen, ich wusste nicht, dass es so einfach berechenbar ist. Dann schau ich jetzt einfach, dass ich bei der Qualität so spiele, dass ich da immer einen gewissen Spielraum habe

Kennt sich zufälligerweise jemand mit QoS aus? Ich würde nämlich gerne den Upload reservieren für den Server.

Besten Dank für eure Hilfe
Bitte warten ..
Mitglied: Lochkartenstanzer
28.03.2013 um 18:06 Uhr
Zitat von Fears313:
Das hat mir sehr geholfen, ich wusste nicht, dass es so einfach berechenbar ist. Dann schau ich jetzt einfach, dass ich bei der
Qualität so spiele, dass ich da immer einen gewissen Spielraum habe

Das was ich Dir vorgerechnet habe, ist quasi das "unterste" limit, daß mindestens gehen muß. Durch verschiedene Abhängigkeiten, über die Du nicht einmal die Kontrolle hast, kann die benötigte Bandbreite manchmal deutlich höher sein.

Wenn Du Bandbreite dafür freihalten willst, kannst Du einen Router nehmen, der Traffic-shaping kann. Allerdings schützt Dich das nciht vor engpässen "in der Leitung" zu Client.

lks
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VPN Verbindung zum eigenen Server Langsam?!
gelöst Frage von Motte990Router & Routing12 Kommentare

Guten Morgen liebe Leute, Folgendes Problem habe ich , wen ich eine Verbindung zu unserem Server heratelle klappt das ...

RedHat, CentOS, Fedora
Eigenes Linux - Download
Frage von FM1989RedHat, CentOS, Fedora1 Kommentar

Hallo zusammen, ich habe öfter einmal nachfragen von Leuten bekommen ob ich Ihnen einen lokalen Server zum Üben zur ...

Windows Update
WSUS Update Downloads sehr langsam
gelöst Frage von hannsgmaulwurfWindows Update17 Kommentare

Hallo zusammen. Ich habe hier einen WSUS Server (Version lt. Registry 6.3.9600.17477) auf einem Windwos Server 2012 R2 Standard ...

Server
Download aus einer VM langsam (Virtualbox)
Frage von thepandapiServer2 Kommentare

Guten Morgen alle Zusammen! ich hätte da mal eine Frage. Ich habe auf meinem Server via Virtualbox eine VM ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...