Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Editor mit Umlauten unter Windows 7

Frage Entwicklung Batch & Shell

Mitglied: zensbert

zensbert (Level 1) - Jetzt verbinden

08.03.2010 um 21:09 Uhr, 11356 Aufrufe, 15 Kommentare

Grüß Gott.. So da wär ma wieder.. Da mein XP System die Grätsche gemacht hat, bin ich nu ma auf Seven umgestiegen.. Wollt ich sowieso, kam mir also gelegen.. Nu denn, da ich viel mit Batch-Dateien bastele is mir was gravierendes aufgefallen, und zwar arbeite ich gerne mit dem Editor was das Batchen angeht, UltraEdit und Co. haben zuviel KlimmBimms drumherum, nur wenn ich jetzt mein Batches öffne, sind dort alle "ü" verschwunden, früher in XP waren die im Editor als viereckige Kästchen angezeigt, nu aber sin se weg, kein leerzeichen einfach nix da, interessanter Weise wenn ich aus der batch das Wort "für" lösche (steht nur fr da) muss ich dennoch 3 mal die löschen taste drücken, irgendwie sinse halt doch noch da.. wie krieg ich das hin das ich mit dem Editor wieder ordentlich batchen kann?
Thx for Help,
Thomas
Mitglied: daniel999
08.03.2010 um 22:00 Uhr
Hallo Thomas,

schau mal hier:
http://www.pctipp.ch/praxishilfe/kummerkasten/windowsvista/50377/tastat ...
Habe "kb16 sg" getestet. Funktioniert bei meinem Win7.
Daniel
Bitte warten ..
Mitglied: zensbert
08.03.2010 um 22:20 Uhr
hi, danke für deine hilfe erstmal, ich war wohl undeutlich, ich meine notepad, nicht den dos-editor..
Bitte warten ..
Mitglied: 76109
08.03.2010 um 22:30 Uhr
Hallo chizophren!

Eventuell, nur im Notepad mal die Schriftart wechseln.

Gruß Dieter
Bitte warten ..
Mitglied: kristov
09.03.2010 um 06:56 Uhr
Hallo,

ich arbeite mit [notepad2 und hab umlauttechnisch keine Probleme damit. Man braucht es nicht zu installieren, also ist es schnell mal getestet. Ich mag die Software auch, weil sie ohne KlimmBimms auskommt.

lg,
kristov
Bitte warten ..
Mitglied: zensbert
09.03.2010 um 17:54 Uhr
Halloi,
@Dieter, das habe ich bereits probiert, kein Unterschied..
@kristov, egal ob Notepad2 oder Notepad++, auch dort dasselbe.. System-Einstellung?

Habe 7 Ultimate x64, sofern das was aussmacht..
Wenn ich im Notepad "Unicode-Steuerzeichen anzeigen" im Kontextmenü aktiviere werden die ü´s wenigsten mit einem senkrechten Strich gekennzeichnet..

Das komische ist, dass es nur bei ü´s auftritt, ein Batch-ö wurde bei mir früher so angezeigt ” und jetzt immer noch, ebenso ä´s, nur eben die ü´s sind weg..

Thx so far..
Bitte warten ..
Mitglied: 76109
09.03.2010 um 18:45 Uhr
Hallo chizophren!

HEX 55 6D 6C 61 75 74 65 20 8E 84 99 94 9A 81 0D 0A
DOS U m l a u t e Ä ä Ö ö Ü ü CR LF
WIN U m l a u t e Ž š CR LF

Für das kleine ü (81hex) gibt es leider kein Zeichen. Die Symboltabelle hört bei 80hex auf und geht erst bei 82hex weiter.

Und egal welchen Editor Du verwendest, ist überall der gleiche Mist (Windows 7 Prof)

Gruß Dieter
Bitte warten ..
Mitglied: zensbert
09.03.2010 um 19:16 Uhr
Hmm.. dann nutzt Win7 da was anderes als XP?? is ja Mist.. nicht das Ergebnis was ich mir gewünscht habe, aber is ja kein Wunschkonzert^^ Danke für eure Hilfe.. Wenn jemand noch was einfällt, bitte melden!
Ciao Thomas
Bitte warten ..
Mitglied: daniel999
09.03.2010 um 21:14 Uhr
Hallo, dann schreib doch einfach für ö=oe, ä=ae ... usw.
Bitte warten ..
Mitglied: zensbert
09.03.2010 um 23:11 Uhr
kann man, muss man aber nicht.. sieht halt sch** aus.
Bitte warten ..
Mitglied: daniel999
10.03.2010 um 22:44 Uhr
Hallo, habe noch etwas gefunden.
Prüfe mal ob folgende Werte unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
1252 = c_1252.nls
ACP = 1252
eingestellt sind. Vermute das 1252 fehlt oder eine andere Codepage eingestellt ist.
Hatte bei mir mal 1252 auf c_850.nls geändert und schon fehlen äöü.
Daniel
Bitte warten ..
Mitglied: zensbert
10.03.2010 um 22:50 Uhr
hi..
die werte bei mir sind wie bei dir..
Bitte warten ..
Mitglied: daniel999
10.03.2010 um 23:08 Uhr
verstehe ich nicht, mein notepad zeigt ohne probleme öäü an

teste mal in der dos-box (cmd):
chcp - Zeigt aktuelle DOS-Codepage an, müsste eigentlich 850 sein.
wenn es nicht 850 ist , dann probier mal
chcp 850
danach öäü eingeben (direkt in der dos box), werden diese als öäü angezeigt oder welche Symbole kommen ?
danach das ganze mal mit chcp 1252


Welche Länder und Tastatureinestellungen hast Du?
Bitte warten ..
Mitglied: zensbert
10.03.2010 um 23:19 Uhr
oh du hast mich da wohl nicht ganz verstanden, tippe ich ein ö dann kommt ein ö... nur is ein dos-batch-ö was man mit dem windows notepad schreibt ein quaderförmiges symbol (unter xp zumindest) bei seven ist da einfach nix, wahrsch. hat didi da recht... is bei mir alles auf deutsch natürlich...
Bitte warten ..
Mitglied: daniel999
11.03.2010 um 01:36 Uhr
so versuche mal noch folgendes
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
1252 = c_850.nls
Dann siehst Du die Umlaute im Notepad zwar nicht aber die Batch-Ausgabe funktioniert.

Eine einfachere Lösung wäre gewesen die Codepage in der Batchdatei mit "chcp 850" umzustellen, aber leider ignoriert Windows diese Einstellung. Komischerweise funktioniert "chcp 850" als auch der alte Befehl "mode con cp select=850" in der dos-box.
Warum kann ich mir nicht erklären.
Bitte warten ..
Mitglied: rockopa
22.07.2010 um 11:30 Uhr
Hallo zensbert
Du kannst in ultraedit einfach unter Ansicht->OEM-Zeichensatz, einen Haken setzen, dann klappt's auch mit dem ü...
Bitte warten ..
Ähnliche Inhalte
Drucker und Scanner
Windows 7 druckt nur über Editor
Frage von 94erBromDrucker und Scanner6 Kommentare

Hallo zusammen. Folgendes Problem: Auf einem Windows 7 Rechner kann nur noch aus dem Editor heraus gedruckt werden. Selbst ...

Batch & Shell
Altebekanntes Batch umlaute Problem (txt editor)
Frage von RitriviaBatch & Shell2 Kommentare

Hallo ich will eine Batch Datei schreiben in der er prüfen soll welcher Ordner vorhanden ist und dann in ...

PHP
PHP 7 und LDAP mit Umlauten
gelöst Frage von wiesi200PHP3 Kommentare

Hallo, ich bastle für unsere Firma an einer kleinen Webseite die Daten aus unserem ERP System anzeigen kann. Zur Umgebung CentOS 7 ...

Windows 7
Windows Zwischenablage vergisst deutsche Umlaute ( Windows 7 x64 )
gelöst Frage von DERMOLCHWindows 719 Kommentare

Moin Kollegen, wir haben hier ein schwer nachvollziehbares Problem, vielleicht ist es dem Einen oder Anderen auch schonmal unter ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 1 TagHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 1 TagMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 1 TagSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Windows Server
Windows Store Apps
gelöst Frage von PeterleBWindows Server11 Kommentare

Gibt es einen Weg, auf Windows Server 2016 Windows Store Apps wie zum Beispiel die HP Smart App zu ...

Microsoft Office
Outlook Cache Mode Frage
Frage von GwaihirMicrosoft Office11 Kommentare

Hallo zusammen, bin gerade neu in der Firma und lerne hier einige neue Dinge kennen. Zum Beispiel, dass die ...

Microsoft
Erfahrungen mit Webcam over RDP gesucht
Frage von DerWoWussteMicrosoft10 Kommentare

Moin Kollegen. Bekanntlich kann man Webcams nur mit Drittanbietersoftware in RDP reinschleifen. Was nutzt Ihr dazu? Wie stabil funktioniert ...