Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Eigenes ADM zum festlegen des Standardbrowsers klappt nicht

Frage Microsoft Windows Server

Mitglied: DocuSnap-Dude

DocuSnap-Dude (Level 2) - Jetzt verbinden

09.09.2010, aktualisiert 21:36 Uhr, 4890 Aufrufe, 6 Kommentare

ADM selbst gebaut nur leider ändern sich die Regwerte nicht....

Hallo,

ich hab mich jetzt mal daran gemacht un ein ADM gebaut, um den Standardbrowser auf Userebene per Gruppemnrichtline festzulegen. Nur leider hab ich noch irgendeinen fehler --> die Registrywerte welche ich setze ändern sich nicht :-S

01.
Class User 
02.
	Category "MyOwnSettings "Standard Browser Definition" 
03.
			POLICY "HTM-Files: Define Standard Browser" 
04.
				KEYNAME "Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.htm\UserChoice" 
05.
					EXPLAIN "Choose Standard Browser for HTM-Files" 
06.
						PART "HTM-Files" DROPDOWNLIST  REQUIRED 
07.
							VALUENAME "Progid" 
08.
								ITEMLIST 
09.
									NAME "Firefox"       			VALUE "FirefoxHTML" 
10.
									NAME "Internet Explorer"       	VALUE "IE.AssocFile.HTM" 
11.
								END ITEMLIST 
12.
						END PART 
13.
			END POLICY 
14.
			 
15.
			POLICY "HTML-Files: Define Standard Browser" 
16.
				KEYNAME "Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.html\UserChoice" 
17.
					EXPLAIN "Choose Standard Browser for HTML-Files" 
18.
						PART "HTML-Files" DROPDOWNLIST  REQUIRED 
19.
							VALUENAME "Progid" 
20.
								ITEMLIST 
21.
									NAME "Firefox"       			VALUE "FirefoxHTML" 
22.
									NAME "Internet Explorer"       	VALUE "IE.AssocFile.HTM" 
23.
								END ITEMLIST 
24.
						END PART 
25.
			END POLICY 
26.
 
27.
			POLICY "FTP-Filepaths: Define Standard Browser" 
28.
				KEYNAME "Software\Microsoft\Windows\Shell\Associations\UrlAssociations\ftp\UserChoice" 
29.
					EXPLAIN "Choose Standard Browser FTP-File paths" 
30.
						PART "FTP-File paths" DROPDOWNLIST  REQUIRED 
31.
							VALUENAME "Progid" 
32.
								ITEMLIST 
33.
									NAME "Firefox"       			VALUE "FirefoxURL" 
34.
									NAME "Internet Explorer"       	VALUE "IE.FTP" 
35.
								END ITEMLIST 
36.
						END PART 
37.
			END POLICY 
38.
 
39.
			POLICY "HTTP-Filepaths: Define Standard Browser" 
40.
				KEYNAME "Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice" 
41.
					EXPLAIN "Choose Standard Browser for HTTP-File paths" 
42.
						PART "HTTP-File paths" DROPDOWNLIST  REQUIRED 
43.
							VALUENAME "Progid" 
44.
								ITEMLIST 
45.
									NAME "Firefox"       			VALUE "FirefoxURL" 
46.
									NAME "Internet Explorer"       	VALUE "IE.HTTP" 
47.
								END ITEMLIST 
48.
						END PART 
49.
			END POLICY 
50.
 
51.
			POLICY "HTTPS-Filepaths: Define Standard Browser" 
52.
				KEYNAME "Software\Microsoft\Windows\Shell\Associations\UrlAssociations\https\UserChoice" 
53.
					EXPLAIN "Choose Standard Browser for HTTP-File paths" 
54.
						PART "HTTPS-File paths" DROPDOWNLIST  REQUIRED 
55.
							VALUENAME "Progid" 
56.
								ITEMLIST 
57.
									NAME "Firefox"       			VALUE "FirefoxURL" 
58.
									NAME "Internet Explorer"       	VALUE "IE.HTTPS" 
59.
								END ITEMLIST 
60.
						END PART 
61.
			END POLICY 
62.
		 
63.
		End Category 
64.
	End Category 
65.
 
Jemand eine Idee wo mein Fehler steckt?

Danke!

Frank
Mitglied: 2hard4you
09.09.2010 um 23:29 Uhr
Moin,

ich bin mal frech - es ist Windows - hat mir meine Glaskugel gesagt

aber da beschäftigt M$ x Mitarbeiter, um Windows weiterzuentwickeln - und Du kannst nicht mal Deine Version sagen - das sieht düster aus für Dich ^^

Gruß

24
Bitte warten ..
Mitglied: Pjordorf
10.09.2010 um 00:06 Uhr
Hi,

Version? Warum? Es weiß doch jeder welche hier verwendet wird. Da muss ich 24 schon recht geben

Aber nun weiter zu deinem Problem Frank.

Was passiert wenn du erstmal nur 1 Kategorie und nur 1 Policy und nur 1 Part nimmst? Läuft es dann? Deine ersten beiden Policy sind Identisch. Ist das gewollt? In http://www.gruppenrichtlinien.de/index.html?/adm/OReilly_Uebersetzung.h ... oder http://www.gruppenrichtlinien.de/links.html?74 schon mal geschaut?

Peter
Bitte warten ..
Mitglied: KURR01
10.09.2010 um 07:33 Uhr
Guten Morgen,

ohne den Inhalt näher zu Betrachten ist mir gleich ein Syntaxfehler aufgefallen:

Category "MyOwnSettings "Standard Browser Definition" (3x Anführungszeichen, dies ist soweit ich weiß nicht korrekt)


Gruß
Bitte warten ..
Mitglied: DocuSnap-Dude
10.09.2010 um 08:13 Uhr
Moin,

Step by Step:

2hard4you: WinXp und Win7-clients an win2003-ActiveDirectoryDomain

Pjordorf: ersten beiden Policys nicht ganz identisch weil sich die erst auf den KEYNAME .htm bezieht und die zweite auf .html. Und ja, ist auch bei einzelnen Sektoren so (es ändert sich leider gar nichts. Der link Gruppenrichtlinien hab ich geschaut (nutze ich regelmäßig)

Kurr01: hab ich grad gecheckt; leider war es das auch nicht.

Was ich grad überlege: hab ich grad 'n Blackout oder kann es sein das ich den VALUE nicht einfach so setzen kann; sprich das der Fehler hier liegt:
01.
NAME "Firefox"       			VALUE "FirefoxHTML"
Kann es sein, daß ich da grad irgendwie vergessen habe das ich den Reg_SZ-Wert mit anderem Syntax setzen muss (String-Werte evtl.)?

Danke euch 3en erst mal!

Frank
Bitte warten ..
Mitglied: KURR01
10.09.2010 um 09:17 Uhr
Die zuordnung müsste so passen, wenn nur VALUE angegen wird, wird ein REG_SZ Wert erstellt.

Kannst du nochmals die Registrypfade und Schlüssel prüfen? Ich konnte zumindest bei der Registry von Windows XP den Shlüssel "UserChoice" unter keinem der Punkte finden?!

KURR01
Bitte warten ..
Mitglied: DocuSnap-Dude
10.09.2010 um 19:22 Uhr
So da bin ich nun wieder einen Step weiter gekommen so zwischendurch:

Also beim reinen XP-Client ändern sich diese Dinge hier beim Browserwechsel:
01.
HKLM\SOFTWARE\Classes\.htm\: "htmlfile" 
02.
HKLM\SOFTWARE\Classes\.htm\: "FirefoxHTML" 
03.
 
04.
HKLM\SOFTWARE\Classes\.html\: "htmlfile" 
05.
HKLM\SOFTWARE\Classes\.html\: "FirefoxHTML" 
06.
 
07.
HKLM\SOFTWARE\Classes\ftp\shell\open\command\: ""C:\Program Files\Internet Explorer\IEXPLORE.EXE" %1" 
08.
HKLM\SOFTWARE\Classes\ftp\shell\open\command\: ""C:\Program Files\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1"" 
09.
 
10.
HKLM\SOFTWARE\Classes\ftp\shell\open\ddeexec\: ""%1",,-1,0,,,," 
11.
HKLM\SOFTWARE\Classes\ftp\shell\open\ddeexec\: ""%1",,0,0,,,," 
12.
 
13.
HKLM\SOFTWARE\Classes\ftp\shell\open\ddeexec\Application\: "IExplore" 
14.
HKLM\SOFTWARE\Classes\ftp\shell\open\ddeexec\Application\: "Firefox" 
15.
 
16.
HKLM\SOFTWARE\Classes\HTTP\shell\open\command\: ""C:\Program Files\Internet Explorer\IEXPLORE.EXE" -nohome" 
17.
HKLM\SOFTWARE\Classes\HTTP\shell\open\command\: ""C:\Program Files\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1"" 
18.
 
19.
HKLM\SOFTWARE\Classes\HTTP\shell\open\ddeexec\: ""%1",,-1,0,,,," 
20.
HKLM\SOFTWARE\Classes\HTTP\shell\open\ddeexec\: ""%1",,0,0,,,," 
21.
 
22.
HKLM\SOFTWARE\Classes\HTTP\shell\open\ddeexec\Application\: "IExplore" 
23.
HKLM\SOFTWARE\Classes\HTTP\shell\open\ddeexec\Application\: "Firefox" 
24.
 
25.
HKLM\SOFTWARE\Classes\https\shell\open\command\: ""C:\Program Files\Internet Explorer\IEXPLORE.EXE" -nohome" 
26.
HKLM\SOFTWARE\Classes\https\shell\open\command\: ""C:\Program Files\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1"" 
27.
 
28.
HKLM\SOFTWARE\Classes\https\shell\open\ddeexec\: ""%1",,-1,0,,,," 
29.
HKLM\SOFTWARE\Classes\https\shell\open\ddeexec\: ""%1",,0,0,,,," 
30.
 
31.
HKLM\SOFTWARE\Classes\https\shell\open\ddeexec\Application\: "IExplore" 
32.
HKLM\SOFTWARE\Classes\https\shell\open\ddeexec\Application\: "Firefox" 
33.
 
34.
HKLM\SOFTWARE\Clients\StartMenuInternet\: "IEXPLORE.EXE" 
35.
HKLM\SOFTWARE\Clients\StartMenuInternet\: "FIREFOX.EXE"
Daraus werd ich nun mal weiter machen und meine ADM neu bauen. Posting folgt....

Generell hab ich da noch ("DerWoWusste" sei Dank) eine zweite Möglichkeit im Auge an die ich echt vorher nicht gedacht habe. Auch das dann bei Erfolg hier gepostet....
Bitte warten ..
Ähnliche Inhalte
Windows 7
FrontMotion 35.0.1 Fehler in den ADMs?!?
gelöst Frage von Jamaika23Windows 72 Kommentare

Hallo Leute, hat jemand den FrontMotion 35.0.1 per MSI ausgerollt und auch Probleme mit den ADM-Einstellungen? Aktuell wird leider ...

Windows XP
ADM Import unter Windows XP
gelöst Frage von timbowWindows XP4 Kommentare

Hallo, ich habe von meinen Vorgesetzten die Anweisung bekommen, ein paar Makroeinstellungen für die Office Produkte in unserem Haus ...

DNS
DNS Anfänger Frage . Zugriff vom Internen Netz auf eigene Website klappt nicht
gelöst Frage von OSelbeckDNS14 Kommentare

Mehrer VM´s im Netz, alle haben den DC als DNS, nur der DC die Firewall. Zugriff auf eigene Website ...

Batch & Shell
Batch: Benutzerumgebungsvariablen festlegen
Frage von xneb20Batch & Shell1 Kommentar

Hallo, ich brauche eine Batch für das festlegen einiger Umgebungsvariablen. Allerdings sollen diese nach Eingabe des Benutzers festgelegt werden. ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 4 StundenWindows 10

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 5 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 19 StundenInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 23 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Windows Server
Anmeldung direkt am DC nicht möglich
Frage von ThomasGrWindows Server16 Kommentare

Hallo, ich habe bei unserem Server 2016 Standard ein Problem. Keine Ahnung wie das auf einmal passiert ist. Ich ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte15 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...