Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel Sverweis in Bedingung

Frage Microsoft Microsoft Office

Mitglied: Peronas

Peronas (Level 1) - Jetzt verbinden

28.01.2013 um 12:09 Uhr, 3867 Aufrufe, 7 Kommentare

Hey Zusammen,

und zwar bin ich zur zeit mit Excel am arbeiten und verzweifel an einer Funktion.

Ich möchte etwas abfragen und gleichzeitig eintragen. Wenn der Wert nach einem SVerweis gefunden wurde, dann soll in eine eigene spalte der wert aus der spalte neben dem Fund des Sverweises angezeigt werden. ist so etwas möglich?

falls möglich, sogar ohne vba?
Mitglied: bastla
28.01.2013 um 12:31 Uhr
Hallo Peronas!
ist so etwas möglich?
Auch wenn ich mir nicht ganz sicher bin, wie ich "Wenn der Wert nach einem SVerweis gefunden wurde" interpretieren soll, würde ich meinen: ja, so etwas ist möglich.

Grüße
bastla
Bitte warten ..
Mitglied: Peronas
28.01.2013 um 12:38 Uhr
Hey Bastla,

soll bedeuten, dass wenn der SVerweis einen Wert gefunden hat, dann soll die Spalte hinter der Zeile des "Fundes" ausgegeben werden
Bitte warten ..
Mitglied: Biber
28.01.2013, aktualisiert um 12:52 Uhr
Moin Peronas,

Zitat von Peronas:
Hey Bastla,

soll bedeuten, dass wenn der SVerweis einen Wert gefunden hat, dann soll die Spalte hinter der Zeile des "Fundes" ausgegeben werden
Das ist eher unkonventionell..
Excel kann eigentlich nichts "hinter der Zeile des Fundes ausgeben", weil hinter der Zeile keine Spalten mehr vorhanden sind. Ist eine der Limitationen in Excel.

Magst du nicht ein etwas konkreteres Szenario skizzieren?
Zum Beispiel "in Tabelle1, A2 steht eine Kundennummer, Wenn die in dem Blatt "Kundendaten", Spalte 2 gefunden wird, dann soll in Blatt1, B2 der Kundenname aus Kundendaten!$C1:C$3000 angezeigt werden"??

Denk dran, es ist Montag selbst für die Geduldigsten.

Grüße
Biber
Bitte warten ..
Mitglied: Peronas
28.01.2013 um 12:58 Uhr
Tut mir leid, bin etwas im Stress, daher immer die kurzen und knappen Antworten.

Folgendes Prinzip steckt dahinter.

In Tabelle1 stehen IP-Adressen, welche mit einer anderen Tabelle (auch IP-Adressen) verglichen werden soll.

SVerweis:
Wenn die IP der Tabelle 1 auch in Tabelle 2 Spalte 3 gefunden wurde,

Unbekannt:
dann soll der Wert aus Tabelle 2 Spalte 4 neben der IP (z.B. dazugehörende DNS) in Tabelle 1 hinter die IP geschrieben werden.

Ich hoffe, dass man es so verstehen kann.
Bitte warten ..
Mitglied: bastla
28.01.2013, aktualisiert um 13:06 Uhr
Hallo Peronas!

Was Du beschreibst ist ja eigentlich das Grundprinzip der "SVERWEIS()"-Funktion - demnach also, wenn Deine IP in der Tabelle 1 in Spalte A (im Beispiel für Zeile 2) steht, in Spalte B die Formel:
=SVERWEIS(A2;Tabelle2!C:D;2;0)
Wenn Du "Tabelle2!C:D" durch einen Bereich ersetzen kannst (und sei es absolut als "Tabelle2!C2:D145") braucht sich Excel nicht mit den ganzen Spalten abzumühen ...

Bei Bedarf lässt sich das natürlich noch behübschen, damit nicht im Fall des Nicht-Findens "#NV" angezeigt wird.

Grüße
bastla
Bitte warten ..
Mitglied: LianenSchwinger
28.01.2013 um 13:06 Uhr
... das geht

(A2) =SVERWEIS(A1;Tabelle2!C:D;2;FALSCH)

Gruß Jörg
Bitte warten ..
Mitglied: Peronas
28.01.2013 um 13:08 Uhr
Ach wunderbar, danke euch ;) Habe das ganze mit dem Spaltenindex verschlafen. ^^

Da merkt man wieder, dass noch Montag ist.

Gruß
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst SVERWEIS in Excel arbeitet nicht wie erwünscht (3)

Frage von NoirDeNoir zum Thema Microsoft Office ...

Microsoft Office
Excel VBA: Tranferieren von Werten aus Quelldatei in die Masterdatei mit SVERWEIS (3)

Frage von peter.schroeder zum Thema Microsoft Office ...

Datenbanken
gelöst SQL max wert in WHERE Bedingung (7)

Frage von StarMann zum Thema Datenbanken ...

Microsoft Office
gelöst Zellen mit vba verketten bis Bedingung eintritt (2)

Frage von hellas zum Thema Microsoft Office ...

Neue Wissensbeiträge
Humor (lol)

Wohnt jemand in Belgien und kann nicht mehr ruhig ausschlafen?

(4)

Information von LordGurke zum Thema Humor (lol) ...

Sicherheits-Tools

Trendmicro OSCE und das Fall Creators Update Win10 RS3

(3)

Information von Henere zum Thema Sicherheits-Tools ...

Microsoft Office

Text in Zahlen umwandeln

Tipp von logische zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Microsoft Office
ICH BIN AM ENDE MEINES IT-WISSENS ANGELANGT!!!! (38)

Frage von 134537 zum Thema Microsoft Office ...

Windows Server
Gruppenrichtlinie greift nicht zu! (24)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (21)

Frage von sunics zum Thema Hosting & Housing ...

Voice over IP
DeutschlandLAN IP Voice Data M Premium, Erfahrung mit Faxgeräte? (16)

Frage von liquidbase zum Thema Voice over IP ...