Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2010 - Split DNS - Zertifikatswarnung

Frage Microsoft Exchange Server

Mitglied: EinsteinJunior

EinsteinJunior (Level 1) - Jetzt verbinden

05.02.2015, aktualisiert 09.02.2015, 2696 Aufrufe, 12 Kommentare

Hallo,

ich habe hier einen Exchange 2010 Server im Einsatz.
Das Zertifikat war zum Erneuern fällig. Da interne Domains nicht mehr in das Zertifikat mit aufgenommen werden können, habe ich Split-DNS konfiguriert und die Exchange Dienste laut Anleitung (Microsoft) umkonfiguriert (ECP, EAS, OABD, OWA, Autodiscover, WebServicesVirtualDirectory). Split-DNS funktioniert.

Nach dem Einspielen des neuen Zertifikates kommt es im Outlook dennoch zu einem Zertifikatsfehler.


Über "E-Mail Autokonfiguration testen" zeigt er mir unter Server immer noch den internen Domainnamen an.
Muss ich hier die E-Mail Konten mit dem externen Servernamen neu einrichten?

Oder was könnte das Problem sein?

1efcfda8a2910991d98fb37ce55c1575 - Klicke auf das Bild, um es zu vergrößern

60c9b088b9e3aa6dd0f324ce1cb2b92c - Klicke auf das Bild, um es zu vergrößern


VG Marko
Mitglied: EinsteinJunior
05.02.2015 um 08:46 Uhr
Habe es getestet. Auch ein Neueinrichten des E-Mail Kontos im Outlook bringt nicht die Lösung. Auch wenn ich den ext. FQDN angebe, wechselt er automatisch zum internen FQDN.

VG Marko
Bitte warten ..
Mitglied: emeriks
05.02.2015, aktualisiert um 10:49 Uhr
Hi,
Da interne Domains nicht mehr in das Zertifikat mit aufgenommen werden können,
Wer sagt denn sowas?

Und - wie ist der Exch denn von extern erreichbar? Über einen TMG?

E.
Bitte warten ..
Mitglied: EinsteinJunior
05.02.2015, aktualisiert um 10:59 Uhr
Interne FQDN (z.B. *.local) können nicht mehr in UCC Zertifikate mit aufgenommen werden.
Wurde mir auch von unserem Zertifikatsanbieter so bestätigt.

Von extern funktioniert alles. Es geht um die interne Anbindung der Outlook Clients. Da greift er immer noch auf den FQDN "server.domain.local" zu, anstatt auf den öffentlichen FQDN.


VG Marko
Bitte warten ..
Mitglied: colinardo
05.02.2015, aktualisiert um 11:31 Uhr
Hallo Marko,
hast du mal den Service Connection Point (SCP) im AD überprüft.
Active Directory Standorte und Dienste starten, dann unter Ansicht Dienstknoten anzeigen aktivieren und hierhin navigieren:
http://theucguy.net/service-connection-point-scp-in/

Und zweitens, habt Ihr einen SRV-Eintrag für Autodiscover in eurem DNS der vielleicht auf den internen Namen zeigt ? Wenn nicht kannst du diesen zusätzlich mal anlegen:
http://stephan-mey.de/autodiscovery-dns-eintrag-srv-erstellen/

Grüße Uwe
Bitte warten ..
Mitglied: EinsteinJunior
05.02.2015, aktualisiert um 13:53 Uhr
Hallo Uwe,

den SCP habe ich überprüft. Der Eintrag "serviceBindingInformation" zeigt auf die richtige externe Domäne.

SVR-Eintrag habe ich angelegt. Leider auch ohne Erfolg.

Wenn ich mit Outlook die "E-Mail Autokonfiguration" teste, zeigt er unter Server immer den lokalen FQDN an.

Hier noch mal ein Screenshot. Vielleicht stimmt da was nicht. Muss der Eintrag bei FQDN auf dem lokalen oder externen zeigen?
5e15b1b8e24b6d20c246d504ddbc5a47 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: colinardo
05.02.2015, aktualisiert um 13:32 Uhr
Zitat von EinsteinJunior:
Hier noch mal ein Screenshot. Vielleicht stimmt da was nicht. Muss der Eintrag bei FQDN auf dem lokalen oder externen zeigen?
Das ist OK so.

Manchmal benötigt es etwas Zeit für die Replikation der Einstellung, ein Reboot sollte das beschleunigen.

Sind Outlook Anywhere URLs konfiguriert ?
http://www.administrator.de/wissen/powershell-funktion-konfigurieren-in ...

Existiert ein DNS Eintrag ala autodiscover.domain.de ?
Bitte warten ..
Mitglied: EinsteinJunior
05.02.2015 um 13:48 Uhr
Outlook Anywhere ist bei uns nicht aktiviert. Müssen die URLs trotzdem konfiguriert werden?

DNS-Eintrag autodiscover.xxxxx.de existiert. nslookup und ping zeigen auf die korrekte interne IP-Adresse.

Habe zwar sämtliche IIS- und Exchange-Dienste bereits neu gestartet, werde aber heute Abend den Server mal komplett neu starten.
Hoffe das bringt was.

VG Marko
Bitte warten ..
Mitglied: colinardo
05.02.2015, aktualisiert um 14:01 Uhr
Müssen die URLs trotzdem konfiguriert werden?
Nur wenn Outlook von extern über RPC o. HTTPs genutzt wird.

Checke mal die RPCClientAccessServer Eigenschaft der Datenbank:
http://anandthearchitect.com/2013/03/25/exchange-server-2010-whats-your ...
http://community.spiceworks.com/topic/331203-exchange-2010-autodiscover ...
Bitte warten ..
Mitglied: EinsteinJunior
05.02.2015 um 14:32 Uhr
Ich glaube du bist auf dem richtigen Weg.
Hier steht noch die interne FQDN drinnen. Leider lässt er mir es aber auf die externe Domain nicht ändern.
ping und nslookup funktionieren auf die externe Domain.

fbe4159b2ccda14857fa0c351930c2b1 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: EinsteinJunior
06.02.2015 um 08:20 Uhr
Hallo Uwe,

dein Tipp hat mich schon ein wenig weiter gebracht. Ich war anscheinend gestern geistig schon im Nirvana und hatte vergessen das "CAS Array" anzulegen.
Unter Server wird jetzt die externe Domain (im Outlook) angezeigt. Das passt. Leider bringt Outlook beim Start immer noch eine Zertifikatswarnung mit der internen FQDN.

Unter Verbindungsstatus ist im Outlook nur noch der externe Domainname zu sehen. Keine Ahnung wo er immer noch auf den internen Namen zugreift.

Vielleicht hat noch jemand einen Tipp.

VG Marko
Bitte warten ..
Mitglied: colinardo
LÖSUNG 06.02.2015, aktualisiert 09.02.2015
Hallo Marko,
Outlook speichert den RPCEndpoint im Profil zwischen. Du musst am besten das Profil komplett löschen und neu erstellen:
The Outlook client (whether Outlook 2003, 2007 or 2010) won’t pick up the change automatically. If you use Outlook 2007 or 2010, you can have the profile updated by making the old RPC endpoint unavailable or by performing profile repair. But Outlook 2003 can’t change the endpoint and doesn’t include a profile repair feature. That forces you to go in and manually change the profile by removing the username, adding it back and then clicking the “Check name” button). This isn’t ideal by itself, and it also involves end users, so you really should create the CAS array beforehand.
Quelle: https://technet.microsoft.com/en-us/magazine/ff626260.aspx

Noch mehr Futter dazu gibt's hier:
http://www.shudnow.net/2010/04/18/creating-databases-and-the-rpcclienta ...

Grüße Uwe
Bitte warten ..
Mitglied: EinsteinJunior
09.02.2015 um 10:27 Uhr
Hallo Uwe,

vielen Dank für die Hilfe.

Bei Outook 2013 war die finale Lösung noch das Profil zu löschen und neu anzulegen.

Jetzt funktioniert es so wie es soll.

VG Marko
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst RU 17 Exchange 2010 . Erfahrungen? (12)

Frage von keine-ahnung zum Thema Exchange Server ...

Windows Server
Exchange 2010 Active Directory und Windows Server 2016 (4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 - Öffentliche Ordner - Kontakte (11)

Frage von 0ber0n zum Thema Exchange Server ...

Exchange Server
Exchange 2010 Probleme - Autodiscover oder noch mehr? (2)

Frage von PowlFruit zum Thema Exchange Server ...

Neue Wissensbeiträge
Administrator.de Feedback

Umgangsformen auf der Seite

(7)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(11)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows Server
Windows Server Komplettspiegelung (13)

Frage von pdiddo zum Thema Windows Server ...

Windows Server
Windows Server 2016 RDS Remoteapp Anzeigefehler (11)

Frage von qlnGenius zum Thema Windows Server ...