Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange Server sendet nicht an 2. MX Record

Frage Microsoft Exchange Server

Mitglied: Suntzus

Suntzus (Level 1) - Jetzt verbinden

18.07.2009, aktualisiert 09:22 Uhr, 5319 Aufrufe, 8 Kommentare

allo Leute,

ich bin einwenig am verzweifeln...

Wir haben einen exchange 2003 auf SBS Basis.

Dieser funktioniert soweit auch wunderbar.

Nun zum Problem:

Wenn ich an eine bestimmte Firma eine E-Mail versende kommt diese leider nie an, da dort das IT Team Greylisting gegen Spam im Einsatz hat. Genauer gesagt wird jeder Mailzustellungsversuch beim ersten Sende Versuch bei denen geblockt und erst der 2. Angenommen. (Halt abwehr gegen Spam)

Nun ist es aber so das, mein Mailserver das erste mal Sendet und natürlich abgeblockt wird. (So soll es ja auch sein) Nun versucht der Server es erneut, aber nicht wie es normal ist das er versucht an einen alternativen MX Record zu senden sondern wieder den ersten.... Und Somit wieder abgeblockt wird. Die Firma hat 3 MX Record einträge mit je unterschiedlicher Priorität 50,100,150... Bei ersten mit der Höchsten wird halt immer abgeblockt und er der 2. lässt die nachricht praktisch durch. Der 3. schein Backup Lösung zu sein...

Nun ja kann ich dem Exchange irgendwie beibringen das er beim wiederholen vom senden den 2. MX benutzen soll??

Wäre cool wenn jemand eine Lösung hätte!!

Schönen gruß Suntzus
Mitglied: HubertN
18.07.2009 um 10:53 Uhr
Moin


Zitat von Suntzus:
(...)
aber nicht wie es normal ist das er versucht an einen alternativen
MX Record zu senden sondern wieder den ersten....

Greylisting setzt selbstversändlich darauf auf, dass die Mail an den gleichen Server noch einmal gesendet wird. Wie sollte das sonst überhaupt funktionieren !?
Greylisting bedeutet ja in der Praxis, dass mein Mailserer die Mail nicht annimmt, sich aber intern sagt "o.k. - wenn der andere Server es innerhalb von einer Zeit x noch einmal versucht, dann nehme ich die Mail an". Das würde wohl kaum gehen, wenn man es gleich über einen anderen Server versucht.
Das dein Server nicht auf den zweiten MX umschaltet ist völlig normal. Der andere Mailserver hat doch geantwortet - ist also erreichbar gewesen.

Zuerst einmal wäre doch überhaupt die Frage, ob der Server die Mail endgültig nicht los wird (bekommst du einen NDR ?)

Wenn ja, dann gibts auch eine ganz einfache Lösung für dein Problem: Frage beim Admin der anderen Firma an, damit er deine Absenderadresse auf die Whitelist setzt.

Gruß

Hubert
Bitte warten ..
Mitglied: Randyman
18.07.2009 um 13:56 Uhr
Hi,

sehe ich genau so wie Hubert. Der zweite MX kommt nur dann zum Einsatz wenn der erste nicht erreichbar wäre. Das Greylisting basiert auf der erneuten Zustellung an den selben Mailserver. Siehe auch

http://de.wikipedia.org/wiki/Greylisting

Gruss
Randy
Bitte warten ..
Mitglied: DerSchorsch
18.07.2009 um 16:09 Uhr
Hallo,

wie die anderen schon geschrieben haben, ist es schon richtig, dass er wieder auf den 1. MX los geht. Allerdings ist Greylisting einEingriff in die SMTP-Kommunikation, auf die ein Exchange manchmal falsch reagiert.

Problembeschreibung und Workaround:
http://blogs.technet.com/dmelanchthon/archive/2007/07/19/probleme-mit-g ...

Hotfix von MS:
http://support.microsoft.com/kb/950757/en-us

Gruß,
Schorsch
Bitte warten ..
Mitglied: Suntzus
19.07.2009 um 18:54 Uhr
Hallo Hubert,

vielen dank für deine Antwort.

Tut mir leid hatte einige wichtigen details vergessen! der Exchange Server sendet die Nachrrichten an unseren SMTP Relay Server (Hexamail) und dieser wiederum schickt dann die Nachrrichten raus. Nachdem Hexmail die 48 versuche durch hat die Mail zuzustellen kommt dann auch eine Unzustellbarkeitsnachrricht an. In den Logs kann man sehen das der Server immer versucht auf den selben Server zu schicken den mit der höchsten Priorität halt. Das scheint ja auch normal zu sein oder?! Nun ist die Frage warum die Mail trotzdem nicht durchkommt.

Hier einen ausszug von dem Admin der Firma, die mich halt darauf gebracht hat das es Geylisting ist:

Die Ursache des Fehlers ist demnach
eindeutig und wie folgt: Ihr Server sendet Mail, wie zunächst jeder Server,
beim ersten Versuch unter Verwendung des sog. MX-Records unseres
DNS-Eintrags bzw. mit Prüfung des ersten von jeweils 3 Schlüsselpaaren. Das
erste Schlüsselpaar ist jedoch auf unserer Seite immer ungültig. Das ist so
gewollt, weil dies ein extrem effektiver Schutz vor Spam ist. Ein nach
Standard konfigurierter sendender Server hat damit aber kein Problem, denn
er versucht dann sofort, das Mail erneut zu senden und nimmt dabei den
zweiten der jeweils drei Schlüssel. Das funktioniert auch bei uns immer
problemlos. Ihr Server ist aber offensichtlich so eingestellt, dass er den
zweiten Sendeversuch gar nicht durchführt und stattdessen sofort einen
Fehler meldet.

Wäre echt Super wenn ihr mir da weiterhelfen könnt!!

Der Hexmail Server sendet aber definitiv die E-Mail neu raus 48 mal das ganze. Hab auch die Zeit von 10 min auf 2 minuten runtergeschraubt. Leider ohne Erfolg...


Mfg Suntzus
Bitte warten ..
Mitglied: HubertN
19.07.2009 um 22:06 Uhr
Schlüssel ? Reden wir hier nicht mehr über eine Standard SMTP-Übetragung ???

So ganz verstehe ich die Ausage des anderen Admin ehrlich gesagt nicht... Effektive Maßnahme gegen Spam, die aber jeder gängige Mailserver umgeht ?! Also irgendie kommt mir das ein wenig spanisch vor...

Gruß

Hubert
Bitte warten ..
Mitglied: Suntzus
20.07.2009 um 09:26 Uhr
Was er mit Schlüsseln meint ist mir auch Rätselhaft. Kann mir nur vorstellen das er mit 3 Schlüsseln die drei MX records meint und das der erste MX halt ins leere läuft.

Das beste ist wohl ich werde das IT Team dort mal anrufen.

Werde euch berichten wie es ausgegangen ist =)

Gruß Suntzus
Bitte warten ..
Mitglied: Suntzus
20.07.2009 um 10:28 Uhr
Hallo Leute,

also ich habe versucht mit dem anderen IT Team zu reden leider mit recht wenig erfolg. Der dafür zuständig ist hatte keine Zeit und wird sich dann in den nächsten Tagen mal melden....

Konnte also nur mit jemanden reden der denke nicht so sehr die Ahnung vond deren Konifg gegen Spam hat. Er meinte halt nur das das erste Schlüsselpaar ungultig ist und der Mailserver beim 2. versuch automatisch den 2. Schlüssel benutzen muss und er damit reinkommt. Was er mit den Schlüsseln meint KA.

Aber mal eine andere Frage. Kann dem Server sagen das er den Backup MX Server ansteuern soll oder geht das sogar per telnet?


Gruß Suntzus
Bitte warten ..
Mitglied: HubertN
23.07.2009 um 12:42 Uhr
Wenn du nicht am Exchange herumbasteln willst, dann kannst du deine DNS-Auflösung so verbiegen, dass der Server gleich den zweiten MX nimmt.

Aber das wäre sicher nur eine temporäre Lösung...

Fassen wir aber doch mal zusammen: Du kannst dir jetzt Gedanken machen, wie du das Problem gelöst bekommst, weil ein anderer Admin irgendetwas an seinem Server herumgebastelt hat...


Gruß

Hubert
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
MX Eintrag für Exchange-Server , habe aber nur feste IP (9)

Frage von Mausbiber zum Thema Exchange Server ...

Windows Server
gelöst Neuer PDC - Exchange Server anpassungen? (6)

Frage von adrian138 zum Thema Windows Server ...

Cloud-Dienste
gelöst Eigener Exchange Server möglich ? In der Cloud ? (4)

Frage von power-user zum Thema Cloud-Dienste ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
RODC über VPN - Verbindung weg (10)

Frage von stefan2k1 zum Thema Windows Server ...