Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

fail2ban not running

Frage Linux

Mitglied: Janni

Janni (Level 2) - Jetzt verbinden

09.07.2009, aktualisiert 12:27 Uhr, 3571 Aufrufe, 1 Kommentar

Moinsen,

seit kurzem läuft fail2ban nicht mehr.....(fail2ban 0.8.3, Ubuntu 9.04 Server mit SSH, Apache, Samba, etc.):

root@nameserver:/etc# init.d/fail2ban start
root@nameserver:/etc# init.d/fail2ban status
    • Status of authentication failure monitor * fail2ban is not running

Die einzige Änderung am System war das Ausführen von apt-get upgrade. Dabei muß irgendwas verändert worden sein, nur kann ich keinem Paket eine Beziehung hierzu zuordnen.
Es scheint als ob er beim Starten keine "Jails" in den Iptables anlegen kann und darum abbricht. Leider gibt kein einziges log-file Hinweise (auch das fail2ban-log als Debug-Stufe nicht)....
Wenn ich in der jail.conf, bzw. jail.local die Jails lösche kann er starten nur ist das ein wenig sinnlos, da er dann nichts in den iptables einträgt.

Hat Jemand Ähnliches beobachtet ?

Danke
Janni

P.S. die findbaren Lösungen wie z.B. Neuinstallation fail2ban, Löschen diverser Ordner (Socket-Ordner, etc.), Änderung auf Python 2.5, etc. brachten keine Lösung.

P.P.S. die jail.local sieht so aus:
01.
# Fail2Ban local configuration file. 
02.
 
03.
[DEFAULT] 
04.
ignoreip = 127.0.0.1 mein IP-Bereich/255.255.255.0 
05.
bantime  = 604800 
06.
findtime = 3600 
07.
maxretry = 3 
08.
 
09.
10.
# JAILS 
11.
12.
[ssh] 
13.
enabled = true 
14.
port	= ssh 
15.
filter	= sshd 
16.
logpath  = /var/log/auth.log 
17.
maxretry = 3 
18.
 
19.
[pam-generic] 
20.
enabled = true 
21.
filter	= pam-generic 
22.
port = all 
23.
banaction = iptables-allports 
24.
port     = anyport 
25.
logpath  = /var/log/auth.log 
26.
maxretry = 3 
27.
 
28.
[ssh-ddos] 
29.
enabled = true 
30.
port    = ssh 
31.
filter  = sshd-ddos 
32.
logpath  = /var/log/auth.log 
33.
maxretry = 3 
34.
 
35.
36.
# HTTP servers 
37.
38.
[apache] 
39.
enabled = true 
40.
port	= http,https 
41.
filter	= apache-auth 
42.
logpath = /var/log/apache*/*error.log 
43.
maxretry = 6
Mitglied: Janni
09.07.2009 um 12:25 Uhr
Was für ein blöder Fehler:

- Anscheinend hat Irgendwas, Irgendwer, ein Angreifer oder einfach die Sonne ... alle Dateien unter action.d gelöscht, das habe ich nur nicht gesehen, da im WinSCP die Ordnerstruktur noch im Cache war ;-(
- erst "fail2ban-client start" hat auf die fehlenden Dateien hingewiesen
- apt-get install fail2ban kopiert die fehlenden Dateien nicht in diesen Ordner, sondern erzeugt nur einen Leeren !
- Dateien manuell eingefügt, jetzt geht es wieder
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(7)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Linux
gelöst Google Chrome startet nicht (12)

Frage von Thomas91 zum Thema Linux ...